Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0045488
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[New POS] Restaurantsmajoralways2020-11-23 18:012021-01-19 17:49
Reportertimothee_catteeuwView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionduplicateFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0045488: 13/11 delivery - Negative quantity

DescriptionAs you see below, when clicking "-" button, that creates a menu with a negative quantity and a negative total amount.

https://drive.google.com/file/d/1NMRBe6842GaqBTTwXH8Caj3nGRXcizvT/view [^]

When clicking "-", that must delete 1 menu.
Steps To Reproducecf. video
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of defect 0045511 closedAugustoMauch 13/11 delivery - Add a menu trough by selecting "+" 

-  Notes
(0124589)
dbaz (developer)
2020-11-24 17:05

According to the specification negative (or to negativize) lines are allowed, as a way of handling returns, or to void previously added lines (by mistake).

This is in the last paragraph of: https://docs.google.com/document/d/1Y5jRURbt92qNzHbSdhTyE3y42ag-yo7673_I-ntg8B8/edit#heading=h.1fajqvej0i8n [^]
(0124679)
guilleaer (manager)
2020-12-01 18:48

This issue was resolved with delivery P1.1

Order line popup is not shown for menus. To remove line swipe is done
(0125645)
AugustoMauch (developer)
2021-01-19 17:49

This is a duplicate of https://issues.openbravo.com/view.php?id=45511, [^] in both cases the problem is that the edit line popover is shown when clicking on a menu ticket line.

That popover should not be displayed, its actions are not supported in ticket menu lines

- Issue History
Date Modified Username Field Change
2020-11-23 18:01 timothee_catteeuw New Issue
2020-11-23 18:01 timothee_catteeuw Assigned To => Retail
2020-11-23 18:01 timothee_catteeuw Triggers an Emergency Pack => No
2020-11-24 17:05 dbaz Note Added: 0124589
2020-12-01 18:48 guilleaer Review Assigned To => guilleaer
2020-12-01 18:48 guilleaer Note Added: 0124679
2020-12-01 18:48 guilleaer Status new => closed
2020-12-01 18:48 guilleaer Resolution open => unable to reproduce
2021-01-18 18:14 guilleaer Assigned To Retail => AugustoMauch
2021-01-18 18:14 guilleaer Status closed => new
2021-01-18 18:14 guilleaer Resolution unable to reproduce => open
2021-01-18 18:14 guilleaer Status new => scheduled
2021-01-19 17:49 AugustoMauch Relationship added duplicate of 0045511
2021-01-19 17:49 AugustoMauch Note Added: 0125645
2021-01-19 17:49 AugustoMauch Status scheduled => closed
2021-01-19 17:49 AugustoMauch Resolution open => duplicate


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker