Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040925
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Analyticsminorhave not tried2019-05-21 08:322019-06-04 08:52
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisione1311ab239eb
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Toalostale
Regression introduced in release
Summary

0040925: Remove unneeded asm-3.2.jar library

DescriptionThe asm-3.2.jar library was included in Analytics because it is a compile dependency of jersey-server-1.11 library[1].

After this changeset[2], the jersey-server library was updated to version 1.19, which does not longer requires the dependency with asm library[3]. This is because the asm classes are repackaged and included inside the jersey-server library itself, under the "jersey.repackaged.org.objectweb.asm" package.

[1] https://mvnrepository.com/artifact/com.sun.jersey/jersey-server/1.11 [^]
[2] https://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/2b218040d291 [^]
[3] https://mvnrepository.com/artifact/com.sun.jersey/jersey-server/1.19 [^]
Steps To Reproduce.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0111942)
hgbot (developer)
2019-05-21 09:06

Repository: erp/pmods/org.openbravo.client.analytics
Changeset: e1311ab239eb2dbf60cf52734c20e90c551345a8
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue May 21 08:36:04 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/e1311ab239eb2dbf60cf52734c20e90c551345a8 [^]

fixes issue 40925: Remove unneeded asm-3.2.jar library

---
M legal/Licensing.txt
R legal/ASM-license.txt
R lib/runtime/asm-3.2.jar
---
(0112362)
alostale (developer)
2019-06-04 08:52

reviewed

- Issue History
Date Modified Username Field Change
2019-05-21 08:32 caristu New Issue
2019-05-21 08:32 caristu Assigned To => caristu
2019-05-21 08:32 caristu Description Updated View Revisions
2019-05-21 08:33 caristu Description Updated View Revisions
2019-05-21 09:06 hgbot Checkin
2019-05-21 09:06 hgbot Note Added: 0111942
2019-05-21 09:06 hgbot Status new => resolved
2019-05-21 09:06 hgbot Resolution open => fixed
2019-05-21 09:06 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/e1311ab239eb2dbf60cf52734c20e90c551345a8 [^]
2019-05-21 10:15 caristu Review Assigned To => alostale
2019-06-04 08:52 alostale Note Added: 0112362
2019-06-04 08:52 alostale Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker