Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040602
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Sessionsmajoralways2019-04-12 09:132019-04-24 16:37
ReporterlmonrealView Statuspublic 
Assigned Torqueralta 
PriorityurgentResolutionfixedFixed in VersionRR19Q3
StatusclosedFix in branchFixed in SCM revisionb744a37e9cd4
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toadrianromero
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040602: Unparseable date: "0NaN-NaN-NaN NaN:NaN:NaN.NaN" error when opening store offline

DescriptionWhen opening the store in offline mode, there is no option to set business date but in the count cash screen the date displayed is "0NaN-NaN-NaN NaN:NaN:NaN.NaN.

After doing some transactions and going back online there is a register in Errors while importing and then all the cash ups go to Errors While Importing.

Error in back office is:

org.codehaus.jettison.json.JSONException: Unparseable date: "0NaN-NaN-NaN NaN:NaN:NaN.NaN"
    at org.openbravo.retail.sessions.OpenSessionPOS.saveRecord(OpenSessionPOS.java:118)
    at org.openbravo.mobile.core.process.DataSynchronizationProcess.saveRecord(DataSynchronizationProcess.java:200)
    at org.openbravo.mobile.core.process.DataSynchronizationProcess.exec(DataSynchronizationProcess.java:155)
    at org.openbravo.mobile.core.process.DataSynchronizationProcess.exec(DataSynchronizationProcess.java:87)
    at org.openbravo.mobile.core.process.MobileImportEntryProcessorRunnable.processEntry(MobileImportEntryProcessorRunnable.java:54)
    at org.openbravo.retail.sessions.OpenSessionPOSEntryProcessor$OpenSessionPOSRunnable.processEntry(OpenSessionPOSEntryProcessor.java:74)
    at org.openbravo.service.importprocess.ImportEntryProcessor$ImportEntryProcessRunnable.doRunCycle(ImportEntryProcessor.java:372)
    at org.openbravo.service.importprocess.ImportEntryProcessor$ImportEntryProcessRunnable.run(ImportEntryProcessor.java:293)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
    at java.lang.Thread.run(Thread.java:748)
Caused by: java.text.ParseException: Unparseable date: "0NaN-NaN-NaN NaN:NaN:NaN.NaN"
    at java.text.DateFormat.parse(DateFormat.java:366)
    at org.openbravo.retail.sessions.OpenSessionPOS.saveRecord(OpenSessionPOS.java:66)
    ... 12 more

Steps To Reproduce
1. Open store from webpos and add business date
2. Do some tickets(return and sale)
2.Do cash up
3. Go to back office and close store (if needed close open tills after closing store)
4. Go offline
5. Log again in offline mode
6. No business date screen is displayed, instead it is the count cash for open till. Add a difference amount.

If you check the date displayed is "NaN-NaN"

(Some times I have to test repeat steps twice in order to get the error)


TagsNo tags attached.
Attached Filespng file icon Screenshot 2019-04-11 18.06.45.png [^] (87,100 bytes) 2019-04-12 09:13


png file icon Screenshot 2019-04-11 18.07.51.png [^] (57,659 bytes) 2019-04-12 09:13


png file icon Errors_wi.png [^] (188,288 bytes) 2019-04-12 09:14

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0039569 closedrqueralta Error Unparseable date "NaN-NaN-0NaN" when the "Enable Close Store process in Web POS" preference is enabled 

-  Notes
(0111207)
hgbot (developer)
2019-04-18 01:11

Repository: erp/pmods/org.openbravo.retail.sessions
Changeset: b744a37e9cd493c10aa0a8beb8f0792d0453f6f4
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Wed Apr 17 18:51:07 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/b744a37e9cd493c10aa0a8beb8f0792d0453f6f4 [^]

Fixed issue 40602: Unparseable date: "0NaN-NaN-NaN NaN:NaN:NaN.NaN" error when
opening store offline

- Business date value sent to back office was seted first with
OB.UTIL.localStorage.getItem('businessdate') instead
OB.POS.modelterminal.get('terminal').poss_businessdate

---
M web/org.openbravo.retail.sessions/js/countcash/countcash-model.js
M web/org.openbravo.retail.sessions/js/countcash/tabcountcash.js
---
(0111288)
adrianromero (manager)
2019-04-24 16:37

Verified

- Issue History
Date Modified Username Field Change
2019-04-12 09:13 lmonreal New Issue
2019-04-12 09:13 lmonreal Assigned To => Retail
2019-04-12 09:13 lmonreal File Added: Screenshot 2019-04-11 18.06.45.png
2019-04-12 09:13 lmonreal Triggers an Emergency Pack => No
2019-04-12 09:13 lmonreal File Added: Screenshot 2019-04-11 18.07.51.png
2019-04-12 09:14 lmonreal File Added: Errors_wi.png
2019-04-12 09:17 lmonreal Steps to Reproduce Updated View Revisions
2019-04-12 09:19 lmonreal Issue Monitored: martinsdan
2019-04-13 00:38 rqueralta Assigned To Retail => rqueralta
2019-04-13 00:39 rqueralta Status new => scheduled
2019-04-18 01:11 hgbot Checkin
2019-04-18 01:11 hgbot Note Added: 0111207
2019-04-18 01:11 hgbot Status scheduled => resolved
2019-04-18 01:11 hgbot Resolution open => fixed
2019-04-18 01:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/b744a37e9cd493c10aa0a8beb8f0792d0453f6f4 [^]
2019-04-24 16:37 adrianromero Review Assigned To => adrianromero
2019-04-24 16:37 adrianromero Note Added: 0111288
2019-04-24 16:37 adrianromero Status resolved => closed
2019-04-24 16:37 adrianromero Fixed in Version => RR19Q3
2019-05-21 16:08 ngarcia Relationship added related to 0039569


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker