Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040093
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Omnichannelminorhave not tried2019-01-31 17:212019-03-05 09:38
ReporterplujanView Statuspublic 
Assigned Toranjith_qualiantech_com 
PrioritynormalResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revision5361c109b40d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Tojorge-garcia
Regression levelPackaging and release
Regression date2018-11-08
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8bb7e3c1aa17 [^]
Triggers an Emergency PackNo
Summary

0040093: [RR19Q1] [OMNI] The "Invoice" checkbox can be visually removed from paid tickets

DescriptionWhen a ticket has been invoiced, a checkbox labelled "Invoice" is shown. For draft tickets, it is possible to click this check to remove it and to add it again using the "Invoice this receipt" menu option.

However, in previous releases, trying to remove the check from a paid ticket generated a pop up error message "This order cannot be edited", while in current release there is no pop up and the check is removed. It is true that the change is simply visual (reloading the same ticket will show the check again)
Steps To Reproduce1. Create a ticket with a line
2. Select the menu option "Invoice this receipt" and pay it by its total amount. Note a check labelled "Invoice" is shown.
3. Go to the Open Receipt menu option and select the ticket to open it
4. Note the "Invoice" checkbox and click it. The checkbox now is not shown. Repeat these steps in 18Q4 and check an error message is shown "This order cannot be edited"
5. Close the ticket and open it again, note the check that is still shown, so the uncheck in step 4 is just visual.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0040224RR19Q1 closedranjith_qualiantech_com [RR19Q1] [OMNI] The "Invoice" checkbox can be visually removed from paid tickets 
blocks defect 0040390 closedRetail [RR19Q1] The "Invoice this receipt" menu option is available for closed tickets 

-  Notes
(0109567)
hgbot (developer)
2019-02-05 09:05

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 262969db0fded50b1bebbbdbcd9ece28fb0e21ea
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Feb 05 13:35:21 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/262969db0fded50b1bebbbdbcd9ece28fb0e21ea [^]

Fixed issue 40093 : Invoice Flag should not be updated when receipt is not editable

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/pointofsale.js
---
(0109568)
hgbot (developer)
2019-02-05 09:05

Repository: tools/automation/pi-mobile
Changeset: 8b45857a09661701c5ba9ecbf607113c6a071b0d
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Feb 05 13:35:35 2019 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/8b45857a09661701c5ba9ecbf607113c6a071b0d [^]

Verifies issue 40093 : Added Automated Test 'I40093_VerifyInvoiceFlagInPaidReceipt'

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/receipts/I40093_VerifyInvoiceFlagInPaidReceipt.java
---
(0109925)
hgbot (developer)
2019-02-19 10:42

Repository: tools/automation/pi-mobile
Changeset: 86bafed98bc23a19a7f42511318eeda3410041b9
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Feb 19 15:12:04 2019 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/86bafed98bc23a19a7f42511318eeda3410041b9 [^]

Fixed Quarantine Failing Omni Prepayment Tests

* Completed Receipt cannot be set as Invoice. So Receipt Invoice is updated before completing the receipt
* Issue was failing due to issue 40093

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/ImmediatePayOpenTicketsDeferredServicePrepayment290.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/ImmediatePayOpenTicketsPrepaymentAmountLayaway280.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/ImmediateServiceAsPerProductUndeliverableProductPrepayment250.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/ImmediateServiceUniqueQuantityUndeliverableProductPrepayment260.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/OMNI060_PayOpenTicketsDeferredServicePrepaymentWithApprovalAfterOrderDelivery.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/OMNI190_PayOpenTicketsDeferredServicePrepaymentWithApprovalAfterDelivery.java
---
(0110137)
ranjith_qualiantech_com (developer)
2019-03-01 08:01

Fix is not correct and it needs to be fixed based on the implementation of prepayments
(0110189)
hgbot (developer)
2019-03-04 14:33

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 972bc7f8ebb5cafd4210cf843df8164807a02468
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Mar 04 19:03:04 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/972bc7f8ebb5cafd4210cf843df8164807a02468 [^]

Related to issue 40093 : Backed out changeset: 262969db0fde

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/pointofsale.js
---
(0110190)
hgbot (developer)
2019-03-04 14:35

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 5361c109b40dc74d0a4fd9fda41868253e307728
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Mar 04 19:05:38 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/5361c109b40dc74d0a4fd9fda41868253e307728 [^]

Fixed issue 40093 : Invoice should not be genereated if it is already generated

* Currently, Invoice can be generated for completed receipt also.
  So if invoice is generated for the order, we should not allow to enable invoice again

---
M src/org/openbravo/retail/posterminal/PaidReceipts.java
M web/org.openbravo.retail.posterminal/js/model/order.js
M web/org.openbravo.retail.posterminal/js/pointofsale/view/pointofsale.js
---
(0110191)
hgbot (developer)
2019-03-04 14:39

Repository: tools/automation/pi-mobile
Changeset: 396eb07542cde1524e83b15eb5f8f8f88f54abd7
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Mar 04 19:03:00 2019 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/396eb07542cde1524e83b15eb5f8f8f88f54abd7 [^]

Related to issue 40093 : Backed out changeset: 86bafed98bc2

Backed out changeset: 1573ea0380ff

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/ImmediatePayOpenTicketsDeferredServicePrepayment290.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/ImmediatePayOpenTicketsPrepaymentAmountLayaway280.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/ImmediateServiceAsPerProductUndeliverableProductPrepayment250.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/ImmediateServiceUniqueQuantityUndeliverableProductPrepayment260.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/OMNI060_PayOpenTicketsDeferredServicePrepaymentWithApprovalAfterOrderDelivery.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/OMNI190_PayOpenTicketsDeferredServicePrepaymentWithApprovalAfterDelivery.java
---
(0110192)
hgbot (developer)
2019-03-04 14:39

Repository: tools/automation/pi-mobile
Changeset: a46f649e3f3703e2f4d88c350fb55081db1a0c58
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Mar 04 19:09:19 2019 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/a46f649e3f3703e2f4d88c350fb55081db1a0c58 [^]

Verifies issue 40093 : Modified Automated Test 'I40093_VerifyInvoiceFlagInPaidReceipt'

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/ImmediatePayOpenTicketsDeferredServicePrepayment290.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/ImmediatePayOpenTicketsPrepaymentAmountLayaway280.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/OMNI060_PayOpenTicketsDeferredServicePrepaymentWithApprovalAfterOrderDelivery.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/OMNI190_PayOpenTicketsDeferredServicePrepaymentWithApprovalAfterDelivery.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/receipts/I40093_VerifyInvoiceFlagInPaidReceipt.java
---
(0110219)
jorge-garcia (developer)
2019-03-05 09:38

Code reviewed and tested

- Issue History
Date Modified Username Field Change
2019-01-31 17:21 plujan New Issue
2019-01-31 17:21 plujan Assigned To => Retail
2019-01-31 17:21 plujan Regression level => Packaging and release
2019-01-31 17:21 plujan Triggers an Emergency Pack => No
2019-02-04 12:50 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2019-02-04 12:50 ranjith_qualiantech_com Status new => scheduled
2019-02-04 13:03 ranjith_qualiantech_com Regression date => 2018-11-08
2019-02-04 13:03 ranjith_qualiantech_com Regression introduced in release => pi
2019-02-04 13:03 ranjith_qualiantech_com Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8bb7e3c1aa17 [^]
2019-02-05 09:05 hgbot Checkin
2019-02-05 09:05 hgbot Note Added: 0109567
2019-02-05 09:05 hgbot Status scheduled => resolved
2019-02-05 09:05 hgbot Resolution open => fixed
2019-02-05 09:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/262969db0fded50b1bebbbdbcd9ece28fb0e21ea [^]
2019-02-05 09:05 hgbot Checkin
2019-02-05 09:05 hgbot Note Added: 0109568
2019-02-15 14:38 marvintm Status resolved => new
2019-02-15 14:38 marvintm Resolution fixed => open
2019-02-15 14:38 marvintm Status new => scheduled
2019-02-15 14:38 marvintm Status scheduled => resolved
2019-02-15 14:38 marvintm Fixed in Version => RR19Q2
2019-02-15 14:38 marvintm Resolution open => fixed
2019-02-19 10:42 hgbot Checkin
2019-02-19 10:42 hgbot Note Added: 0109925
2019-02-28 10:10 jorge-garcia Review Assigned To => jorge-garcia
2019-03-01 08:01 ranjith_qualiantech_com Note Added: 0110137
2019-03-01 08:01 ranjith_qualiantech_com Status resolved => new
2019-03-01 08:01 ranjith_qualiantech_com Resolution fixed => open
2019-03-01 08:01 ranjith_qualiantech_com Fixed in Version RR19Q2 =>
2019-03-01 14:38 ranjith_qualiantech_com Status new => scheduled
2019-03-04 14:33 hgbot Checkin
2019-03-04 14:33 hgbot Note Added: 0110189
2019-03-04 14:35 hgbot Checkin
2019-03-04 14:35 hgbot Note Added: 0110190
2019-03-04 14:35 hgbot Status scheduled => resolved
2019-03-04 14:35 hgbot Resolution open => fixed
2019-03-04 14:35 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/262969db0fded50b1bebbbdbcd9ece28fb0e21ea [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/5361c109b40dc74d0a4fd9fda41868253e307728 [^]
2019-03-04 14:39 hgbot Checkin
2019-03-04 14:39 hgbot Note Added: 0110191
2019-03-04 14:39 hgbot Checkin
2019-03-04 14:39 hgbot Note Added: 0110192
2019-03-05 09:38 jorge-garcia Note Added: 0110219
2019-03-05 09:38 jorge-garcia Status resolved => closed
2019-03-05 09:38 jorge-garcia Fixed in Version => RR19Q2
2019-03-15 10:05 plujan Relationship added blocks 0040390


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker