Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039757
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] I. Performancemajorhave not tried2018-12-04 15:262018-12-12 10:52
ReporterSandrahuguetView Statuspublic 
Assigned ToSandrahuguet 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q3.4
StatusclosedFix in branchFixed in SCM revision19193a2a5b15
ProjectionnoneETAnoneTarget Version3.0PR18Q3.4
OSLinux 64 bitDatabasePostgreSQLJava version7.x
OS VersionOpenbravo Appliance 14.04Database version9.3.xAnt version1.9.x
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039757: It would be nice to have a method to use lock "FOR NO KEY UPDATE"

DescriptionIt would be nice to have a method to use lock "FOR NO KEY UPDATE", because "FOR UPDATE" in PostgreSQL is too aggressive.
Steps To Reproduce- In order to easily simulate the 2 transactions are processed at same time it is necessary to set a break-point just after execution of following code :

financialAccount.setCurrentBalance(financialAccount.getCurrentBalance().subtract(transaction.getDepositAmount()).add(transaction.getPaymentAmount()));

- Go to Payment In and create a payment:
  Organization: F&B España - Region Norte
  Received From: Alimentos y Supermercados, S.A
  Payment Method: Transferencia
  Deposit To: Cuenta de Banco - EUR
  Amount: 100
  In Add details - > Overpayment Action: Leave the credit to be used later
  Done and execution should be stopped in previous break-point

- Open "new incognito window" in Chrome and access
  Go to Payment In and create a new payment:
  Organization: F&B España - Region Norte
  Received From: Restaurantes Luna Llena, S.A.
  Payment Method: Transferencia
  Deposit To: Cuenta de Banco - EUR
  Amount: 200
  Click in add details, the popup does not open, save the header is locked
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0039755 closedSandrahuguet It would be nice to have a method to use lock "FOR NO KEY UPDATE" 

-  Notes
(0108288)
hgbot (developer)
2018-12-05 15:22

Repository: erp/backports/3.0PR18Q3.4
Changeset: 8ee19e974b751b598ca333f763fe623c4b6eb96c
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Wed Dec 05 12:44:44 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR18Q3.4/rev/8ee19e974b751b598ca333f763fe623c4b6eb96c [^]

Fixed issue 39757 added in OBDAL lockForNoKeyUpdate

new lockForNoKeyUpdate method to allow the use "FOR NO KEY UPDATE",
because "FOR UPDATE" in PostgreSQL is too aggressive.

---
M src/org/openbravo/dal/service/OBDal.java
---
(0108303)
hgbot (developer)
2018-12-05 17:50

Repository: erp/backports/3.0PR18Q3.4
Changeset: 850834ffd2286f8383238e66e859608fd57e5c03
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Wed Dec 05 17:17:46 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR18Q3.4/rev/850834ffd2286f8383238e66e859608fd57e5c03 [^]

related to issue 39757 code review changes

Not necessary to return the id. Only creates the lock.
Use createNativeQuery and improve code.

---
M src/org/openbravo/dal/service/OBDal.java
---
(0108307)
Sandrahuguet (developer)
2018-12-05 18:07

author Sandra Huguet <sandra.huguet@openbravo.com>
Wed, 05 Dec 2018 18:04:21 +0100 (2 minutes ago)
changeset 34299 be274de32560
parent 34298 1d4d9b87c8f4
Backed out changeset 850834ffd228

https://code.openbravo.com/erp/backports/3.0PR18Q3.4/rev/be274de32560 [^]
(0108411)
hgbot (developer)
2018-12-11 17:51

Repository: erp/backports/3.0PR18Q3.4
Changeset: 31760ca39b26b98471032f0d1f226e1fa66ae4d8
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Tue Dec 11 17:37:57 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR18Q3.4/rev/31760ca39b26b98471032f0d1f226e1fa66ae4d8 [^]

related to issue 39757 backed out changeset 8ee19e974b75

---
M src/org/openbravo/dal/service/OBDal.java
---
(0108412)
hgbot (developer)
2018-12-11 17:51

Repository: erp/backports/3.0PR18Q3.4
Changeset: 19193a2a5b15681a29f9f6c35b91903f0b8e6024
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Tue Dec 11 17:43:07 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR18Q3.4/rev/19193a2a5b15681a29f9f6c35b91903f0b8e6024 [^]

Fixed issue 39757 change lockForNoKeyUpdate to return the instance with the lock

*Retrieves an object from the database getting a lock "for no key update" for the indicated
object. Change method name, parameters and return.
*Improve and modify the javadoc with the required changes.

---
M src/org/openbravo/dal/service/OBDal.java
---
(0108544)
alostale (developer)
2018-12-12 10:52

reviewed + tested

- Issue History
Date Modified Username Field Change
2018-12-04 15:29 Sandrahuguet Type defect => backport
2018-12-04 15:29 Sandrahuguet Target Version => 3.0PR18Q3.4
2018-12-05 13:21 Sandrahuguet Review Assigned To => alostale
2018-12-05 15:22 hgbot Checkin
2018-12-05 15:22 hgbot Note Added: 0108288
2018-12-05 15:22 hgbot Status scheduled => resolved
2018-12-05 15:22 hgbot Resolution open => fixed
2018-12-05 15:22 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR18Q3.4/rev/8ee19e974b751b598ca333f763fe623c4b6eb96c [^]
2018-12-05 17:50 hgbot Checkin
2018-12-05 17:50 hgbot Note Added: 0108303
2018-12-05 18:07 Sandrahuguet Note Added: 0108307
2018-12-05 18:07 Sandrahuguet Status resolved => new
2018-12-05 18:07 Sandrahuguet Resolution fixed => open
2018-12-11 17:51 hgbot Checkin
2018-12-11 17:51 hgbot Note Added: 0108411
2018-12-11 17:51 hgbot Checkin
2018-12-11 17:51 hgbot Note Added: 0108412
2018-12-11 17:51 hgbot Status new => resolved
2018-12-11 17:51 hgbot Resolution open => fixed
2018-12-11 17:51 hgbot Fixed in SCM revision http://code.openbravo.com/erp/backports/3.0PR18Q3.4/rev/8ee19e974b751b598ca333f763fe623c4b6eb96c [^] => http://code.openbravo.com/erp/backports/3.0PR18Q3.4/rev/19193a2a5b15681a29f9f6c35b91903f0b8e6024 [^]
2018-12-12 10:52 alostale Note Added: 0108544
2018-12-12 10:52 alostale Status resolved => closed
2018-12-12 10:52 alostale Fixed in Version => 3.0PR18Q3.4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker