Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025493
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] E. Translationmajoralways2014-01-16 16:222014-02-13 12:28
ReporteregoitzView Statuspublic 
Assigned Toshankarb 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revisiondd222399853e
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025493: The text on a report of a module not in english can be replaced with a transaltion if the literal is alrady transalted

DescriptionThe text on a report of a module not in english can be replaced with a transaltion if the literal is alrady transalted.
The steps to reproduce describes and example:
Steps To Reproduce-Install the spanish transalation pack
-Define a new module in spanish
-Crea a new jrxml to be assigned to the invoices.
-Define the new report as a template for the document type for invoices.
-Add on the jrxml the literal "Invoice" on a static text (you want to be printed without translate)
-Compile the application with compile.complete
-Restart tomcat
-Check that there is a textinferfaces for your jrmxl file with text Invoices
and that the transalation is for english because the textinterfacs belong to a module defined on spanish.
-Print an invoice
*See that the text "Invoice" is translated to "Factura" but you wanted to print "Invoice"
Proposed SolutionSee the attached file.

The problem was that although the translations where properly ordered on the select, after that a hash map is filled witht the result of the query.
The array with the result of the query is readed in order so if there are two results with the same text on the query, the second one replaces the first when filling the hash map
TagsNo tags attached.
Attached Filesdiff file icon TranslationUtils.diff [^] (939 bytes) 2014-01-16 16:22 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0063732)
hgbot (developer)
2014-01-28 06:51

Repository: erp/devel/pi
Changeset: dd222399853ef3d618728c023128f98c04623864
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Mon Jan 27 15:55:02 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/dd222399853ef3d618728c023128f98c04623864 [^]

Fixes Issue 0025493: Prevent unwanted translation of literals.

If a report using a literal and if the literal is already translated,
then the literal is replaced by the translated value.
Preventing that by adding values to the resultmap only if it did not exist.

---
M src-core/src/org/openbravo/uiTranslation/TranslationUtils.java
---
(0064121)
hudsonbot (developer)
2014-02-12 18:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d1a5bb862230 [^]
Maturity status: Test
(0064223)
AugustoMauch (developer)
2014-02-13 12:28

Code reviewed and verified in pi@9d50bf45a6c9

- Issue History
Date Modified Username Field Change
2014-01-16 16:22 egoitz New Issue
2014-01-16 16:22 egoitz Assigned To => AugustoMauch
2014-01-16 16:22 egoitz File Added: TranslationUtils.diff
2014-01-16 16:22 egoitz Modules => Core
2014-01-16 16:22 egoitz Triggers an Emergency Pack => No
2014-01-20 10:00 shankarb Assigned To AugustoMauch => shankarb
2014-01-28 06:45 shankarb Status new => scheduled
2014-01-28 06:45 shankarb fix_in_branch => pi
2014-01-28 06:47 shankarb Review Assigned To => AugustoMauch
2014-01-28 06:47 shankarb fix_in_branch pi =>
2014-01-28 06:47 shankarb Issue Monitored: AugustoMauch
2014-01-28 06:51 hgbot Checkin
2014-01-28 06:51 hgbot Note Added: 0063732
2014-01-28 06:51 hgbot Status scheduled => resolved
2014-01-28 06:51 hgbot Resolution open => fixed
2014-01-28 06:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/dd222399853ef3d618728c023128f98c04623864 [^]
2014-02-12 18:29 hudsonbot Checkin
2014-02-12 18:29 hudsonbot Note Added: 0064121
2014-02-13 12:28 AugustoMauch Note Added: 0064223
2014-02-13 12:28 AugustoMauch Status resolved => closed
2014-02-13 12:28 AugustoMauch Fixed in Version => 3.0MP32


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker