Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0008498
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementmajoralways2009-04-08 09:182009-07-08 07:00
ReportersureshbabuView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revisionf544940c086d
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabaseOracleJava version
OS VersionDatabase versionAnt version
Product Version2.50betaSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0008498: while creating a new volume discount BP's are wrongly added from the old volume discount to the new one.

Descriptionwhile creating a new volume discount in the Business partner's tab, Business partners are wrongly added from the old volume discount to the new volume discount

Steps To Reproducesteps which i used to reproduce the issue,

created a volume discount1 ( Master Data Management || Business Partner Setup || Volume Discount || Volume Discounts )
Name: <enter a valid name >
Scaled: Un check
Included Product: All selected
Included Product categories: Not selected

Step 2: Move to Product tab and
product: Hammer
and click new
Product: Paint



step 3: Move to volume discount parameters tab
Discount % : 10 (10%)
Min Amount : 10000

Move to Business partners tab
Business partner: McGiver supplies
Valid from date: <today's date>
Sales Transaction: checked
and click new and enter
Business partner: Red bunny
Valid from date: <today's date>
Sales Transaction: checked


Then i tried to create a new Volume discount to test the scaled functionality so i clicked new and entered all the required details and then i moved to Business partner tab.

Actual result: Both BP's Red Bunny & MC Giver Supplies are wrongly added to the list.

 
Tags250 final review, 250 QA
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0008501 closedjayakumar In volume discount settlement tab displays invoice details of all Business partners. 

-  Notes
(0015289)
alostale (developer)
2009-04-08 16:36

This bug is applicable to all sub tabs with used to have isParent='Y' and it has been removed because they do not define business objects.

They can be obtained with this query:

 select w.name win, t1.name child_tab, tb1.tablename child_table, t.name parent_tab, tb.tablename parent_tab, t1.whereclause, t1.ad_tab_id
         from ad_window w, ad_tab t, ad_tab t1, --t1 is the tab to look for parents
              ad_Table tb, ad_table tb1
        where t1.ad_window_id = t.ad_window_id
         and t.ad_window_id = w.ad_window_id
         and tb.ad_table_id = t.ad_table_id
         and tb1.ad_table_id = t1.ad_table_id
          and t.seqno < t1.seqno
          and t.tablevel < t1.tablevel
          and t.seqno = (select max(t2.seqno)
                           from ad_tab t2, ad_tab t3
                          where t3.ad_window_id = t2.ad_window_id
                            and t3.ad_tab_id = t1.ad_tab_id
                            and t2.seqno < t3.seqno
                            and t2.tablevel < t3.tablevel)
          and not exists (select 1 from ad_column c, ad_column c2
                           where c.ad_table_id = t1.ad_table_id and c.isparent = 'Y' and c2.ad_table_id = t.ad_table_id and c2.columnname = c.columnname)
          and not exists (select 1 from ad_column c, ad_column c2
                           where c.ad_table_id = t1.ad_table_id and c.iskey = 'Y' and c2.ad_table_id = t.ad_table_id and upper(c2.columnname) = upper(c.columnname))
          and w.isactive = 'Y'
          and t1.isactive ='Y'
          order by t1.whereclause;
(0015290)
hgbot (developer)
2009-04-08 16:47

Repository: erp/devel/pi
Changeset: 9968db2e63b03c665b24a5b108df10715a8ee1f4
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Apr 08 16:43:13 2009 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9968db2e63b03c665b24a5b108df10715a8ee1f4 [^]

fixed bug 0008498: while creating a new volume discount BP's are wrongly added from the old volume discount to the new one.

---
M src-db/database/sourcedata/AD_TAB.xml
---
(0017842)
hgbot (developer)
2009-07-03 13:13

Repository: erp/devel/pi
Changeset: f544940c086d28b0e8e85fb4ce1d4cbae50e8635
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Apr 08 16:43:13 2009 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f544940c086d28b0e8e85fb4ce1d4cbae50e8635 [^]

fixed bug 0008498: while creating a new volume discount BP's are wrongly added from the old volume discount to the new one.

---
M src-db/database/sourcedata/AD_TAB.xml
---
(0017984)
sureshbabu (reporter)
2009-07-08 07:00

Tested working fine.

- Issue History
Date Modified Username Field Change
2009-04-08 09:18 sureshbabu New Issue
2009-04-08 09:18 sureshbabu Assigned To => rafaroda
2009-04-08 09:18 sureshbabu Regression testing => No
2009-04-08 09:18 sureshbabu Tag Attached: 250 final review
2009-04-08 09:52 psarobe Priority normal => immediate
2009-04-08 09:52 psarobe Severity minor => major
2009-04-08 09:52 psarobe Status new => scheduled
2009-04-08 09:52 psarobe Tag Attached: 250 QA
2009-04-08 10:10 rafaroda Assigned To rafaroda => sathiyan
2009-04-08 10:43 sathiyan Assigned To sathiyan => jayakumar
2009-04-08 12:27 psarobe Assigned To jayakumar => iperdomo
2009-04-08 13:26 iperdomo Assigned To iperdomo => alostale
2009-04-08 16:36 alostale Note Added: 0015289
2009-04-08 16:47 hgbot Checkin
2009-04-08 16:47 hgbot Note Added: 0015290
2009-04-08 16:47 hgbot Status scheduled => resolved
2009-04-08 16:47 hgbot Resolution open => fixed
2009-04-08 16:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9968db2e63b03c665b24a5b108df10715a8ee1f4 [^]
2009-04-14 12:36 psarobe Relationship added related to 0008501
2009-04-14 16:23 psarobe Status resolved => closed
2009-04-15 12:00 anonymous sf_bug_id 0 => 2764978
2009-07-03 13:13 hgbot Checkin
2009-07-03 13:13 hgbot Note Added: 0017842
2009-07-03 13:13 hgbot Status closed => resolved
2009-07-03 13:13 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/9968db2e63b03c665b24a5b108df10715a8ee1f4 [^] => http://code.openbravo.com/erp/devel/pi/rev/f544940c086d28b0e8e85fb4ce1d4cbae50e8635 [^]
2009-07-08 07:00 sureshbabu Status resolved => closed
2009-07-08 07:00 sureshbabu Note Added: 0017984
2009-07-08 07:00 sureshbabu Fixed in Version 2.50MP1 => pi


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker