Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0009823
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajorsometimes2009-07-09 17:532009-07-18 00:00
ReporternetworkbView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision5ce40ea25872
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_11
OS VersionrPath LinuxDatabase version8.3.5Ant version1.7.1
Product Version2.40MP6SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0009823: columns in table C_TAXREGISTERLINE are wrong defined

Descriptionthree problems:

Columns TOTALAMT, TAXBASEAMT and TAXAMT belong C_TAXREGISTERLINE are wrong defined for two reasons:
 1. the lengths of this fields, in some cases are too small. when run process "create var register" error is returned:
ORA-01438 value larger than specified precision allowed for this column.

 2. the fields are defined like number(10), without decimals. They should be defined with decimals

Column DOCUMENTNO:
 3. It is defined in application dictionary like integer, but it should be String
Steps To Reproducewhen run "create var register" process in Financial Management || Receivables & Payables || Transactions || Tax Payment || Header:
in Tax Register Header:
 "Last Register Amount" and "tax total amount" fields dont have decimals
in lines:
 "taxable amount", "tax amount" and "total amount" fields dont have decimals
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0009884 closedvmromanos columns in table C_TAXREGISTERLINE are wrong defined 
related to defect 0009923 closedpjuvara API check: build 81 fails 

-  Notes
(0018077)
pjuvara (reporter)
2009-07-10 10:19

Please specify product version.
(0018149)
rafaroda (developer)
2009-07-13 09:31

Martin, could you please inform about the problems that could arise in pi (because of DAL) and in 2.40 by a change in the type of a column of a table?

Thanks.
(0018150)
mtaal (developer)
2009-07-13 09:36

Hi Rafa,
I do not expect problems for the DAL and the xml import. generate.entities needs to be rerun but that's it afaics. This because afaics the changes in format are backwards compatible (a decimal field can be filled from a integer number and the same for documentno from integer to string).

gr. Martin
(0018260)
hgbot (developer)
2009-07-15 14:18

Repository: erp/devel/pi
Changeset: 5ce40ea258729e4174f29002a3a5b5d248bead57
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Jul 15 14:15:17 2009 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5ce40ea258729e4174f29002a3a5b5d248bead57 [^]

Fixed bug 9823: columns in table C_TAXREGISTERLINE are wrong defined

---
M src-db/database/model/tables/C_TAXREGISTER.xml
M src-db/database/model/tables/C_TAXREGISTERLINE.xml
---

- Issue History
Date Modified Username Field Change
2009-07-09 17:53 networkb New Issue
2009-07-09 17:53 networkb Assigned To => rafaroda
2009-07-10 10:19 pjuvara Note Added: 0018077
2009-07-10 10:19 pjuvara Status new => feedback
2009-07-10 10:55 networkb version => 2.40MP6
2009-07-10 10:55 networkb Target Version 2.40MP6 =>
2009-07-10 16:44 pjuvara Status feedback => new
2009-07-13 09:31 rafaroda Note Added: 0018149
2009-07-13 09:31 rafaroda Assigned To rafaroda => mtaal
2009-07-13 09:36 mtaal Note Added: 0018150
2009-07-13 09:36 mtaal Assigned To mtaal => rafaroda
2009-07-14 09:02 rafaroda Assigned To rafaroda => eduardo_Argal
2009-07-14 09:02 rafaroda Status new => scheduled
2009-07-14 09:02 rafaroda fix_in_branch => pi
2009-07-15 11:04 vmromanos Assigned To eduardo_Argal => vmromanos
2009-07-15 14:18 hgbot Checkin
2009-07-15 14:18 hgbot Note Added: 0018260
2009-07-15 14:18 hgbot Status scheduled => resolved
2009-07-15 14:18 hgbot Resolution open => fixed
2009-07-15 14:18 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5ce40ea258729e4174f29002a3a5b5d248bead57 [^]
2009-07-16 10:50 shuehner Relationship added related to 0009923
2009-07-17 13:35 plujan Status resolved => closed
2009-07-18 00:00 anonymous sf_bug_id 0 => 2823355


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker