Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0008917
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupmajoralways2009-05-05 19:432009-06-02 06:42
ReporteryeasyView Statuspublic 
Assigned Toiperdomo 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revisionc38acc7c0db8
ProjectionnoneETAnoneTarget Version
OSWindowsDatabasePostgreSQLJava version
OS VersionServer 2003Database version8.3.7Ant version
Product Version2.50SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0008917: Error Message when set org. as ready

Description When processing "Set as Ready" during the general setup - Organization:
ERROR: value too long for type character varying(1000)
Steps To ReproduceA way to reproduce this bug is:

1- As Openbravo Admin, create a lot of organizations for the same client, for example 30 (it is not important neither the org type nor the position at the org's tree)
2- Try to set as ready any of them
Proposed SolutionIncrease the length of the column OB_CONTEXT of the AD_PROCESS_REQUEST table
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 0009224 closedmarvintm Data record insertion fails when using a CLOB column 
related to defect 0009238 closediperdomo api check: build 29 failed with a warning 

-  Notes
(0016100)
psarobe (manager)
2009-05-06 14:05

Please give more information as we cannot reproduce
(0016244)
psarobe (manager)
2009-05-11 11:06

Reminder sent to: yeasy

Any feedback?
(0016277)
yeasy (reporter)
2009-05-11 19:16

The problem can be solved by changing the log in role. Thanks!
(0016367)
rafaroda (developer)
2009-05-15 10:07

Reporter did manage to solve his problem: it was not an Openbravo ERP issue.
(0016672)
pjuvara (reporter)
2009-05-27 11:02

This problem happens when there is a large number of organizations and this makes the concatenated list of organization exceed the size.

This bug has been encountered in the internal Openbravo implementation (35 organizations). This is a professional subscription customer and this is a showstopper for the project.
(0016682)
vmromanos (developer)
2009-05-27 15:14

This is a Platform's bug, because it affects every PL procedure/function.

The column OB_CONTEXT of the AD_PROCESS_REQUEST table stores a snapshoot of the session variables, like the IDs of the clients, organizations or warehouses configured in the system when executing a PL procedure.

When the length of this string is greater than 10000 (it is easy with UUIDs), this bug appears.


The solution is to increase the length of this column, but Platform should decide the new length.
(0016740)
hgbot (developer)
2009-05-28 19:50

Repository: erp/devel/pi
Changeset: 32910a30d3cc7be3ae1cc355f29f8dd1a54a05f4
Author: Iván Perdomo <ivan.perdomo <at> openbravo.com>
Date: Thu May 28 19:49:24 2009 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/32910a30d3cc7be3ae1cc355f29f8dd1a54a05f4 [^]

Fixes issue 8917: Increase ob_context length

---
M src-db/database/model/tables/AD_PROCESS_REQUEST.xml
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0016802)
hgbot (developer)
2009-06-01 12:04

Repository: erp/devel/api-checks
Changeset: c38acc7c0db8bfedf932143f7cdb06fff486827e
Author: Iván Perdomo <ivan.perdomo <at> openbravo.com>
Date: Mon Jun 01 12:04:18 2009 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/c38acc7c0db8bfedf932143f7cdb06fff486827e [^]

Changed column length. Related to issue 8917

---
M model/model/tables/AD_PROCESS_REQUEST.xml
---
(0016834)
pjuvara (reporter)
2009-06-02 06:42

Verified

- Issue History
Date Modified Username Field Change
2009-05-05 19:43 yeasy New Issue
2009-05-05 19:43 yeasy Assigned To => rafaroda
2009-05-06 14:05 psarobe Note Added: 0016100
2009-05-06 14:05 psarobe Status new => feedback
2009-05-11 11:06 psarobe Note Added: 0016244
2009-05-11 19:16 yeasy Note Added: 0016277
2009-05-15 10:07 rafaroda Regression testing => No
2009-05-15 10:07 rafaroda Status feedback => closed
2009-05-15 10:07 rafaroda Note Added: 0016367
2009-05-15 10:07 rafaroda Resolution open => no change required
2009-05-16 00:00 anonymous sf_bug_id 0 => 2792498
2009-05-27 10:58 pjuvara Status closed => new
2009-05-27 10:58 pjuvara Resolution no change required => open
2009-05-27 10:58 pjuvara Priority normal => immediate
2009-05-27 10:58 pjuvara Severity major => critical
2009-05-27 11:02 pjuvara Note Added: 0016672
2009-05-27 13:35 psarobe Severity critical => major
2009-05-27 13:35 psarobe Status new => scheduled
2009-05-27 13:35 psarobe Assigned To rafaroda => vmromanos
2009-05-27 13:35 psarobe fix_in_branch => pi
2009-05-27 15:14 vmromanos Note Added: 0016682
2009-05-27 15:14 vmromanos Assigned To vmromanos => psarobe
2009-05-27 15:14 vmromanos Status scheduled => feedback
2009-05-27 16:25 vmromanos fix_in_branch pi =>
2009-05-27 16:25 vmromanos Proposed Solution updated
2009-05-27 16:25 vmromanos Steps to Reproduce Updated
2009-05-27 16:26 rafaroda Assigned To psarobe => alostale
2009-05-27 16:26 rafaroda Status feedback => scheduled
2009-05-27 18:01 alostale Assigned To alostale => iperdomo
2009-05-28 07:59 pjuvara Issue Monitored: pjuvara
2009-05-28 13:35 iperdomo Relationship added depends on 0009224
2009-05-28 19:50 hgbot Checkin
2009-05-28 19:50 hgbot Note Added: 0016740
2009-05-28 19:50 hgbot Status scheduled => resolved
2009-05-28 19:50 hgbot Resolution open => fixed
2009-05-28 19:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/32910a30d3cc7be3ae1cc355f29f8dd1a54a05f4 [^]
2009-05-29 12:20 iperdomo Relationship added related to 0009238
2009-06-01 12:04 hgbot Checkin
2009-06-01 12:04 hgbot Note Added: 0016802
2009-06-01 12:04 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/32910a30d3cc7be3ae1cc355f29f8dd1a54a05f4 [^] => http://code.openbravo.com/erp/devel/api-checks/rev/c38acc7c0db8bfedf932143f7cdb06fff486827e [^]
2009-06-02 06:42 pjuvara Status resolved => closed
2009-06-02 06:42 pjuvara Note Added: 0016834
2009-06-02 06:42 pjuvara Fixed in Version => pi


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker