Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0054400
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] POSmajoralways2024-01-19 14:352024-02-19 13:22
ReporterwicherrView Statuspublic 
Assigned ToTriage Omni OMS 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0054400: Deleting a ticket without calling the calculation of taxes makes the ticket go to EWI

DescriptionUsing a pricelist with prices without tax,
When you add a product on the basket and delete the ticket on the scan tab, it goes to EWI with the following error :



org.openbravo.base.exception.OBException: Error in OrderLoader: No tax was found for the specified product. Please review your configuration
    at org.openbravo.retail.posterminal.OrderLoader.saveRecord(OrderLoader.java:513)
    at org.openbravo.mobile.core.process.DataSynchronizationProcess.saveRecord(DataSynchronizationProcess.java:214)
    at org.openbravo.mobile.core.process.DataSynchronizationProcess.exec(DataSynchronizationProcess.java:165)
    at org.openbravo.mobile.core.process.DataSynchronizationProcess.exec(DataSynchronizationProcess.java:97)
    at org.openbravo.mobile.core.process.MobileImportEntryProcessorRunnable.processEntry(MobileImportEntryProcessorRunnable.java:55)
    at org.openbravo.retail.posterminal.importprocess.OrderImportEntryProcessor$OrderLoaderRunnable.processEntry(OrderImportEntryProcessor.java:64)
    at org.openbravo.service.importprocess.ImportEntryProcessor$ImportEntryProcessRunnable.doRunCycle(ImportEntryProcessor.java:447)
    at org.openbravo.service.importprocess.ImportEntryProcessor$ImportEntryProcessRunnable.run(ImportEntryProcessor.java:370)
    at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
    at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
    at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
    at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
    at java.base/java.lang.Thread.run(Thread.java:829)
Caused by: org.openbravo.base.exception.OBException: No tax was found for the specified product. Please review your configuration
    at org.openbravo.retail.posterminal.OrderLoader.verifyOrderLineTax(OrderLoader.java:2277)
    at org.openbravo.retail.posterminal.OrderLoader.saveRecord(OrderLoader.java:344)
    ... 12 more
Steps To ReproduceThis defect has been obtained using the Avalara module

Step to reproduce 1 :
Create a new ticket
Add a product
DON’T click on Pay
Delete the ticket
Check the EWI

Step to reproduce 2 :
Create a new ticket
Add a product
Click on Pay
Click on Back
Delete the ticket
Check the EWI
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0054653 closedkousalya_r Openbravo ERP API Change: OrderLine Tax 

-  Notes
(0160664)
hgbot (developer)
2024-02-13 07:12

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/1470 [^]
(0160665)
hgbot (developer)
2024-02-13 07:13

Merge Request created: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/1138 [^]
(0160697)
hgbot (developer)
2024-02-13 14:24

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.api/-/merge_requests/235 [^]
(0160724)
hgbot (developer)
2024-02-14 10:07

Merge Request created: https://gitlab.com/openbravo/ci/backoffice-api/-/merge_requests/61 [^]
(0160732)
hgbot (developer)
2024-02-14 11:56

Merge request closed: https://gitlab.com/openbravo/ci/backoffice-api/-/merge_requests/61 [^]
(0160899)
hgbot (developer)
2024-02-19 12:33

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/1470 [^]
(0160901)
hgbot (developer)
2024-02-19 12:34

Merge request merged: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/1138 [^]
(0160902)
hgbot (developer)
2024-02-19 12:34

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.api/-/merge_requests/235 [^]
(0160906)
frank_gonzalez (developer)
2024-02-19 13:10
edited on: 2024-02-19 13:20

org.openbravo.retail.posterminal merge commit:

https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/commit/d259c390e32eec11c64c5e151ed8afceca63a4e9 [^]

Core merge commit:
https://gitlab.com/openbravo/product/openbravo/-/commit/55a15dfc4f696588c98c974df65bb04f5a4454d5 [^]

org.openbravo.api merge commit:
https://gitlab.com/openbravo/product/pmods/org.openbravo.api/-/commit/3d2e3a0c0c788259319af6532a700fb1243e56ce [^]


- Issue History
Date Modified Username Field Change
2024-01-19 14:35 wicherr New Issue
2024-01-19 14:35 wicherr Assigned To => Retail
2024-01-19 14:35 wicherr Triggers an Emergency Pack => No
2024-01-24 20:51 aferraz Assigned To Retail => Triage Omni OMS
2024-02-13 07:12 hgbot Note Added: 0160664
2024-02-13 07:13 hgbot Note Added: 0160665
2024-02-13 11:00 frank_gonzalez Relationship added related to 0054653
2024-02-13 14:24 hgbot Note Added: 0160697
2024-02-14 10:07 hgbot Note Added: 0160724
2024-02-14 11:56 hgbot Note Added: 0160732
2024-02-19 12:33 hgbot Note Added: 0160899
2024-02-19 12:34 hgbot Note Added: 0160901
2024-02-19 12:34 hgbot Note Added: 0160902
2024-02-19 13:10 frank_gonzalez Note Added: 0160906
2024-02-19 13:20 frank_gonzalez Note Edited: 0160906 View Revisions
2024-02-19 13:22 frank_gonzalez Status new => scheduled
2024-02-19 13:22 frank_gonzalez Status scheduled => resolved
2024-02-19 13:22 frank_gonzalez Resolution open => fixed
2024-02-19 13:22 frank_gonzalez Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker