Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0048457
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] Restaurantscriticalsometimes2022-01-20 18:252022-01-30 17:34
Reportertimothee_catteeuwView Statuspublic 
Assigned Tosntgreale 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0048457: JIRA 2617 - Sometimes ticket Z data are not correctly reinit after closing

DescriptionSometimes the ticket Z take into account old datas even if a closure was done.

The problem with that is that all datas are accumulated. And it is printed datas of 2 closures instead if just of 1.

The ticket saved in BO is also KO.
Steps To Reproduce1) Go to webpos
2) start a new ticket and pay it
3) Close the till
4) Check the ticket Z which was printed
5) close all chrome processes (or restart computer)
6) connect to POS again
7) Print the ticket X, by clicking print the ticket X option
→ KO the ticket X consists of all the information of the previous closure
8) Select a safebox, start a new ticket and pay it
9) Close the till
10) Check the ticket Z which was printed
→ KO the ticket Z consists of all the information of the previous closure and the last closure

Technical cause shared by JME :
=> the indicatorXz.isResetXZModel is “undefined” and the indicatorXz object is not reset.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0048502TAP closedsntgreale JIRA 2617 - Sometimes ticket Z data are not correctly reinit after closing 

-  Notes
(0134511)
guilleaer (manager)
2022-01-24 12:24

This issue was a regression introduced by

https://issues.openbravo.com/view.php?id=48443 [^]

New fix for https://issues.openbravo.com/view.php?id=48443 [^] was done
(0134618)
guilleaer (manager)
2022-01-27 15:36

This MR reinitilize the Ticket Z in FS version

https://gitlab.com/obcustomers/AGAP/com.openbravo.flunch.reports/-/merge_requests/21 [^]
(0134662)
guilleaer (manager)
2022-01-28 14:23

In FS and TAP is not working when browser is closed after logout. This is because state is not persisted
(0134669)
sntgreale (developer)
2022-01-28 19:33

MR -> https://gitlab.com/obcustomers/AGAP/com.openbravo.flunch.reports/-/merge_requests/24 [^]

- Issue History
Date Modified Username Field Change
2022-01-20 18:25 timothee_catteeuw New Issue
2022-01-20 18:25 timothee_catteeuw Assigned To => Retail
2022-01-20 18:25 timothee_catteeuw Triggers an Emergency Pack => No
2022-01-24 12:24 guilleaer Review Assigned To => guilleaer
2022-01-24 12:24 guilleaer Note Added: 0134511
2022-01-24 12:24 guilleaer Status new => closed
2022-01-24 12:24 guilleaer Resolution open => fixed
2022-01-26 16:36 guilleaer Status closed => new
2022-01-26 16:36 guilleaer Resolution fixed => open
2022-01-26 16:38 elara Assigned To Retail => elara
2022-01-27 15:19 elara Status new => scheduled
2022-01-27 15:36 guilleaer Note Added: 0134618
2022-01-27 15:36 guilleaer Target Version TAP =>
2022-01-27 15:36 guilleaer Status scheduled => resolved
2022-01-27 15:36 guilleaer Resolution open => fixed
2022-01-27 15:36 guilleaer Status resolved => closed
2022-01-28 14:22 guilleaer Status closed => new
2022-01-28 14:22 guilleaer Resolution fixed => open
2022-01-28 14:22 guilleaer Status new => scheduled
2022-01-28 14:23 guilleaer Note Added: 0134662
2022-01-28 19:06 sntgreale Assigned To elara => sntgreale
2022-01-28 19:33 sntgreale Note Added: 0134669
2022-01-30 17:34 guilleaer Status scheduled => resolved
2022-01-30 17:34 guilleaer Resolution open => fixed
2022-01-30 17:34 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker