Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0047953
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Gift cards and gift vouchersmajoralways2021-10-29 16:372022-01-27 17:15
ReporterlbressanView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR22Q2
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0047953: Gift Card Data not saved

DescriptionWhen selecting a gift card, the line is not inserted, so the code that fills its data is not executed.

Video of the explained behavior: https://watch.screencastify.com/v/sQcClseFrBhxQdkYjoDT [^]

Steps To Reproduce1) Open web POS in Live Build https://livebuilds.openbravo.com/retail_modules_pgsql_pi/web/org.openbravo.retail.posterminal/?terminal=VBS-1 [^] .

2) Open Developer tools and go to "Sources" tab

3) Select the js file in livebuilds.openbravo.com/retail_modules_pgsql_pi/web/js/gen

4) Set a breakpoint at line "if (this.currentLine) { " .

Codeblock :
if (this.currentLine) {
  gcowner.bPartnerId = this.currentLine.get('giftcardobqcneGCOwner');
  gcowner.bPartnerName = this.currentLine.get(gcowner_name);
  ...

5) In web POS search "Voucher" in product search box

6) Select the Gift Card

7) Observe that the line is not inserted, so "this.currentLine" is undefined and therefore, the fields inside the if block are not filled.

8) Continue execution (play button)

9) Click on Gift Card Owner and select a customer

10) Complete the identifier (e.g: "test") and click Apply.

11) Go to "Checkout", click on "Pay total" and then on "Done"

12) Go to Menu -> Gift / Credit Notes and click on the search icon

13) Observe that the gift card data was not saved
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0133050)
ranjith_qualiantech_com (developer)
2021-11-15 15:01

Checked and confirmed with Reporter.
Issue is not reproducible in livebuilds.
(0133199)
marvintm (manager)
2021-11-19 07:28

We have been unable to reproduce the issue. We tried contacting the reporter several times, but we got no response.
(0133200)
Practics (reporter)
2021-11-19 07:43

Hi, this is not's true, we explain all in the suport ticket 31068
(0134371)
hgbot (developer)
2022-01-19 06:19

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/merge_requests/106 [^]
(0134449)
hgbot (developer)
2022-01-21 08:27

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards [^]
Changeset: 6269c94d6a30f88b0a86cdc9eb407b012ce54628
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 18-01-2022 12:06:29
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/commit/6269c94d6a30f88b0a86cdc9eb407b012ce54628 [^]

Fixed ISSUE-47953: GiftCard owner should be updated with Ticket customer
* When add new gift card/voucher, owner should be updated with ticket customer,
  if ticket customer is not a anonymous customer

---
M web/org.openbravo.retail.giftcards/js/components/GCNewEntitiesGCOwner.js
---
(0134450)
hgbot (developer)
2022-01-21 08:27

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/merge_requests/106 [^]
(0134499)
dromero (developer)
2022-01-21 18:24

Add video with the error
https://watch.screencastify.com/v/FseEoujuH5bWzoHKzpWZ [^]
(0134612)
dromero (developer)
2022-01-27 13:54

The issues is resolved. The customer was wrong.

- Issue History
Date Modified Username Field Change
2021-10-29 16:37 lbressan New Issue
2021-10-29 16:37 lbressan Assigned To => Retail
2021-10-29 16:37 lbressan Regression date => 2021-10-15
2021-10-29 16:37 lbressan Triggers an Emergency Pack => No
2021-10-29 17:36 Practics Issue Monitored: Practics
2021-11-02 17:49 justin_patterson Assigned To Retail => justin_patterson
2021-11-10 07:18 marvintm Regression date 2021-10-15 =>
2021-11-11 07:38 marvintm Assigned To justin_patterson => ranjith_qualiantech_com
2021-11-15 15:01 ranjith_qualiantech_com Note Added: 0133050
2021-11-19 07:28 marvintm Note Added: 0133199
2021-11-19 07:28 marvintm Status new => closed
2021-11-19 07:28 marvintm Resolution open => unable to reproduce
2021-11-19 07:43 Practics Note Added: 0133200
2022-01-13 18:12 marvintm Status closed => new
2022-01-13 18:12 marvintm Resolution unable to reproduce => open
2022-01-17 10:37 ranjith_qualiantech_com Status new => acknowledged
2022-01-19 06:19 hgbot Note Added: 0134371
2022-01-21 08:27 hgbot Resolution open => fixed
2022-01-21 08:27 hgbot Status acknowledged => closed
2022-01-21 08:27 hgbot Note Added: 0134449
2022-01-21 08:27 hgbot Note Added: 0134450
2022-01-21 18:24 dromero Note Added: 0134499
2022-01-21 18:24 dromero Status closed => new
2022-01-21 18:24 dromero Resolution fixed => open
2022-01-27 13:54 dromero Note Added: 0134612
2022-01-27 17:15 marvintm Status new => scheduled
2022-01-27 17:15 marvintm Status scheduled => resolved
2022-01-27 17:15 marvintm Fixed in Version => RR22Q2
2022-01-27 17:15 marvintm Resolution open => fixed
2022-01-27 17:15 marvintm Review Assigned To => marvintm
2022-01-27 17:15 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker