Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0047844
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] [POS2] POSmajoralways2021-10-13 16:122021-10-14 11:32
ReporterSergio_GomezView Statuspublic 
Assigned ToRetail 
PrioritynormalResolutionopenFixed in Version
StatusnewFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0047844: Attribute values are not displayed correctly when receipts are reopened

DescriptionWhen the receipt is reopened, the attribute value is displayed as a Json of the saved information
Steps To ReproduceIn the backoffice https://livebuilds.openbravo.com/retail_mp_3.0RR21Q3.2: [^] [^]

-Create an attribute (Instance Attribute = 'Y', Mandatory = 'Y')
-Create an attribute set with the previous attribute
-Add the attribute to one product
-Create a goods receipt setting the amount and a test attribute set value for the product
-Create a physical inventory with the product
-Set the preference Web POS Enable support for product attributes = 'Y'

In the webpos https://livebuilds.openbravo.com/retail_mp_3.0RR21Q3.2/web/org.openbravo.retail.posterminal/?terminal=VBS-1: [^] [^]

-Create a sale with the product
-Set the attribute value in the popup
-Make the payment
-In the left menu reopen the receipt
-Check that the attribute value is not displayed correctly

See the video: https://watch.screencastify.com/v/uEnpoacDfRA5Afw3Vb3K [^] [^]
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2021-10-13 16-11-28.png [^] (235,336 bytes) 2021-10-13 16:12

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 0047843 newRetail Unable to use attributes in products without enabling instance attribute 
blocks defect 0047845 newRetail Services button does not appear in products with attribute values 
Not all the children of this issue are yet resolved or closed.

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2021-10-13 16:12 Sergio_Gomez New Issue
2021-10-13 16:12 Sergio_Gomez Assigned To => Retail
2021-10-13 16:12 Sergio_Gomez File Added: Screenshot from 2021-10-13 16-11-28.png
2021-10-13 16:12 Sergio_Gomez Triggers an Emergency Pack => No
2021-10-13 16:26 Sergio_Gomez Relationship added blocks 0047845
2021-10-13 16:27 Sergio_Gomez Relationship added depends on 0047843
2021-10-13 17:25 Practics Issue Monitored: Practics
2021-10-14 11:32 guilleaer Project POS2 => Retail Modules


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker