Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0047726
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Gift cards and gift vouchersmajoralways2021-09-21 09:572021-10-18 08:17
Reporterjoniturralde93View Statuspublic 
Assigned Torqueralta 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0047726: Gift Certificate sequence prefix should be unique

DescriptionThe customer can set repeated prefixes, which leads to duplicated certificate numbers and Errors While Importing, so we should ensure no prefix is duplicated in two touchpoints.
Steps To ReproduceEnter the same prefix in two terminals of the same organization and start generating certificates, this will lead to Error While Importing
Proposed SolutionAdd validation when saving a Gift Certificate Sequence Prefix
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0132018)
hgbot (developer)
2021-09-27 12:18

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/merge_requests/91 [^]
(0132105)
hgbot (developer)
2021-10-04 04:52

Merge request closed: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/merge_requests/91 [^]
(0132106)
hgbot (developer)
2021-10-04 04:57

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/merge_requests/95 [^]
(0132113)
hgbot (developer)
2021-10-04 07:28

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards [^]
Changeset: ed9ee31e67edbda2dcd654a0baa72361b68e2781
Author: Rafael Queralta <rafaelcuba81@gmail.com>
Date: 2021-10-04T05:27:51+00:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/commit/ed9ee31e67edbda2dcd654a0baa72361b68e2781 [^]

Fixed BUG-47726: Added constrain for gift card sequence prefix

---
M src-db/database/model/modifiedTables/OBPOS_APPLICATIONS.xml
---
(0132114)
hgbot (developer)
2021-10-04 07:28

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/merge_requests/95 [^]
(0132124)
marvintm (developer)
2021-10-04 13:02

Reopened because unique constraints do not work in Oracle with null values, and we need to support this case.
(0132125)
hgbot (developer)
2021-10-04 13:02

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards [^]
Changeset: aab908aad7b1c99016670e9e4698744182793762
Author: Antonio Moreno <anmorenoperez@gmail.com>
Date: 2021-10-04T13:02:12+02:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/commit/aab908aad7b1c99016670e9e4698744182793762 [^]

Related to ISSUE-47726. Revert unique constraint as we need to support null values, and in Oracle it doesn't work

---
M src-db/database/model/modifiedTables/OBPOS_APPLICATIONS.xml
---
(0132152)
hgbot (developer)
2021-10-04 17:46

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/merge_requests/96 [^]
(0132225)
hgbot (developer)
2021-10-07 07:24

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards [^]
Changeset: 12950a8dbd96a7cde3b47d4d413d964cc861629c
Author: Rafael Queralta <rafaelcuba81@gmail.com>
Date: 2021-10-07T05:24:09+00:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/commit/12950a8dbd96a7cde3b47d4d413d964cc861629c [^]

Fixed BUG-47726: Added validation to avoid duplicated gift certificates sequences prefix

---
A src/org/openbravo/retail/giftcards/event/GCNVCertificateSequencePrefixEventHandler.java
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0132226)
hgbot (developer)
2021-10-07 07:24

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/merge_requests/96 [^]
(0132311)
joniturralde93 (developer)
2021-10-13 10:15

As of now in live builds with modules, if the certificate prefix is set, the record is saved, and then any other field is modified, when trying to save the record again we get:
Saving failed. Duplicated Sequence Prefix. Please, insert a new Gift Certificate Sequence Prefix.

As the current condition checks the same record when trying to find duplicates.
(0132379)
hgbot (developer)
2021-10-18 08:08

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/merge_requests/99 [^]
(0132380)
hgbot (developer)
2021-10-18 08:17

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards [^]
Changeset: 00cbc5ab28d1186877688c3ce190a9395bf0b1bb
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2021-10-15T17:07:12+05:30
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/commit/00cbc5ab28d1186877688c3ce190a9395bf0b1bb [^]

Fixed ISSUE-47726: Updated validation to check duplicate giftcard prefix in Touchpoint

---
M src/org/openbravo/retail/giftcards/event/GCNVCertificateSequencePrefixEventHandler.java
---
(0132381)
hgbot (developer)
2021-10-18 08:17

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.giftcards/-/merge_requests/99 [^]

- Issue History
Date Modified Username Field Change
2021-09-21 09:57 joniturralde93 New Issue
2021-09-21 09:57 joniturralde93 Assigned To => Retail
2021-09-21 09:57 joniturralde93 Triggers an Emergency Pack => No
2021-09-21 16:14 rqueralta Assigned To Retail => rqueralta
2021-09-21 16:14 rqueralta Status new => scheduled
2021-09-27 12:18 hgbot Note Added: 0132018
2021-10-04 04:52 hgbot Note Added: 0132105
2021-10-04 04:57 hgbot Note Added: 0132106
2021-10-04 07:28 hgbot Resolution open => fixed
2021-10-04 07:28 hgbot Status scheduled => closed
2021-10-04 07:28 hgbot Note Added: 0132113
2021-10-04 07:28 hgbot Note Added: 0132114
2021-10-04 13:02 marvintm Note Added: 0132124
2021-10-04 13:02 marvintm Status closed => new
2021-10-04 13:02 marvintm Resolution fixed => open
2021-10-04 13:02 hgbot Note Added: 0132125
2021-10-04 17:46 hgbot Note Added: 0132152
2021-10-07 07:24 hgbot Resolution open => fixed
2021-10-07 07:24 hgbot Status new => closed
2021-10-07 07:24 hgbot Note Added: 0132225
2021-10-07 07:24 hgbot Note Added: 0132226
2021-10-13 10:15 joniturralde93 Note Added: 0132311
2021-10-13 10:15 joniturralde93 Status closed => new
2021-10-18 08:08 hgbot Note Added: 0132379
2021-10-18 08:17 hgbot Status new => closed
2021-10-18 08:17 hgbot Note Added: 0132380
2021-10-18 08:17 hgbot Note Added: 0132381


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker