Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0047441
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POScriticalalways2021-07-22 11:382021-07-23 14:01
ReporteregoitzView Statuspublic 
Assigned ToRetail 
PriorityimmediateResolutionfixedFixed in VersionRR20Q2.2
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSWindowsDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRR20Q2SCM revision 
Review Assigned Toadrianromero
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0047441: Error when searching for products with the latest version of Chrome

DescriptionVersion Openbravo 20q2
Version Chrome 92.0.4515.107
Windows

It remains loading and if I do any refresh the pos is frozen.
To be able to reproduce it, it is necessary to have many products loaded

Attached the video
Steps To ReproduceHave the following versions:
Version Openbravo 20q1
Version Chrome 92.0.4515.107
Windows

1) Open the terminal
2) Search a product

After that error, they scanned a product, and the product is not added.

Proposed SolutionApply attached patch
TagsNo tags attached.
Attached Filesdiff file icon FIX0047441-20Q2.2.diff [^] (1,327 bytes) 2021-07-23 11:09 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0047432 closedadrianromero Error when searching for clients with the latest version of Chrome 

-  Notes
(0130719)
adrianromero (manager)
2021-07-23 11:16

This issue affects to Openbrav version 20Q2.2 and previous versions in combination with Chrome 92.0.4515.107 and later versions

Later Openbravo versions are not affected because master data queries use IndexDB instead of WebSQL.

Chrome 92.0.4515.107 adds the SQLite option SQLITE_OMIT_AUTOMATIC_INDEX.This option makes that SQL queries with joins on non indexed columns perform very poorly as automatic indexes on those columns are not created, so explicit indexes must be created as done in the attached patch.

https://chromium.googlesource.com/chromium/src/+/5d1cbc8576cd32833b785e00ec4b39ebf25a6773%5E%21/#F0 [^]
(0130721)
adrianromero (manager)
2021-07-23 11:27

As a workaround Chrome can be downgraded to version 91.0.4472.77

- Issue History
Date Modified Username Field Change
2021-07-22 11:38 egoitz New Issue
2021-07-22 11:38 egoitz Assigned To => Retail
2021-07-22 11:38 egoitz Triggers an Emergency Pack => No
2021-07-22 11:38 egoitz Issue generated from 0047432
2021-07-22 11:38 egoitz Relationship added related to 0047432
2021-07-22 12:06 Practics Issue Monitored: Practics
2021-07-23 11:09 adrianromero File Added: FIX0047441-20Q2.2.diff
2021-07-23 11:09 adrianromero Proposed Solution updated
2021-07-23 11:16 adrianromero Note Added: 0130719
2021-07-23 11:27 adrianromero Note Added: 0130721
2021-07-23 11:45 adrianromero Status new => scheduled
2021-07-23 11:45 adrianromero Status scheduled => resolved
2021-07-23 11:45 adrianromero Resolution open => fixed
2021-07-23 11:45 adrianromero Review Assigned To => adrianromero
2021-07-23 11:45 adrianromero Status resolved => closed
2021-07-23 11:45 adrianromero Fixed in Version => RR20Q2.2
2021-07-23 14:01 eugeni Issue Monitored: eugeni


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker