Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0047437
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] Restaurantsminoralways2021-07-22 09:442021-07-27 12:31
Reportertimothee_catteeuwView Statuspublic 
Assigned Toagonzalez 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0047437: JIRA 2234 - When selecting components in a menu, the word "select" is not translatable

DescriptionIn restaurant context, when you select a menu and before selecting what your component will be, you have the term "select" display before each kind of component.
Exemple (cf. as well
- Simple menu
    - Select Starter
    - Select Main course
    - Select beverage
    - Select Dessert

The problem is the word select is not translatable.

In the file GetMenuItemInfo.js, in the line 154, there is the hardcoded text 'select'

          categoryMessage = `Select ${getCategoryOrGroupName(
            category,
            menuDefinition
          )}`;
This is wrong, this text should be Translatable
Steps To ReproduceLogin webpos (I tested on this environnement--> https://livebuilds.openbravo.com/retail_pos2_modules_pgsql/web/pos/?terminal=VBS-2 [^])

Open the sales area "Restaurant"
Go to menu category
Select simple menu
on the ticket view, we can see "select" 4 times and this word is not translatable
TagsNo tags attached.
Attached Filespng file icon MENU_SELECT.png [^] (93,919 bytes) 2021-07-22 09:44

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0047438TAP closedagonzalez JIRA 2234 - When selecting components in a menu, the word "select" is not translatable 

-  Notes
(0130708)
hgbot (developer)
2021-07-22 19:41

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2.restaurant/-/merge_requests/57 [^]
(0130787)
hgbot (developer)
2021-07-27 12:30

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2.restaurant/-/merge_requests/57 [^]

- Issue History
Date Modified Username Field Change
2021-07-22 09:44 timothee_catteeuw New Issue
2021-07-22 09:44 timothee_catteeuw Assigned To => Retail
2021-07-22 09:44 timothee_catteeuw File Added: MENU_SELECT.png
2021-07-22 09:44 timothee_catteeuw Triggers an Emergency Pack => No
2021-07-22 09:46 dmiguelez Status new => acknowledged
2021-07-22 09:47 dmiguelez Status acknowledged => scheduled
2021-07-22 09:47 dmiguelez Status scheduled => acknowledged
2021-07-22 09:50 dmiguelez Status acknowledged => scheduled
2021-07-22 09:50 dmiguelez Assigned To Retail => agonzalez
2021-07-22 19:41 hgbot Note Added: 0130708
2021-07-27 12:30 hgbot Note Added: 0130787
2021-07-27 12:31 dmiguelez Status scheduled => resolved
2021-07-27 12:31 dmiguelez Resolution open => fixed
2021-07-27 12:31 dmiguelez Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker