Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0047232
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] POSmajorhave not tried2021-06-23 17:542021-08-03 15:00
ReporterjavietxeView Statuspublic 
Assigned Tojarmendariz 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0047232: JIRA 2057: CRM connector focus changing and validations

DescriptionWhen changing the focus, seems that if the validation takes more time than the focus changing actions, some asynchrony can happen letting the CRM connector in a strange state.

In Agapes it happens with the email field (it has a validation) together with the "is dematerialised?" checkbox, that depending on the selection some fields are hidden or not.
Steps To ReproduceWhen creating a customer,

When we check/uncheck several times “Demat card” checkbox

When leave checkbox unchecked

When start to enter an email

When clicking on “Demat card”, the fields “Card number” and crypto remains instead of being hidden (See the video provided in the JIRA)
Proposed SolutionWhen changing focus from an imput, wait some
TagsNo tags attached.
Attached Fileswmv file icon error_validation_crm.wmv [^] (979,603 bytes) 2021-06-29 11:38
? file icon 2021-08-03_10-59-14.mp4 [^] (557,746 bytes) 2021-08-03 13:43

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0046889 acknowledgedRetail Extra buttons are displayed in the customer form while on change operation is in progress 
depends on backport 0047234TAP closedjarmendariz JIRA 2057: CRM connector focus changing and validations 

-  Notes
(0130331)
jarmendariz (developer)
2021-07-08 17:46

After discussing this topic with Guillermo, Cristian, David Baz and myself, we all agreed that we should be able to keep a flag in the Form's state to indicate that the form is being validated at this moment so, when a checkbox processes a check/uncheck event, we can delay the execution of this event until the validation is finished and then we know whether this checkbox event could be processed or not.
(0130703)
hgbot (developer)
2021-07-22 17:54

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/merge_requests/606 [^]
(0130908)
hgbot (developer)
2021-07-30 18:54

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.core2 [^]
Changeset: 735145b7022ea8d21a058ce60ba171abf2d09c73
Author: Javier Armendáriz <javier.armendariz@openbravo.com>
Date: 2021-07-30T16:53:51+00:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/commit/735145b7022ea8d21a058ce60ba171abf2d09c73 [^]

Fixed ISSUE-47232: Blocking UI before validation when a field changes to avoid overlapping states when form item changes at the same time as the validation

---
M web-jspack/org.openbravo.core2/src/components/BaseFormDatePicker/BaseFormDatePicker.jsx
M web-jspack/org.openbravo.core2/src/components/BaseFormInput/BaseFormInput.jsx
M web-jspack/org.openbravo.core2/src/components/BaseFormInput/ClearInputButton.jsx
M web-jspack/org.openbravo.core2/src/components/BaseFormTimePicker/BaseFormTimePicker.jsx
M web-jspack/org.openbravo.core2/src/components/Form/BaseForm.jsx
M web-jspack/org.openbravo.core2/src/components/Form/__test__/ConfigurableForm.test.jsx
M web-jspack/org.openbravo.core2/src/components/Form/__test__/TestForm.config.json
---
(0130909)
hgbot (developer)
2021-07-30 18:54

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/merge_requests/606 [^]
(0130950)
jmelin (developer)
2021-08-03 13:43

After filling the email, you need to click twice on "Demat" checkbox to change it as "selected"

1. Open window to create a new customer
2. Click several times on checkbox “Demat card” and leave unchecked
3. Type an email address in the email field
4. Click on the “Demat card” checkbox

=> KO, something appears/disappears and the checkbox remains unchecked.
You need to click a 2nd time to be selected
(0130956)
dmiguelez (developer)
2021-08-03 14:59
edited on: 2021-08-03 15:00

This is a known side effect created by the resolution of the issue.
However, since the data is consistent (which was not before the fix) and since this is a very corner case from the business flow point of view, this scenario can be reported as a different issue categorized as a trivial design defect


- Issue History
Date Modified Username Field Change
2021-06-23 17:54 javietxe New Issue
2021-06-23 17:54 javietxe Assigned To => Retail
2021-06-23 17:54 javietxe Resolution time => 1625608800
2021-06-23 17:54 javietxe Triggers an Emergency Pack => No
2021-06-23 17:58 guilleaer Status new => scheduled
2021-06-23 17:58 guilleaer Assigned To Retail => platform
2021-06-23 17:58 guilleaer Status scheduled => acknowledged
2021-06-29 11:38 cberner File Added: error_validation_crm.wmv
2021-07-08 17:46 jarmendariz Note Added: 0130331
2021-07-13 12:14 dmiguelez Resolution time 1625608800 => 1627423200
2021-07-22 17:51 jarmendariz Assigned To platform => jarmendariz
2021-07-22 17:54 hgbot Note Added: 0130703
2021-07-23 09:25 jarmendariz Relationship added related to 0046889
2021-07-30 18:54 hgbot Resolution open => fixed
2021-07-30 18:54 hgbot Status acknowledged => closed
2021-07-30 18:54 hgbot Note Added: 0130908
2021-07-30 18:54 hgbot Note Added: 0130909
2021-08-03 13:43 jmelin Note Added: 0130950
2021-08-03 13:43 jmelin Status closed => new
2021-08-03 13:43 jmelin Resolution fixed => open
2021-08-03 13:43 jmelin File Added: 2021-08-03_10-59-14.mp4
2021-08-03 14:59 dmiguelez Resolution time 1627423200 =>
2021-08-03 14:59 dmiguelez Note Added: 0130956
2021-08-03 14:59 dmiguelez Severity major => trivial
2021-08-03 14:59 dmiguelez Type defect => design defect
2021-08-03 14:59 dmiguelez Status new => acknowledged
2021-08-03 14:59 dmiguelez Note Edited: 0130956 View Revisions
2021-08-03 14:59 dmiguelez Status acknowledged => scheduled
2021-08-03 15:00 dmiguelez Severity trivial => major
2021-08-03 15:00 dmiguelez Type design defect => defect
2021-08-03 15:00 dmiguelez Status scheduled => resolved
2021-08-03 15:00 dmiguelez Resolution open => fixed
2021-08-03 15:00 dmiguelez Status resolved => closed
2021-08-03 15:00 dmiguelez Note Edited: 0130956 View Revisions
2021-08-03 15:00 dmiguelez Note Edited: 0130956 View Revisions


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker