Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0047036
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] Y. DBSourceManagerminorhave not tried2021-06-09 11:352021-06-16 13:40
ReportershuehnerView Statuspublic 
Assigned Toshuehner 
PrioritynormalResolutionfixedFixed in VersionPR21Q3
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget VersionPR21Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0047036: Remove lots of obsolete support code for obsolete (update.database.mod, ezattributes module, dbmanager.jar references)

DescriptionWe still carry lots of support code in dbsourcemanager for things being obsolete a long time:
- ant update.database.mod
The task was removed many many years ago but we still kept the whole 'ModelLoader' code duplicated which was created for it
- ezattributes (Easy Extensible Attributes) module was last user of that extra ModelLoader but that module itself is unsupported since February 2019 (and recently stopped working properly because of other changes)
- dbmanager.jar (aka src-db/src) in backoffice repo is also unused a long time (replaced by the extendable excludeFilter.xml) but still had some code-references left

Cleanup all that support code in dbsourcemanager (and some references in backoffice:src-db/database/build*.xml) to reduce maintenance effort and unblock further planned dbsm work
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 0029853 closedshuehner ant validate.database fails in pi 
blocks feature request 0028703PR21Q3 closedshuehner dbmanager.jar & src-db/src removal 
blocks design defect 0032688 acknowledgedplatform remove unused resources 
blocks defect 0047047 closedshuehner Reading tables part of PostgreSQL modelloader could be simplified and speed up 

-  Notes
(0129260)
shuehner (administrator)
2021-06-09 13:11

https://gitlab.com/openbravo/product/dbsm/-/merge_requests/21 [^]
(0129263)
hgbot (developer)
2021-06-09 13:32

Repository: https://gitlab.com/openbravo/product/dbsm [^]
Changeset: 21e22f65ab50389afff4ec48cffe8de2fb767715
Author: Stefan Huehner <stefan.huehner@openbravo.com>
Date: 2021-06-09T13:28:11+02:00
URL: https://gitlab.com/openbravo/product/dbsm/-/commit/21e22f65ab50389afff4ec48cffe8de2fb767715 [^]

Fixes ISSUE-47036: Remove obsolete support code to ease maintenance

This removes obsolete support code needed in the past for:
- ant update.database.mod (long dead and removed)
- ezattributes (Easy Extensible Attributes) module
  Unuspported and already non-working since a while

Mostly it removes the duplication of all the ModelLoader code making it
much more readable.

---
M src/org/apache/ddlutils/Platform.java
M src/org/apache/ddlutils/io/DatabaseDataIO.java
M src/org/apache/ddlutils/model/Database.java
M src/org/apache/ddlutils/platform/ModelLoader.java
M src/org/apache/ddlutils/platform/ModelLoaderBase.java
M src/org/apache/ddlutils/platform/PlatformImplBase.java
M src/org/apache/ddlutils/platform/oracle/OracleModelLoader.java
M src/org/apache/ddlutils/platform/postgresql/PostgreSqlModelLoader.java
M src/org/openbravo/ddlutils/task/AlterDatabaseDataAll.java
M src/org/openbravo/ddlutils/task/DatabaseUtils.java
M src/org/openbravo/ddlutils/util/DBSMOBUtil.java
R src/org/openbravo/ddlutils/task/AlterDatabaseDataMod.java
R src/org/openbravo/ddlutils/task/AlterDatabaseModJava.java
---
(0129392)
hgbot (developer)
2021-06-11 10:18

Repository: https://gitlab.com/openbravo/product/openbravo [^]
Changeset: 22f02a99f5c0a72d95a403d47af6e15d080190fe
Author: Stefan Huehner <stefan.huehner@openbravo.com>
Date: 2021-06-11T10:17:06+02:00
URL: https://gitlab.com/openbravo/product/openbravo/-/commit/22f02a99f5c0a72d95a403d47af6e15d080190fe [^]

ISSUE-47036: Remove outdated comment mentiond update.database.mod

Remove obsolete comment now that update.database.mod is fully gone

---
M src-core/src/org/openbravo/modulescript/ModuleScript.java
---
(0129393)
hgbot (developer)
2021-06-11 10:18

Repository: https://gitlab.com/openbravo/product/openbravo [^]
Changeset: 5c9721a21dc89e884c13b3bfb31df376e727ffdb
Author: Stefan Huehner <stefan.huehner@openbravo.com>
Date: 2021-06-11T10:17:06+02:00
URL: https://gitlab.com/openbravo/product/openbravo/-/commit/5c9721a21dc89e884c13b3bfb31df376e727ffdb [^]

fixes ISSUE-47036; fixes ISSUE-45729; fixes ISSUE-47047; fixes ISSUE-28703

dbsm including the fixes for:

ISSUE-47036: Remove lots of obsolete support code for obsolete
    (update.database.mod, ezattributes module, dbmanager.jar references)
ISSUE-45729: export.database fails with some views on oracle with:
    An invalid XML character (Unicode: 0x0) was found in the CDATA section.
ISSUE-47047: Reading tables part of PostgreSQL modelloader could be simplified and speed up
ISSUE-28703: dbmanager.jar & src-db/src removal

---
M src-db/database/lib/dbsourcemanager.jar
---

- Issue History
Date Modified Username Field Change
2021-06-09 11:35 shuehner New Issue
2021-06-09 11:35 shuehner Assigned To => platform
2021-06-09 11:35 shuehner Modules => Core
2021-06-09 11:35 shuehner Triggers an Emergency Pack => No
2021-06-09 11:38 shuehner Relationship added blocks 0028703
2021-06-09 11:38 shuehner Relationship added blocks 0032688
2021-06-09 13:11 shuehner Note Added: 0129260
2021-06-09 13:32 hgbot Resolution open => fixed
2021-06-09 13:32 hgbot Status new => resolved
2021-06-09 13:32 hgbot Note Added: 0129263
2021-06-09 15:12 shuehner Relationship added depends on 0029853
2021-06-09 20:02 shuehner Target Version => PR21Q3
2021-06-09 20:02 shuehner Assigned To platform => shuehner
2021-06-09 22:17 shuehner Relationship added blocks 0047047
2021-06-11 10:18 hgbot Note Added: 0129392
2021-06-11 10:18 hgbot Fixed in Version => PR21Q3
2021-06-11 10:18 hgbot Note Added: 0129393
2021-06-16 13:40 alostale Review Assigned To => alostale
2021-06-16 13:40 alostale Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker