Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0046980
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[POS2] POSmajoralways2021-06-03 13:272021-06-14 18:59
ReporterdmiguelezView Statuspublic 
Assigned Toprakashmurugesan88 
PriorityhighResolutionopenFixed in Version
StatusscheduledFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget VersionTAP
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0046980: Set focus of Customer Form windows in the first field when opened

DescriptionWhen opening the Customer Form Windows (Search Customer and New/Edit Customer) the focus should be always set on the first field so the user can start introducing data right away.
Steps To ReproduceIn the POS click on the customer icon
The Window shown is the Search Customer Form.
Check that the focus is not set on the first field.

Click on New Customer Button.
The Window shown is the New/Edit Customer Form.
Check that the focus is not set on the first field.
Proposed SolutionAfter some developments, it is possible to define the focus of a form:
https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/commit/303585aac2afdb7e2b2db81711e074b295a0b6c5 [^]

This can be done through the form handler (for example, CustomerFormHandler.js)
When performing an action, like onLoad, the returned new State can include the field that should be focused.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0046979 closedprakashmurugesan88 JIRA-1759: Set focus of Customer Form windows in the first field when opened 

-  Notes
(0129347)
prakashmurugesan88 (developer)
2021-06-10 13:56

Merge Request Created,
https://gitlab.com/obcustomers/AGAP/org.openbravo.pos2/-/merge_requests/54 [^]
(0129397)
prakashmurugesan88 (developer)
2021-06-11 10:20

Pushed changes,

https://gitlab.com/obcustomers/AGAP/org.openbravo.pos2/-/commit/c7d631b2ecb1f6d5f0cc3bbb98880af67686de15 [^]
(0129491)
dmiguelez (developer)
2021-06-14 18:59

Reopened due to Issue: https://issues.openbravo.com/view.php?id=47128 [^]

- Issue History
Date Modified Username Field Change
2021-06-03 13:28 dmiguelez Type defect => backport
2021-06-03 13:28 dmiguelez Target Version => TAP
2021-06-03 13:28 dmiguelez Status scheduled => acknowledged
2021-06-08 11:11 dmiguelez Assigned To Retail => prakashmurugesan88
2021-06-08 11:20 dmiguelez Status acknowledged => scheduled
2021-06-10 13:56 prakashmurugesan88 Note Added: 0129347
2021-06-11 10:20 prakashmurugesan88 Note Added: 0129397
2021-06-11 10:20 prakashmurugesan88 Status scheduled => resolved
2021-06-11 10:20 prakashmurugesan88 Resolution open => fixed
2021-06-11 10:21 prakashmurugesan88 Status resolved => closed
2021-06-14 18:59 dmiguelez Note Added: 0129491
2021-06-14 18:59 dmiguelez Status closed => new
2021-06-14 18:59 dmiguelez Resolution fixed => open
2021-06-14 18:59 dmiguelez Status new => scheduled


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker