Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0046957
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[POS2] POSmajoralways2021-06-02 13:442021-07-29 08:24
ReporterjmelinView Statuspublic 
Assigned Toagonzalez 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version7.x
OS VersionOpenbravo Appliance 14.04Database version9.3.xAnt version1.9.x
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0046957: JIRA 933 - Button to reprint last order ticket

DescriptionFrom the cash desk, a quick access key should allow printing of the last receipt. This functionality can be used in case of demat or ticket <X €.

If a new ticket is started, the previous ticket will need to be printed.

On the new UX / UI, this key will be positioned at the top right of the screen and always visible.

Be careful to increase the printing counter.

See also https://docs.google.com/document/d/1wItBULYOeCcOgKFLcmflQvG2qYPsIbZ4OtVwkCHvcR8/edit# [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0128937)
jmelin (developer)
2021-06-02 13:47

To estimate first
(0130390)
hgbot (developer)
2021-07-12 23:03

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/603 [^]
(0130841)
hgbot (developer)
2021-07-28 15:23

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/603 [^]
(0130862)
hgbot (developer)
2021-07-29 08:24

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/648 [^]
(0130863)
hgbot (developer)
2021-07-29 08:24

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2 [^]
Changeset: 2f2a6fda0fe5846b793183d26d31522bb1fe7e99
Author: David Miguelez <david.miguelez@openbravo.com>
Date: 2021-07-29T06:24:18+00:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/commit/2f2a6fda0fe5846b793183d26d31522bb1fe7e99 [^]

Related to ISSUE-46957. Set onCreateDefault value for mandatory column.

    Since this column is included in the Organization table and this table
    does not tend to be a high volume table it is better to properly
    initiallize this column instead of having to manage null values.

---
M src-db/database/model/modifiedTables/AD_ORG.xml
---
(0130864)
hgbot (developer)
2021-07-29 08:24

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/648 [^]

- Issue History
Date Modified Username Field Change
2021-06-02 13:44 jmelin New Issue
2021-06-02 13:44 jmelin Assigned To => Retail
2021-06-02 13:44 jmelin Triggers an Emergency Pack => No
2021-06-02 13:47 jmelin Note Added: 0128937
2021-06-02 13:47 jmelin Description Updated View Revisions
2021-06-02 13:47 jmelin Steps to Reproduce Updated View Revisions
2021-06-14 09:32 guilleaer Status new => acknowledged
2021-06-14 09:33 guilleaer Resolution time => 1625176800
2021-07-12 23:03 hgbot Note Added: 0130390
2021-07-13 17:43 dmiguelez Status acknowledged => scheduled
2021-07-13 17:43 dmiguelez Assigned To Retail => agonzalez
2021-07-27 13:06 dmiguelez Resolution time 1625176800 => 1627423200
2021-07-28 15:23 hgbot Note Added: 0130841
2021-07-28 15:23 dmiguelez Status scheduled => resolved
2021-07-28 15:23 dmiguelez Resolution open => fixed
2021-07-28 15:23 dmiguelez Status resolved => closed
2021-07-29 08:24 hgbot Note Added: 0130862
2021-07-29 08:24 hgbot Note Added: 0130863
2021-07-29 08:24 hgbot Note Added: 0130864


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker