Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0046538
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] Coretrivialalways2021-05-06 09:092021-09-24 12:16
ReportermigueldejuanaView Statuspublic 
Assigned ToRetail 
PrioritynormalResolutionopenFixed in Version
StatusacknowledgedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0046538: Apply button in discount should be disabled by default

Description- In Discounts window, Apply button should be disabled till we have applied changes.
Steps To Reproducen/a
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0130590)
hgbot (developer)
2021-07-19 21:13

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/614 [^]
(0130726)
hgbot (developer)
2021-07-23 12:44

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2 [^]
Changeset: cdeed6abf816fbc126bf132e03a26bc96ec31f37
Author: hernan-dp <h.de.prada1@gmail.com>
Date: 2021-07-23T10:43:59+00:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/commit/cdeed6abf816fbc126bf132e03a26bc96ec31f37 [^]

fixes ISSUE-46538: Apply button in discount disabled when no changes applied.

---
M web-jspack/org.openbravo.pos2/src/components/Discounts/ManualDiscount/DiscountPanel/DiscountPanel.config.json
---
(0130727)
hgbot (developer)
2021-07-23 12:44

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/614 [^]
(0130728)
dmiguelez (developer)
2021-07-23 12:45

Related commit:
https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/commit/03ae615a813710084f6e1ba2b08cb0bab81de985 [^]
(0130842)
hgbot (developer)
2021-07-28 15:54

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/merge_requests/613 [^]
(0130843)
hgbot (developer)
2021-07-28 15:54

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/merge_requests/613 [^]
(0130844)
hgbot (developer)
2021-07-28 15:55

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/644 [^]
(0130845)
hgbot (developer)
2021-07-28 15:59

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/merge_requests/614 [^]
(0130846)
hgbot (developer)
2021-07-28 16:06

Merge request closed: https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/merge_requests/614 [^]
(0130847)
hgbot (developer)
2021-07-28 16:06

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/644 [^]
(0130848)
hgbot (developer)
2021-07-28 16:07

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2 [^]
Changeset: 82ae4a92fa557d8426fe6fabc0f0fb90061e5720
Author: hernan-dp <h.de.prada1@gmail.com>
Date: 2021-07-28T10:54:26-03:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/commit/82ae4a92fa557d8426fe6fabc0f0fb90061e5720 [^]

Revert "fixes ISSUE-46538: Apply button in discount disabled when no changes applied."

This reverts commit cdeed6abf816fbc126bf132e03a26bc96ec31f37.

---
M web-jspack/org.openbravo.pos2/src/components/Discounts/ManualDiscount/DiscountPanel/DiscountPanel.config.json
---
(0130849)
dmiguelez (developer)
2021-07-28 16:10

Fix has been reverted.

The reason is that, even if the fix is correct, it is possible to implement a better solution that does not required to use the state to communicate both react components

- Issue History
Date Modified Username Field Change
2021-05-06 09:09 migueldejuana New Issue
2021-05-06 09:09 migueldejuana Assigned To => Retail
2021-05-06 09:09 migueldejuana Triggers an Emergency Pack => No
2021-05-07 12:28 guilleaer Resolution time => 1625436000
2021-05-07 12:29 guilleaer Status new => acknowledged
2021-07-14 13:30 dmiguelez Resolution time 1625436000 => 1633039200
2021-07-19 21:06 hernan-dp Assigned To Retail => hernan-dp
2021-07-19 21:07 hernan-dp Status acknowledged => scheduled
2021-07-19 21:13 hgbot Note Added: 0130590
2021-07-23 12:44 hgbot Resolution open => fixed
2021-07-23 12:44 hgbot Status scheduled => closed
2021-07-23 12:44 hgbot Note Added: 0130726
2021-07-23 12:44 hgbot Note Added: 0130727
2021-07-23 12:45 dmiguelez Note Added: 0130728
2021-07-28 15:54 hgbot Note Added: 0130842
2021-07-28 15:54 hgbot Note Added: 0130843
2021-07-28 15:55 hgbot Note Added: 0130844
2021-07-28 15:59 hgbot Note Added: 0130845
2021-07-28 16:06 hgbot Note Added: 0130846
2021-07-28 16:06 hgbot Note Added: 0130847
2021-07-28 16:07 hgbot Note Added: 0130848
2021-07-28 16:10 dmiguelez Note Added: 0130849
2021-07-28 16:10 dmiguelez Status closed => new
2021-07-28 16:10 dmiguelez Resolution fixed => open
2021-07-28 16:10 dmiguelez Status new => acknowledged
2021-08-30 12:45 dmiguelez Assigned To hernan-dp => Retail
2021-09-15 12:23 guilleaer Assigned To Retail => prakashmurugesan88
2021-09-15 12:24 guilleaer Assigned To prakashmurugesan88 => migueldejuana
2021-09-16 14:18 guilleaer Assigned To migueldejuana => Retail
2021-09-24 09:04 prakashmurugesan88 Assigned To Retail => prakashmurugesan88
2021-09-24 09:04 prakashmurugesan88 Status acknowledged => scheduled
2021-09-24 12:16 prakashmurugesan88 Assigned To prakashmurugesan88 => Retail
2021-09-24 12:16 prakashmurugesan88 Status scheduled => acknowledged


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker