Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0046352
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] POSmajoralways2021-04-26 12:342021-05-04 12:14
ReporterjmelinView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version7.x
OS VersionOpenbravo Appliance 14.04Database version9.3.xAnt version1.9.x
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0046352: JIRA 1731 - BP Assignation - message 'Cannot read property 'properties' of undefined'

DescriptionThis issue can not be reproduced on livebuild because the restaurant filter is not available.
Steps To Reproduce1. Connect to POS
2. Search for a customer without changing the value in the YES/NO combo.
- Check that the result is correctly showed
3. Open the YES/NO combo and select the Default value
- Check that the error in the image (Cannot read property 'properties' of undefined) is showed.


In the Chrome Dev tools we can see that the failing row is the one marked in ***
  const searchBusinessPartners = async formState => {
    let filters = {};
    const filterValues = formState.fields;
    // filterValues keep in handler because it is necessary recover filterValues when back to search
    customerSelectorHandler.setFilterValues(filterValues);
    if (filterValues) {
 *** filters = Object.entries(filterValues).map(([key, value]) => {
        const foundComponent = formState.componentList.find(
          component => component.properties.name === key
        );
        return {
          column: key,
          hqlFilter: undefined,
          isId: undefined,
          operator: '=',
          value: value.value,
          label: foundComponent.properties.label
        };
      });
    }

The error in the console is:
VM943:1 Uncaught ReferenceError: filterValues is not defined
    at eval (eval at <anonymous> (CustomerSelector.jsx:82), <anonymous>:1:16)
    at CustomerSelector.jsx:82
    at Array.map (<anonymous>)
    at Ie.l.addFormAction.validateForm (CustomerSelector.jsx:72)
    at Ce.execute (FormHandler.js:133)
    at A (BaseForm.jsx:388)3

TagsTakeaway
Attached Filespng file icon 6bc2a682-e170-4f0b-95d3-d212c3e3f2b3.png [^] (45,102 bytes) 2021-04-26 12:35


png file icon 3497137a-b535-4ff7-850b-e4a516313d7f.png [^] (52,702 bytes) 2021-04-26 12:35

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0046411TAP resolvedranjith_qualiantech_com JIRA 1731 - BP Assignation - message 'Cannot read property 'properties' of undefined' 

-  Notes
(0127768)
ranjith_qualiantech_com (developer)
2021-05-04 12:03

Its fixed in Commit https://gitlab.com/openbravo/product/pmods/org.openbravo.core2/-/commit/fa38d1b55bcff10ad005c5653123d8f54324d07b [^]

- Issue History
Date Modified Username Field Change
2021-04-26 12:34 jmelin New Issue
2021-04-26 12:34 jmelin Assigned To => Retail
2021-04-26 12:34 jmelin Triggers an Emergency Pack => No
2021-04-26 12:34 jmelin Tag Attached: Takeaway
2021-04-26 12:35 jmelin File Added: 6bc2a682-e170-4f0b-95d3-d212c3e3f2b3.png
2021-04-26 12:35 jmelin File Added: 3497137a-b535-4ff7-850b-e4a516313d7f.png
2021-04-26 16:17 javietxe Steps to Reproduce Updated View Revisions
2021-04-26 16:30 javietxe Steps to Reproduce Updated View Revisions
2021-04-27 12:20 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2021-04-29 10:29 guilleaer Status new => scheduled
2021-05-04 12:03 ranjith_qualiantech_com Note Added: 0127768
2021-05-04 12:03 ranjith_qualiantech_com Status scheduled => resolved
2021-05-04 12:03 ranjith_qualiantech_com Resolution open => fixed
2021-05-04 12:14 guilleaer Review Assigned To => guilleaer
2021-05-04 12:14 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker