Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0046226
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] RT-Servermajoralways2021-04-07 16:422021-04-16 23:30
ReporterucarrionView Statuspublic 
Assigned Torqueralta 
PriorityurgentResolutionopenFixed in Version
StatusscheduledFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0046226: The Fiscal Reference Document popup info is not infomed in the printed ticket

DescriptionWhenever a blind return is done using the RT Server module, a popup is shown when clicking the checkout button. This is a popup in which some info is requested to be filled in case the cashier wants to enter some info comming from other system or similars (the popup is optional).
In case this popup is filled, the blind return is considered as verified return so the printed template changes. Currently this is not taken into account and the information inserted in that popup is not informed in the printed ticket.
Steps To Reproduce-Login a webpos till
-Add a product
-Press the line and select the 'Return line' butto
-Press the checkout button
-A popup is raised, update the info (fill all the fields)
-Return the amount
-Complete the transaction
-Check that the information set into the popup is not printed
TagsNo tags attached.
Attached Filesdiff file icon 07cc7ddab62931ec4842d29d51bea4f9568b6015.diff [^] (967 bytes) 2021-04-15 15:57 [Show Content]
diff file icon 1982edf6cf5bf5252bbff5b9efd0e3662526639f.diff [^] (1,157 bytes) 2021-04-15 15:57 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0045857 closedranjith_qualiantech_com Italian Localization - The lottery code popup must not be displayed for return transactions 
has duplicate defect 0046270 closedRetail Logic that controls the Lottery panel when user navigates to Payment tab is not fully correct 

-  Notes
(0127277)
ucarrion (developer)
2021-04-14 20:30

Has been handled by services team. To be closed

- Issue History
Date Modified Username Field Change
2021-04-07 16:42 ucarrion New Issue
2021-04-07 16:42 ucarrion Assigned To => psanjuan
2021-04-07 16:42 ucarrion Triggers an Emergency Pack => No
2021-04-12 10:39 psanjuan Assigned To psanjuan => Retail
2021-04-14 17:04 ucarrion Relationship added caused by 0045857
2021-04-14 20:30 ucarrion Note Added: 0127277
2021-04-14 20:30 ucarrion Status new => closed
2021-04-14 20:30 ucarrion Resolution open => suspended
2021-04-15 15:56 jorgewederago Status closed => new
2021-04-15 15:56 jorgewederago Resolution suspended => open
2021-04-15 15:57 jorgewederago File Added: 07cc7ddab62931ec4842d29d51bea4f9568b6015.diff
2021-04-15 15:57 jorgewederago File Added: 1982edf6cf5bf5252bbff5b9efd0e3662526639f.diff
2021-04-15 18:31 marvintm Relationship added has duplicate 0046270
2021-04-16 23:30 rqueralta Assigned To Retail => rqueralta
2021-04-16 23:30 rqueralta Status new => scheduled


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker