Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0046187
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POScriticalsometimes2021-03-30 16:312021-04-20 17:16
ReportercbrazierView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityurgentResolutionfixedFixed in VersionRR21Q3
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - Confirmed Stable
Regression date2020-04-06
Regression introduced in releaseRR20Q3
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/00f799553369f73469ee678dcede357c099d5032 [^] [^]
Triggers an Emergency PackNo
Summary

0046187: WebPOS triggered unexpected Full Refresh

DescriptionAfter compiling Openbravo and restarting Tomcat, WebPOS triggered a Full Refresh but no model was changed and the delay to execute the full refresh is not reached.
It seems to be related to model property using OBContext to build model HQL Properties
Steps To Reproduceant run.compile.complete.deploy
restart tomcat
Run WebPOS

I'm not able to reproduce it every time
TagsNOR
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0046182 newRetail Refactor/improve of Promo Engine and full / incremental refresh to remove the ProductCharacteristicsValue model 
related to feature request 0046074 newRetail Models with multiple queries do not accept pagination by Id 
related to feature request 0046183 newRetail Hierarchy of Price Lists: development to reduce number of records M_PRODUCTPRICE 
depends on backport 0046285RR21Q2.1 resolvedranjith_qualiantech_com WebPOS triggered unexpected Full Refresh 
depends on backport 0046286RR21Q1.2 resolvedranjith_qualiantech_com WebPOS triggered unexpected Full Refresh 
depends on backport 0046287RR20Q4.4 resolvedranjith_qualiantech_com WebPOS triggered unexpected Full Refresh 
caused by feature request 0043657 closedSandrahuguet Masterdata IndexedDB - Phase 1 
related to defect 0046280 closedgorka_gil Full refresh should be executed every time there are model changes, but sometimes it doesn't happen 

-  Notes
(0127167)
hgbot (developer)
2021-04-08 09:07

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/merge_requests/203 [^]
(0127168)
hgbot (developer)
2021-04-08 09:07

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.complementary/-/merge_requests/9 [^]
(0127169)
hgbot (developer)
2021-04-08 09:07

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.bypaymentmethod/-/merge_requests/7 [^]
(0127170)
hgbot (developer)
2021-04-08 09:07

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.bytotal/-/merge_requests/9 [^]
(0127171)
hgbot (developer)
2021-04-08 09:08

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.combo/-/merge_requests/11 [^]
(0127172)
hgbot (developer)
2021-04-08 09:08

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.scaledprice/-/merge_requests/4 [^]
(0127313)
hgbot (developer)
2021-04-16 13:54

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/merge_requests/203 [^]
(0127314)
hgbot (developer)
2021-04-16 13:54

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core [^]
Changeset: 056f38a7f113b10996cb1c6f1f13e1fe107248de
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2021-04-16T11:52:03+00:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/commit/056f38a7f113b10996cb1c6f1f13e1fe107248de [^]

Fixed ISSUE-46187: Updated MasterData ModelProperties to get JSONName instead of HQLProperty
* To Calculate hash value, JsonName should be used instead of HQLProperty from Modelproperties

---
M src/org/openbravo/mobile/core/master/MasterDataProcessHQLQuery.java
---
(0127315)
hgbot (developer)
2021-04-16 13:54

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.complementary [^]
Changeset: d1a1656ad782788a822b59ef3d9d99e10ee47cda
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2021-04-12T12:54:55+05:30
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.complementary/-/commit/d1a1656ad782788a822b59ef3d9d99e10ee47cda [^]

Related to ISSUE-46187: Updated MasterData ModelProperties to get JSONName instead of HQLProperty
* To Calculate hash value, JsonName should be used instead of HQLProperty from Modelproperties

---
M src/org/openbravo/retail/complementary/master/ComplementaryProducts.java
---
(0127316)
hgbot (developer)
2021-04-16 13:54

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.complementary/-/merge_requests/9 [^]
(0127317)
hgbot (developer)
2021-04-16 13:54

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.bypaymentmethod [^]
Changeset: 67b9c0463ca22ffbce5b656cc36c940e08e6e2d6
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2021-04-12T12:55:03+05:30
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.bypaymentmethod/-/commit/67b9c0463ca22ffbce5b656cc36c940e08e6e2d6 [^]

Related to ISSUE-46187: Updated MasterData ModelProperties to get JSONName instead of HQLProperty
* To Calculate hash value, JsonName should be used instead of HQLProperty from Modelproperties

---
M src/org/openbravo/retail/discounts/bypaymentmethod/PaymentMethodDiscount.java
---
(0127318)
hgbot (developer)
2021-04-16 13:54

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.bypaymentmethod/-/merge_requests/7 [^]
(0127319)
hgbot (developer)
2021-04-16 13:54

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.bytotal [^]
Changeset: c6459e3eec5fb84266014677959b61f63935ce75
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2021-04-12T12:55:11+05:30
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.bytotal/-/commit/c6459e3eec5fb84266014677959b61f63935ce75 [^]

Related to ISSUE-46187: Updated MasterData ModelProperties to get JSONName instead of HQLProperty
* To Calculate hash value, JsonName should be used instead of HQLProperty from Modelproperties

---
M src/org/openbravo/retail/discounts/bytotal/master/FreeProduct.java
---
(0127320)
hgbot (developer)
2021-04-16 13:54

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.bytotal/-/merge_requests/9 [^]
(0127321)
hgbot (developer)
2021-04-16 13:54

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.combo [^]
Changeset: 5d47b1703f1bcd910d1f5eb84acb14b14ded19b9
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2021-04-12T12:55:14+05:30
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.combo/-/commit/5d47b1703f1bcd910d1f5eb84acb14b14ded19b9 [^]

Related to ISSUE-46187: Updated MasterData ModelProperties to get JSONName instead of HQLProperty
* To Calculate hash value, JsonName should be used instead of HQLProperty from Modelproperties

---
M src/org/openbravo/retail/discounts/combo/master/Family.java
---
(0127322)
hgbot (developer)
2021-04-16 13:54

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.combo/-/merge_requests/11 [^]
(0127323)
hgbot (developer)
2021-04-16 13:54

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.scaledprice [^]
Changeset: 3d428a0158faf29818cbea03e9ec7188213d9d7c
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2021-04-12T12:55:18+05:30
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.scaledprice/-/commit/3d428a0158faf29818cbea03e9ec7188213d9d7c [^]

Related to ISSUE-46187: Updated MasterData ModelProperties to get JSONName instead of HQLProperty
* To Calculate hash value, JsonName should be used instead of HQLProperty from Modelproperties

---
M src/org/openbravo/retail/discounts/scaledprice/ScaledPrice.java
---
(0127324)
hgbot (developer)
2021-04-16 13:54

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts.scaledprice/-/merge_requests/4 [^]

- Issue History
Date Modified Username Field Change
2021-03-30 16:31 cbrazier New Issue
2021-03-30 16:31 cbrazier Assigned To => Retail
2021-03-30 16:31 cbrazier Triggers an Emergency Pack => No
2021-03-30 16:53 rafaroda Tag Attached: NOR
2021-03-30 16:53 rafaroda Relationship added related to 0046182
2021-03-30 16:53 rafaroda Relationship added related to 0046074
2021-03-30 16:53 rafaroda Relationship added related to 0046183
2021-03-30 17:12 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2021-03-30 17:17 shuehner Issue Monitored: shuehner
2021-04-08 09:07 hgbot Note Added: 0127167
2021-04-08 09:07 hgbot Note Added: 0127168
2021-04-08 09:07 hgbot Note Added: 0127169
2021-04-08 09:07 hgbot Note Added: 0127170
2021-04-08 09:08 hgbot Note Added: 0127171
2021-04-08 09:08 hgbot Note Added: 0127172
2021-04-16 10:11 marvintm Relationship added related to 0046280
2021-04-16 12:52 marvintm Status new => scheduled
2021-04-16 13:54 hgbot Resolution open => fixed
2021-04-16 13:54 hgbot Status scheduled => closed
2021-04-16 13:54 hgbot Note Added: 0127313
2021-04-16 13:54 hgbot Fixed in Version => RR21Q3
2021-04-16 13:54 hgbot Note Added: 0127314
2021-04-16 13:54 hgbot Note Added: 0127315
2021-04-16 13:54 hgbot Note Added: 0127316
2021-04-16 13:54 hgbot Note Added: 0127317
2021-04-16 13:54 hgbot Note Added: 0127318
2021-04-16 13:54 hgbot Note Added: 0127319
2021-04-16 13:54 hgbot Note Added: 0127320
2021-04-16 13:54 hgbot Note Added: 0127321
2021-04-16 13:54 hgbot Note Added: 0127322
2021-04-16 13:54 hgbot Note Added: 0127323
2021-04-16 13:54 hgbot Note Added: 0127324
2021-04-19 06:59 marvintm Regression level => Production - Confirmed Stable
2021-04-19 06:59 marvintm Regression introduced in release => RR20Q3
2021-04-19 06:59 marvintm Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/00f799553369f73469ee678dcede357c099d5032 [^] [^]
2021-04-19 06:59 marvintm Regression date => 2020-04-06
2021-04-19 15:55 marvintm Status closed => new
2021-04-19 15:55 marvintm Resolution fixed => open
2021-04-19 15:55 marvintm Fixed in Version RR21Q3 =>
2021-04-19 15:55 marvintm Status new => scheduled
2021-04-19 15:55 marvintm Status scheduled => resolved
2021-04-19 15:55 marvintm Fixed in Version => RR21Q3
2021-04-19 15:55 marvintm Resolution open => fixed
2021-04-19 15:55 marvintm Review Assigned To => marvintm
2021-04-19 15:55 marvintm Status resolved => closed
2021-04-20 17:16 dmitry_mezentsev Relationship added caused by 0043657


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker