Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0046049
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2021-03-11 12:502021-03-29 07:00
ReporterucarrionView Statuspublic 
Assigned Torqueralta 
PrioritynormalResolutionduplicateFixed in VersionRR21Q1
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0046049: The 'More...' button on the payment tab is not in green depending on the payment method selected

DescriptionNormally, whenever a payment inside the 'More...' popup is selected and then the popup is closed, that 'More...' button should be in green. This is not occurring when the payment selected is a provider group/payment provider.

Steps To Reproduceprecond: a payment provider/provider group payment must be enabled and set into a Line No so it is included into the 'More...' payment popup.

-Login the webpos
-Add a product
-Press the checkout button
-Press the 'More...' button
-In the popup select the mentioned payment
-Close the popup and check that the 'More...' button is always in grey
TagsNo tags attached.
Attached Filespng file icon Captura de pantalla 2021-03-22 a las 9.10.30.png [^] (29,262 bytes) 2021-03-22 09:10


patch file icon 0001-Fix-BUG-46049-Payment-DialogButton-should-be-updated.patch [^] (1,117 bytes) 2021-03-26 23:36 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
duplicate of defect 0045337 closedranjith_qualiantech_com Payment name is not informed in "More" button with Group Providers 

-  Notes
(0126821)
marvintm (developer)
2021-03-22 09:10

We haven't been able to reproduce this issue. When testing with terminal YS-11 in an instance with ext modules, the "More" button remains checked when a payment method inside the "More" popup is selected:

https://livebuilds.openbravo.com/retail_modules_pgsql_pi/web/org.openbravo.retail.posterminal/?terminal=YS-11#retail.pointofsale [^]

We attached a screenshot of this behaviour.
(0126878)
ucarrion (developer)
2021-03-24 09:28

The issue is reproduced in livebuils 19Q4 version. Check this video please: https://drive.google.com/file/d/1UtltNtDV4caTeEO57R9WyTrEKZ8eLD5F/view [^]
(0126962)
marvintm (developer)
2021-03-29 07:00

Duplicated: https://issues.openbravo.com/view.php?id=45337 [^]

It seems the patch for issue 45337 should be directly applicable in 19Q3.

- Issue History
Date Modified Username Field Change
2021-03-11 12:50 ucarrion New Issue
2021-03-11 12:50 ucarrion Assigned To => Retail
2021-03-11 12:50 ucarrion Resolution time => 1617228000
2021-03-11 12:50 ucarrion Triggers an Emergency Pack => No
2021-03-11 12:51 jorgewederago Issue Monitored: jorgewederago
2021-03-11 13:07 ucarrion Severity minor => major
2021-03-11 17:23 rqueralta Assigned To Retail => rqueralta
2021-03-11 17:23 rqueralta Status new => scheduled
2021-03-22 09:10 marvintm Review Assigned To => marvintm
2021-03-22 09:10 marvintm Note Added: 0126821
2021-03-22 09:10 marvintm Status scheduled => closed
2021-03-22 09:10 marvintm Resolution open => unable to reproduce
2021-03-22 09:10 marvintm File Added: Captura de pantalla 2021-03-22 a las 9.10.30.png
2021-03-24 09:28 ucarrion Assigned To rqueralta => marvintm
2021-03-24 09:28 ucarrion Note Added: 0126878
2021-03-24 09:28 ucarrion Status closed => new
2021-03-24 09:28 ucarrion Resolution unable to reproduce => open
2021-03-25 08:12 marvintm Assigned To marvintm => Retail
2021-03-26 23:36 rqueralta File Added: 0001-Fix-BUG-46049-Payment-DialogButton-should-be-updated.patch
2021-03-26 23:49 rqueralta Assigned To Retail => rqueralta
2021-03-26 23:50 rqueralta Status new => scheduled
2021-03-29 07:00 marvintm Relationship added duplicate of 0045337
2021-03-29 07:00 marvintm Note Added: 0126962
2021-03-29 07:00 marvintm Status scheduled => closed
2021-03-29 07:00 marvintm Resolution open => duplicate
2021-03-29 07:00 marvintm Fixed in Version => RR21Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker