Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0045583
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2020-12-15 16:462021-01-15 04:38
ReporterucarrionView Statuspublic 
Assigned Torqueralta 
PrioritynormalResolutionopenFixed in Version
StatusnewFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0045583: Impossible to complete the Terminal Authentication process with a expired password user

DescriptionLet's imagine that a new user has just been created with a standard password in order to let the user set a new one in the first login.

In case this user needs to complete the Terminal Authentication process the system is showing a message informing about that expired password
Steps To ReproduceLogin backend
Go to user window
Create a new user, set a password and check the 'Expired password' flag
Enable the Terminal Authentication process (preference)
Open a new unlinked till and try to login with the just created new user
Check the message displayed by the system
Proposed SolutionFrom a functional point of view I would say that the expired password should be only take into account in the login process and not in the terminal authentication process. Anyway, whatever the decission is, the user must be able to arrive to the login screen where the new password will be requested by the system
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0125295)
hgbot (developer)
2021-01-07 16:37

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/245 [^]
(0125296)
hgbot (developer)
2021-01-07 16:37

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/merge_requests/123 [^]
(0125301)
hgbot (developer)
2021-01-07 19:49

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/245 [^]
(0125302)
hgbot (developer)
2021-01-07 19:49

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal [^]
Changeset: 4b2d28744e7b76a7d878cc95a46ac89ca5e89159
Author: Rafael Queralta <rafaelcuba81@gmail.com>
Date: 2021-01-07T15:38:12+00:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/commit/4b2d28744e7b76a7d878cc95a46ac89ca5e89159 [^]

Fixed BUG-45583: If the user password expired, change it is required to complete the Terminal Authentication process

---
M src/org/openbravo/retail/posterminal/LoginUtilsServlet.java
M web/org.openbravo.retail.posterminal/js/login/model/login-model.js
---
(0125303)
hgbot (developer)
2021-01-07 19:49

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core [^]
Changeset: 43dcc5f0bef78717e5731b5f1a42707dce16964b
Author: Rafael Queralta <rafaelcuba81@gmail.com>
Date: 2021-01-07T15:38:34+00:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/commit/43dcc5f0bef78717e5731b5f1a42707dce16964b [^]

Fixed BUG-45583: Reload location window was required to avoid screen without any component after close the popup.

---
M web/org.openbravo.mobile.core/source/component/dialog/ob-expirationpassword.js
---
(0125304)
hgbot (developer)
2021-01-07 19:49

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/merge_requests/123 [^]
(0125305)
hgbot (developer)
2021-01-07 19:49

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core [^]
Changeset: a0ad9054009d1c43485593bdadf833e7dc7e0990
Author: Rafael Queralta <rafaelcuba81@gmail.com>
Date: 2021-01-07T13:44:52-05:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/commit/a0ad9054009d1c43485593bdadf833e7dc7e0990 [^]

Fixed BUG-45583: Reload location window was required to avoid screen without any component after close the popup.

---
M web/org.openbravo.mobile.core/source/component/dialog/ob-expirationpassword.js
---
(0125318)
hgbot (developer)
2021-01-08 10:00

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core [^]
Changeset: a606f1474afed3546bf9a7ae6eb8047ee3c1bfb0
Author: Guillermo Alvarez de Eulate <guillermo.alvarez@openbravo.com>
Date: 2021-01-08T08:39:31+01:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/commit/a606f1474afed3546bf9a7ae6eb8047ee3c1bfb0 [^]

Revert "Fixed BUG-45583: Reload location window was required to avoid screen without any component after close the popup."

This reverts commit a0ad9054009d1c43485593bdadf833e7dc7e0990.

---
M web/org.openbravo.mobile.core/source/component/dialog/ob-expirationpassword.js
---
(0125320)
hgbot (developer)
2021-01-08 12:07

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core [^]
Changeset: 79e4f7012c2a9698137993144c53b4ec90995807
Author: Guillermo Alvarez de Eulate <guillermo.alvarez@openbravo.com>
Date: 2021-01-08T12:07:20+01:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/commit/79e4f7012c2a9698137993144c53b4ec90995807 [^]

Revert "Fixed BUG-45583: Reload location window was required to avoid screen without any component after close the popup using cancel"

This reverts commit 43dcc5f0bef78717e5731b5f1a42707dce16964b.

---
M web/org.openbravo.mobile.core/source/component/dialog/ob-expirationpassword.js
---
(0125321)
guilleaer (developer)
2021-01-08 12:08

Reopened

Reverted these changes which are part of the fix
https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/commit/a606f1474afed3546bf9a7ae6eb8047ee3c1bfb0 [^]
https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/commit/79e4f7012c2a9698137993144c53b4ec90995807 [^]

The fix is not complete because if apply/cancel is pressed a gray screen is reached.
Reload is OK for terminal authentication flow but not for the rest of the places where change password popup is used.
(0125473)
hgbot (developer)
2021-01-15 04:37

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/merge_requests/132 [^]
(0125474)
hgbot (developer)
2021-01-15 04:38

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/259 [^]

- Issue History
Date Modified Username Field Change
2020-12-15 16:46 ucarrion New Issue
2020-12-15 16:46 ucarrion Assigned To => Retail
2020-12-15 16:46 ucarrion Triggers an Emergency Pack => No
2020-12-16 08:23 guillermogil Severity minor => major
2020-12-23 17:57 rqueralta Assigned To Retail => rqueralta
2020-12-23 17:58 rqueralta Status new => scheduled
2021-01-05 16:30 rqueralta Status scheduled => resolved
2021-01-05 16:30 rqueralta Resolution open => fixed
2021-01-05 16:31 rqueralta Status resolved => closed
2021-01-05 16:31 rqueralta Status closed => new
2021-01-05 16:31 rqueralta Resolution fixed => open
2021-01-05 16:31 rqueralta Status new => scheduled
2021-01-07 16:37 hgbot Note Added: 0125295
2021-01-07 16:37 hgbot Note Added: 0125296
2021-01-07 19:49 hgbot Resolution open => fixed
2021-01-07 19:49 hgbot Status scheduled => closed
2021-01-07 19:49 hgbot Note Added: 0125301
2021-01-07 19:49 hgbot Fixed in Version => RR21Q2
2021-01-07 19:49 hgbot Note Added: 0125302
2021-01-07 19:49 hgbot Note Added: 0125303
2021-01-07 19:49 hgbot Note Added: 0125304
2021-01-07 19:49 hgbot Note Added: 0125305
2021-01-08 10:00 hgbot Note Added: 0125318
2021-01-08 12:07 hgbot Note Added: 0125320
2021-01-08 12:08 guilleaer Note Added: 0125321
2021-01-08 12:08 guilleaer Status closed => new
2021-01-08 12:08 guilleaer Resolution fixed => open
2021-01-08 12:08 guilleaer Fixed in Version RR21Q2 =>
2021-01-15 04:37 hgbot Note Added: 0125473
2021-01-15 04:38 hgbot Note Added: 0125474


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker