Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0045492
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[New POS] Restaurantsminorhave not tried2020-11-24 10:462021-03-01 11:56
Reportertimothee_catteeuwView Statuspublic 
Assigned Tojorge-garcia 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0045492: 13/11 delivery - Menus are not grouped on the ticket

DescriptionWhen I select twice the same menu with the same articles. I have 2 lines. For same menu and product, it is necessary to group them to the same line.

Below a video with the test :
https://drive.google.com/file/d/14-TuO0z2VPbRIfaQd4t6ip4AI_tqeXk2/view [^]
Steps To ReproduceDo a ticket, select 2 menus manually (the same with same articles)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0124588)
dbaz (developer)
2020-11-24 17:01

If the user tries to change the component of a menu line that is aggrupated (quantity bigger than "1"), it should behave like a receipt line property change, described here: https://docs.google.com/document/d/1Y5jRURbt92qNzHbSdhTyE3y42ag-yo7673_I-ntg8B8/edit#heading=h.748ttdllzfv5 [^]

In this context that means that when this change of a component is invoked a popup with a keypad will be shown to let the user select to how many menus apply the change.
(0124628)
timothee_catteeuw (developer)
2020-11-26 11:15

I don't create another ticket because I think this point is linked to this Mantis.
But I have sometimes the case for articles which are not grouped, example below :

https://drive.google.com/file/d/1bJOF8215_ChwD_hztQXJD1n2SvGkDRCn/view [^]

It seems when selecting articles which can be selected for a menu and when selecting just 1 article, this kind of article are not grouped. Ex : gourde pomme banane.
(0126133)
guilleaer (manager)
2021-02-17 09:12

This issue will be fixed as part of the task nwp3_mealmenuimprovements
(0126422)
guilleaer (manager)
2021-03-01 11:56

https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.restaurant/-/merge_requests/65 [^]

- Issue History
Date Modified Username Field Change
2020-11-24 10:46 timothee_catteeuw New Issue
2020-11-24 10:46 timothee_catteeuw Assigned To => Retail
2020-11-24 10:46 timothee_catteeuw Triggers an Emergency Pack => No
2020-11-24 17:01 dbaz Note Added: 0124588
2020-11-26 11:15 timothee_catteeuw Note Added: 0124628
2020-12-16 17:54 AugustoMauch Status new => scheduled
2020-12-17 10:39 AugustoMauch Issue cloned 0045619
2021-02-17 09:12 guilleaer Assigned To Retail => jorge-garcia
2021-02-17 09:12 guilleaer Note Added: 0126133
2021-03-01 11:56 guilleaer Note Added: 0126422
2021-03-01 11:56 guilleaer Status scheduled => resolved
2021-03-01 11:56 guilleaer Resolution open => fixed
2021-03-01 11:56 guilleaer Review Assigned To => guilleaer
2021-03-01 11:56 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker