Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0045374
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2020-11-04 10:572020-11-24 18:01
Reportersalvador_campanellaView Statuspublic 
Assigned Togorka_gil 
PrioritynormalResolutionfixedFixed in VersionRR21Q1
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0045374: When a product is selected and just after the window refreshes the product line is lost

DescriptionWhen a product is selected and just after the window refreshes the product line is lost
Steps To ReproduceIn the web POS
1.- Select a product
2.- just after the line appears in the receipt press the F5 key

- Error: the line will not be present after finishing the refresh
TagsNo tags attached.
Attached Files? file icon issueRefresh.mp4 [^] (1,861,338 bytes) 2020-11-04 10:57

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0045500RR20Q4 closedgorka_gil When a product is selected and just after the window refreshes the product line is lost 

-  Notes
(0124587)
hgbot (developer)
2020-11-24 16:41

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/merge_requests/106 [^]
(0124600)
hgbot (developer)
2020-11-24 18:01

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/merge_requests/106 [^]
(0124601)
hgbot (developer)
2020-11-24 18:01

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core [^]
Changeset: fdece4975aa08b891703c561b358d91cc33a5935
Author: Gorka Gil <gorka.gil@openbravo.com>
Date: 2020-11-24T17:00:56+00:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/commit/fdece4975aa08b891703c561b358d91cc33a5935 [^]

Fixed ISSUE-45374: capture the unload event to try to persist the state before

It doesn't ensure that the state will be persisted,
since for the asynchronous code there is no way to wait for it,
so in most cases will have time to save the state, but in some not

---
M web/org.openbravo.mobile.core/source/model/ob-terminal-model.js
---

- Issue History
Date Modified Username Field Change
2020-11-04 10:57 salvador_campanella New Issue
2020-11-04 10:57 salvador_campanella Assigned To => Retail
2020-11-04 10:57 salvador_campanella File Added: issueRefresh.mp4
2020-11-04 10:57 salvador_campanella Regression date => 2020-11-25
2020-11-04 10:57 salvador_campanella Triggers an Emergency Pack => No
2020-11-06 10:28 ngarcia Regression date 2020-11-25 =>
2020-11-23 11:14 gorka_gil Assigned To Retail => gorka_gil
2020-11-24 16:41 hgbot Note Added: 0124587
2020-11-24 18:01 hgbot Resolution open => fixed
2020-11-24 18:01 hgbot Status new => closed
2020-11-24 18:01 hgbot Note Added: 0124600
2020-11-24 18:01 hgbot Fixed in Version => RR21Q1
2020-11-24 18:01 hgbot Note Added: 0124601
2020-11-24 18:01 marvintm Status closed => new
2020-11-24 18:01 marvintm Resolution fixed => open
2020-11-24 18:01 marvintm Fixed in Version RR21Q1 =>
2020-11-24 18:01 marvintm Status new => scheduled
2020-11-24 18:01 marvintm Status scheduled => resolved
2020-11-24 18:01 marvintm Fixed in Version => RR21Q1
2020-11-24 18:01 marvintm Resolution open => fixed
2020-11-24 18:01 marvintm Review Assigned To => marvintm
2020-11-24 18:01 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker