Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0045153
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Discounts and Promotionsmajoralways2020-09-28 15:572020-10-26 07:54
ReportercbrazierView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityurgentResolutionfixedFixed in VersionRR21Q1
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRR20Q3SCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0045153: Discount and promotion - Disabling organizations are not sent to WebPOS

DescriptionWhen disabling an organization in a discount, related WebPOS IndexedDB table is not updated and the discount is still applied
Steps To Reproduce1/ Create a promotion / Discount
2/ Add an organization
3/ Run incremental refresh
4/ Disable an organization
5/ Run incremantal refresh
TagsNOR
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0044662 closedranjith_qualiantech_com Discounts are not updated on webpos after incremental refresh 
related to defect 0045154 closedranjith_qualiantech_com Discount and promotion - Filter change are not sent to WebPOS 
related to defect 0045155 closedRetail Discount and promotion- Removing filters are not sent to WebPOS 
related to defect 0045188 closedranjith_qualiantech_com Incremental Refresh fail: continues the load when it should stop 
related to defect 0047288 closedranjith_qualiantech_com Discount and promotion - Disabling pricelist are not sent to WebPOS 

-  Notes
(0123479)
hgbot (developer)
2020-10-01 12:58

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts/-/merge_requests/8 [^]
(0123609)
hgbot (developer)
2020-10-08 06:57

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/124 [^]
(0123643)
hgbot (developer)
2020-10-09 08:33

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal [^]
Changeset: e5ccc5d7bf5102fe5423c1cafef3a90c529d3593
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2020-10-09T06:33:22+00:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/commit/e5ccc5d7bf5102fe5423c1cafef3a90c529d3593 [^]

Related to ISSUE-45153: Added Properties for Discount Master data

---
A src/org/openbravo/retail/posterminal/master/DiscountProperties.java
M src/org/openbravo/retail/posterminal/master/Discount.java
---
(0123644)
hgbot (developer)
2020-10-09 08:33

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/124 [^]
(0123662)
hgbot (developer)
2020-10-12 12:36

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.service.integration.magento.mappings [^]
Changeset: be9e0cc488ed8d46e7d07b6a9e32b1891d9e3709
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2020-10-12T16:06:20+05:30
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.service.integration.magento.mappings/-/commit/be9e0cc488ed8d46e7d07b6a9e32b1891d9e3709 [^]

Related to ISSUE-45153: Added timestamp to Discount Test Data

---
M src-test/org/openbravo/service/integration/magento/mappings/outbound/discounts/data/00-OB.json
M src-test/org/openbravo/service/integration/magento/mappings/outbound/discounts/data/01-OB.json
M src-test/org/openbravo/service/integration/magento/mappings/outbound/discounts/data/02-OB.json
M src-test/org/openbravo/service/integration/magento/mappings/outbound/discounts/data/03-OB.json
---
(0123797)
hgbot (developer)
2020-10-20 10:32

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts [^]
Changeset: e82feefb5a950e3a1f48a4458f85cc9acfaee8e8
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2020-10-05T20:43:00+05:30
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts/-/commit/e82feefb5a950e3a1f48a4458f85cc9acfaee8e8 [^]

Fixed ISSUE-45153: Added EventHandler for Offer Organization Entity
* Offer audit should be updated when there is change in OfferOrg table, since OfferOrg is used in discount query and not as masterdata query
* Added active property with Organization Check in Discount Properties

---
A src/org/openbravo/retail/discounts/event/MOfferOrganizationEventHandler.java
A src/org/openbravo/retail/discounts/master/DiscountFilterProperties.java
---
(0123798)
hgbot (developer)
2020-10-20 10:32

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts/-/merge_requests/8 [^]
(0123829)
hgbot (developer)
2020-10-22 02:50

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts [^]
Changeset: f3088341f91216b3f9286eac751ad37329a12d17
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2020-10-22T06:18:38+05:30
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.discounts/-/commit/f3088341f91216b3f9286eac751ad37329a12d17 [^]

Related to ISSUE-45153: Removed unused Logger variables
* Updatd license year in DiscountFilterProperties file

---
M src/org/openbravo/retail/discounts/event/MOfferOrganizationEventHandler.java
M src/org/openbravo/retail/discounts/master/DiscountFilterProperties.java
---
(0123880)
rafaroda (developer)
2020-10-22 16:33

The fix is not valid: when doign a full refresh, it brings ALL the organizations discounts without organization filter, so we have a regression.

Christophe Brazier has send the patch to Antonio.
(0123911)
hgbot (developer)
2020-10-26 06:07

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/134 [^]
(0123932)
hgbot (developer)
2020-10-26 07:54

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/134 [^]
(0123933)
hgbot (developer)
2020-10-26 07:54

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal [^]
Changeset: 3340ca66a2f70831f432cba81b325110785fa3df
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2020-10-23T08:39:42+05:30
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/commit/3340ca66a2f70831f432cba81b325110785fa3df [^]

Fixed ISSUE-45153: Added Discount Organization Filter in Full Refresh

---
M src/org/openbravo/retail/posterminal/master/Discount.java
---

- Issue History
Date Modified Username Field Change
2020-09-28 15:57 cbrazier New Issue
2020-09-28 15:57 cbrazier Assigned To => Retail
2020-09-28 15:57 cbrazier Triggers an Emergency Pack => No
2020-09-28 16:17 rafaroda Tag Attached: NOR
2020-09-28 16:17 rafaroda Relationship added related to 0044662
2020-09-28 16:18 rafaroda Relationship added related to 0045154
2020-09-28 16:18 rafaroda Relationship added related to 0045155
2020-09-28 16:20 rafaroda Priority normal => urgent
2020-09-28 16:20 rafaroda Severity critical => major
2020-09-29 07:53 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2020-10-01 08:02 ranjith_qualiantech_com Status new => scheduled
2020-10-01 12:58 hgbot Note Added: 0123479
2020-10-05 11:42 rafaroda Relationship added related to 0045188
2020-10-08 06:57 hgbot Note Added: 0123609
2020-10-09 08:33 hgbot Note Added: 0123643
2020-10-09 08:33 hgbot Note Added: 0123644
2020-10-09 08:34 marvintm Status scheduled => resolved
2020-10-09 08:34 marvintm Fixed in Version => RR21Q1
2020-10-09 08:34 marvintm Resolution open => fixed
2020-10-09 08:34 marvintm Review Assigned To => marvintm
2020-10-09 08:34 marvintm Status resolved => closed
2020-10-12 12:36 hgbot Note Added: 0123662
2020-10-20 10:32 hgbot Note Added: 0123797
2020-10-20 10:32 hgbot Note Added: 0123798
2020-10-22 02:50 hgbot Note Added: 0123829
2020-10-22 16:33 rafaroda Note Added: 0123880
2020-10-22 16:33 rafaroda Status closed => new
2020-10-22 16:33 rafaroda Resolution fixed => open
2020-10-22 16:33 rafaroda Fixed in Version RR21Q1 =>
2020-10-26 06:04 ranjith_qualiantech_com Status new => scheduled
2020-10-26 06:07 hgbot Note Added: 0123911
2020-10-26 07:54 hgbot Note Added: 0123932
2020-10-26 07:54 hgbot Resolution open => fixed
2020-10-26 07:54 hgbot Status scheduled => closed
2020-10-26 07:54 hgbot Fixed in Version => RR21Q1
2020-10-26 07:54 hgbot Note Added: 0123933
2021-06-29 16:43 guillermogil Relationship added related to 0047288


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker