Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0044735
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorhave not tried2020-07-31 14:182020-08-06 11:14
ReportershuehnerView Statuspublic 
Assigned Toshuehner 
PrioritynormalResolutionfixedFixed in VersionRR20Q4
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0044735: Jar library mobile-test/lib/google/transaction-api-1.1.jar causes split package with java system image

DescriptionThat jar file causes split package against java system image which is forbidden since Java9.

Found collisions in transaction-api-1.1.jar; Collides with packages:['javax.transaction.xa']

Full details on split package are explained in tracking issue
https://issues.openbravo.com/view.php?id=44733 [^]
Steps To Reproducei.e. use jar-collision-finder script pointed to in tracking issue 44733
Proposed Solution- Remove that jar file or replace with version not having the problem
- Check and update google client libraries to latest versions which may (or not) have that problem already resolved.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0044764RR20Q4 scheduledRetail Retail Modules Jar library mobile-test/lib/google/transaction-api-1.1.jar causes split package with java system image 
blocks design defect 0044733 newplatform Openbravo ERP Tracking issue: Find and fix all jar libaries with split packages between classpath and system image (Forbidden since Java9) 
Not all the children of this issue are yet resolved or closed.

-  Notes
(0121814)
hgbot (developer)
2020-08-04 17:07

Merge Request created: https://gitlab.com/openbravo/ci/mobile-test/-/merge_requests/20 [^]
(0121873)
hgbot (developer)
2020-08-06 11:12

Repository: https://gitlab.com/openbravo/ci/mobile-test [^]
Changeset: b00c5af3f02aa26fb9f06d8feee6b2ef7d07d302
Author: Stefan Huehner <stefan.huehner@openbravo.com>
Date: 2020-08-06T09:12:42+00:00
URL: https://gitlab.com/openbravo/ci/mobile-test/-/commit/b00c5af3f02aa26fb9f06d8feee6b2ef7d07d302 [^]

ISSUE-44735: Remove transaction-api jar file as causes split package
problem.

The jar file causes split package situation with jdk system image.

As it is unclear if it is really required remove it to check behavior
in try-retail.

---
M .classpath
M mobile-test.iml
R lib/google/transaction-api-1.1.jar
---
(0121874)
hgbot (developer)
2020-08-06 11:12

Merge request merged: https://gitlab.com/openbravo/ci/mobile-test/-/merge_requests/20 [^]

- Issue History
Date Modified Username Field Change
2020-07-31 14:18 shuehner New Issue
2020-07-31 14:18 shuehner Assigned To => Retail
2020-07-31 14:18 shuehner Triggers an Emergency Pack => No
2020-07-31 14:18 shuehner Relationship added blocks 0044733
2020-08-04 17:07 hgbot Note Added: 0121814
2020-08-06 11:12 hgbot Note Added: 0121873
2020-08-06 11:12 hgbot Note Added: 0121874
2020-08-06 11:14 marvintm Status new => scheduled
2020-08-06 11:14 marvintm Assigned To Retail => shuehner
2020-08-06 11:14 marvintm Status scheduled => resolved
2020-08-06 11:14 marvintm Fixed in Version => RR20Q4
2020-08-06 11:14 marvintm Resolution open => fixed
2020-08-06 11:14 marvintm Review Assigned To => marvintm
2020-08-06 11:14 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker