Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0044729
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2020-07-31 06:492020-08-05 15:23
ReporterrafarodaView Statuspublic 
Assigned Toprakashmurugesan88 
PrioritynormalResolutionfixedFixed in VersionRR20Q4
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0044729: WebPOS freeze while showing the Loading screen in case of connection lost during the BusinessPartner or BPLocation request

DescriptionWhen a ticket is opened USING REMOTE CUSTOMERS = Y, 3 requests are done:
1) One to PaidReceipts to retrieve the information of the ticket
2) One to BusinessPartner to retrieve the information of the customer
3) One to BPLocation to retrieve the ifnormation of the customer location

If the connection is lost during the PaidReceipts request, the system is able to recover gracefully.

But if the connection is lost during the BusinessPartner or BPLocation requests, the WebPOS will freeze while showing the Loading screen.
Steps To ReproduceEnable Remote for Customer Preference to Y

Open a Ticket using Open Receipts and turn of the connection.
Proposed SolutionFix the behavior on BusinessPartner and BPLocation requests
TagsNOR
Attached Files file icon jira-generated-image-static-6a1056f9-96cf-4c1b-b448-c6b2299d794a [^] (75,663 bytes) 2020-07-31 06:49 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0121778)
hgbot (developer)
2020-08-04 09:50

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/42 [^]
(0121779)
hgbot (developer)
2020-08-04 09:51

Merge Request created: https://gitlab.com/openbravo/product/unsupported/modules/org.openbravo.retail.restaurantmanagement/-/merge_requests/1 [^]
(0121860)
hgbot (developer)
2020-08-05 15:23

Repository: https://gitlab.com/openbravo/product/unsupported/modules/org.openbravo.retail.restaurantmanagement [^]
Changeset: 0f9b9c7f84c8204fb412b999af0397a405e7a724
Author: Prakash <prakash@qualiantech.com>
Date: 2020-08-03T18:12:54+05:30
URL: https://gitlab.com/openbravo/product/unsupported/modules/org.openbravo.retail.restaurantmanagement/-/commit/0f9b9c7f84c8204fb412b999af0397a405e7a724 [^]

Related to BUG-44729 : Loading screen freezes when connection is lost during the BusinessPartner or BPLocation request

* When loading receipt with remote for customer = 'Y' and connection is lost during the BusinessPartner or BPLocation request, Loading screen freezes
* This is because process loadPaidReceipts and newPaidReceipt are pending to be finished.
* Fixed by adding error callback in case of errors, where pending process are finished

* Included error callback in restaurantmanagement as well

---
M web/org.openbravo.retail.restaurantmanagement/js/components/tableloaderview.js
M web/org.openbravo.retail.restaurantmanagement/js/components/tablesview.js
---
(0121861)
hgbot (developer)
2020-08-05 15:23

Merge request merged: https://gitlab.com/openbravo/product/unsupported/modules/org.openbravo.retail.restaurantmanagement/-/merge_requests/1 [^]

- Issue History
Date Modified Username Field Change
2020-07-31 06:49 rafaroda New Issue
2020-07-31 06:49 rafaroda Assigned To => Retail
2020-07-31 06:49 rafaroda File Added: jira-generated-image-static-6a1056f9-96cf-4c1b-b448-c6b2299d794a
2020-07-31 06:49 rafaroda Triggers an Emergency Pack => No
2020-07-31 06:49 rafaroda Tag Attached: NOR
2020-08-03 09:04 prakashmurugesan88 Assigned To Retail => prakashmurugesan88
2020-08-03 15:25 prakashmurugesan88 Status new => scheduled
2020-08-04 09:50 hgbot Note Added: 0121778
2020-08-04 09:51 hgbot Note Added: 0121779
2020-08-05 15:23 hgbot Note Added: 0121860
2020-08-05 15:23 hgbot Note Added: 0121861
2020-08-05 15:23 marvintm Status scheduled => resolved
2020-08-05 15:23 marvintm Fixed in Version => RR20Q4
2020-08-05 15:23 marvintm Resolution open => fixed
2020-08-05 15:23 marvintm Review Assigned To => marvintm
2020-08-05 15:23 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker