Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0044607
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2020-07-13 21:482020-08-03 12:56
ReportergsuarezView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR20Q4
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toadrianromero
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0044607: Removed product category from tab Filter Product Categories

DescriptionWhen you remove a product from tab product in assortment window, and refresh the tab Filter Product Categories you can see that product category was removed
Steps To Reproduce1- see in tab Filter Product Categories in assortment that exist the category Backpacks & Travel
2- See in webpos that you can filter for this product category.
3- Remove any product from tab product with this product category.
4- Refresh the tab Filter Product Categories an see that product category Backpacks & Travel was removed
5- Clean cache in webpos and you can see that you can't filter from this product category because it dissapeared from webpos
TagsNo tags attached.
Attached Filespng file icon Selection_009.png [^] (86,844 bytes) 2020-07-13 21:50


png file icon Selection_010.png [^] (144,329 bytes) 2020-07-13 21:50


png file icon Selection_011.png [^] (135,817 bytes) 2020-07-13 21:51


png file icon FilterProductCategories_Before.png [^] (105,352 bytes) 2020-07-13 21:51


png file icon FilterProductCategories_After.png [^] (99,772 bytes) 2020-07-13 21:52

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0121745)
hgbot (developer)
2020-08-03 08:07

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/40 [^]
(0121762)
hgbot (developer)
2020-08-03 12:55

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/40 [^]
(0121763)
hgbot (developer)
2020-08-03 12:55

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal [^]
Changeset: 2874f44e10aa01a790a113d3fd7fe0a81ac46f0e
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2020-08-03T08:32:26+05:30
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/commit/2874f44e10aa01a790a113d3fd7fe0a81ac46f0e [^]

Fixed ISSUE-44607: Updated EventHandler to Save Assortment Product Category
* When Assortment product is updated/deleted, Assortment Product Category should be updated based on product count

---
M src/org/openbravo/retail/posterminal/event/ProductListEventHandler.java
---
(0121764)
adrianromero (manager)
2020-08-03 12:56

Verified

- Issue History
Date Modified Username Field Change
2020-07-13 21:48 gsuarez New Issue
2020-07-13 21:48 gsuarez Assigned To => Retail
2020-07-13 21:48 gsuarez Triggers an Emergency Pack => No
2020-07-13 21:50 gsuarez File Added: Selection_009.png
2020-07-13 21:50 gsuarez File Added: Selection_010.png
2020-07-13 21:51 gsuarez File Added: Selection_011.png
2020-07-13 21:51 gsuarez File Added: FilterProductCategories_Before.png
2020-07-13 21:52 gsuarez File Added: FilterProductCategories_After.png
2020-07-30 13:30 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2020-08-03 08:07 hgbot Note Added: 0121745
2020-08-03 08:08 ranjith_qualiantech_com Status new => scheduled
2020-08-03 12:55 hgbot Resolution open => fixed
2020-08-03 12:55 hgbot Status scheduled => resolved
2020-08-03 12:55 hgbot Note Added: 0121762
2020-08-03 12:55 hgbot Fixed in Version => RR20Q4
2020-08-03 12:55 hgbot Note Added: 0121763
2020-08-03 12:56 adrianromero Review Assigned To => adrianromero
2020-08-03 12:56 adrianromero Note Added: 0121764
2020-08-03 12:56 adrianromero Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker