Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0044064
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. Platformminorhave not tried2020-05-14 13:352020-10-30 07:54
ReporteralostaleView Statuspublic 
Assigned Tocberner 
PrioritynormalResolutionfixedFixed in VersionPR21Q1
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0044064: Raise minimum stack Java version to JDK11

DescriptionRaise minimum stack Java version to JDK11
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0038675 closedalostale Openbravo ERP Raise minimum stack Java version to Java 8 
depends on design defect 0044733 closedplatform Openbravo ERP Tracking issue: Find and fix all jar libaries with split packages between classpath and system image (Forbidden since Java9) 
has duplicate feature request 0044624 closedplatform Openbravo ERP Remove Java 8 JDK Support and raise stack to Java 11 
has duplicate feature request 0043719 closedplatform Openbravo ERP increase minimum supported JDK to 11 
related to defect 0043251 closedplatform Openbravo ERP Aplcation not compiling in eclipse with java 11 
related to defect 0045274 closedcberner Retail Modules hwmanager Raise minimum supported version from Java 8 to Java 11 
blocks design defect 0039262 closedalostale Openbravo ERP Deprecation warnings on cmdline with java10 compiling src-test 
blocks feature request 0045347 newplatform Openbravo ERP remove Apache HttpClient dependency 

-  Notes
(0123523)
hgbot (developer)
2020-10-05 10:33

Merge Request created: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/191 [^]
(0123586)
hgbot (developer)
2020-10-07 10:16

Merge Request created: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/195 [^]
(0123587)
hgbot (developer)
2020-10-07 10:16

Merge request closed: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/191 [^]
(0123744)
hgbot (developer)
2020-10-16 12:48

Merge Request created: https://gitlab.com/openbravo/product/dbsm/-/merge_requests/16 [^]
(0123968)
hgbot (developer)
2020-10-28 10:15

Merge request merged: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/195 [^]
(0123969)
hgbot (developer)
2020-10-28 10:15

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/openbravo [^]
Changeset: 71d1708f188676b20de186f203611a2c6553780c
Author: Cristian Berner <cristian.berner@openbravo.com>
Date: 2020-10-28T10:01:44+01:00
URL: https://gitlab.com/openbravo/product/openbravo/-/commit/71d1708f188676b20de186f203611a2c6553780c [^]

Fixed FR-44064: Unsupport Java 8 and raise minimum supported version to Java 11

---
A lib/runtime/ecj-4.17.jar
A src/org/openbravo/erpReports/jasperreports.properties
M .classpath.template
M .settings/org.eclipse.jdt.core.prefs
M build.xml
M config/eclipse/Openbravo-eclipse-prefs.epf
M legal/Licensing.txt
M src-test/src/org/openbravo/test/reporting/JasperReportsCompilation.java
M src/build.xml
R lib/runtime/jdt-compiler-4.4.2.jar
---
(0123970)
hgbot (developer)
2020-10-28 10:15

Repository: https://gitlab.com/openbravo/product/dbsm [^]
Changeset: b29e07c38da77df170392aae07fcf5ee33727e45
Author: Cristian Berner <cristian.berner@openbravo.com>
Date: 2020-10-28T10:06:48+01:00
URL: https://gitlab.com/openbravo/product/dbsm/-/commit/b29e07c38da77df170392aae07fcf5ee33727e45 [^]

Related to ISSUE-44064: Raise minimum Java version from 1.8 to 11

---
M build.xml
---
(0123971)
hgbot (developer)
2020-10-28 10:15

Merge request merged: https://gitlab.com/openbravo/product/dbsm/-/merge_requests/16 [^]
(0123974)
hgbot (developer)
2020-10-28 12:00

Repository: https://gitlab.com/openbravo/tools/platform/dependencies [^]
Changeset: 104c545d006b344b11e95c7bf4f95210e28fd777
Author: Cristian Berner <cristian.berner@openbravo.com>
Date: 2020-10-28T11:57:57+01:00
URL: https://gitlab.com/openbravo/tools/platform/dependencies/-/commit/104c545d006b344b11e95c7bf4f95210e28fd777 [^]

Related to ISSUE-44064: Specify ECJ library version (4.17) used by Jasper

JasperReports has a dependency with ECJ but the version is lower than
the one present in core(4.3.1 instead of 4.17). This adds it as another
dependency to explicitly have the version present in core.

---
M build.gradle
---
(0124031)
hgbot (developer)
2020-10-30 07:54

Repository: https://gitlab.com/openbravo/product/openbravo [^]
Changeset: 25426aae9d26242908856ea1ee018a265f44075c
Author: Asier Lostalé <asier.lostale@openbravo.com>
Date: 2020-10-30T07:53:44+01:00
URL: https://gitlab.com/openbravo/product/openbravo/-/commit/25426aae9d26242908856ea1ee018a265f44075c [^]

fixed ISSUE-39262: deprecation warnings on cli with jdk11 compiling src-test

Those warnings were caused by the usage of Field.isAccessible API which
was deprecated in JDK9. Now that minimum JDK has been raised to 11 by
FR-44064, it is possible to use Field.canAccess API, which was introduced
in JDK9, to replace the former.

---
M modules/org.openbravo.base.weld/src-test/org/openbravo/base/weld/test/ParameterCdiTestRule.java
M modules/org.openbravo.client.application/src-test/org/openbravo/client/application/test/DisplayLogicAtServerLevelTest.java
M src-test/src/org/openbravo/test/base/HiddenObjectHelper.java
---

- Issue History
Date Modified Username Field Change
2020-05-14 13:35 alostale New Issue
2020-05-14 13:35 alostale Assigned To => platform
2020-05-14 13:35 alostale Modules => Core
2020-05-14 13:35 alostale Triggers an Emergency Pack => No
2020-05-14 13:35 alostale Relationship added related to 0038675
2020-05-18 08:28 alostale Relationship added related to 0043251
2020-10-05 10:05 cberner Relationship added depends on 0044733
2020-10-05 10:06 cberner Relationship added has duplicate 0044624
2020-10-05 10:33 hgbot Note Added: 0123523
2020-10-07 10:16 hgbot Note Added: 0123586
2020-10-07 10:16 hgbot Note Added: 0123587
2020-10-16 12:48 hgbot Note Added: 0123744
2020-10-21 10:59 cberner Assigned To platform => cberner
2020-10-22 10:20 cberner Relationship added related to 0045274
2020-10-28 10:15 hgbot Resolution open => fixed
2020-10-28 10:15 hgbot Status new => closed
2020-10-28 10:15 hgbot Note Added: 0123968
2020-10-28 10:15 hgbot Fixed in Version => PR21Q1
2020-10-28 10:15 hgbot Note Added: 0123969
2020-10-28 10:15 hgbot Note Added: 0123970
2020-10-28 10:15 hgbot Note Added: 0123971
2020-10-28 12:00 hgbot Note Added: 0123974
2020-10-28 13:46 alostale Relationship added has duplicate 0043719
2020-10-28 13:47 alostale Relationship added blocks 0039262
2020-10-30 07:54 hgbot Note Added: 0124031
2020-10-30 14:14 alostale Relationship added blocks 0045347


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker