Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0044056
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Selfcheckoutmajoralways2020-05-13 17:342020-05-25 08:28
ReporterLeyreView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityimmediateResolutionfixedFixed in VersionRR20Q3
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0044056: If printer is not connected, ask for receipt page will jump to technical error page

DescriptionIf printer is not connected, ask for receipt page will jump to technical error page
Steps To Reproduce1) Configure a Hardware URL for a SCO terminal in the Backend.

2) With the printer not connected, open the previous Terminal in SCO mode:
https://livebuilds.openbravo.com/retail_modules_pgsql_pi/web/org.openbravo.retail.posterminal/?terminal=SCO-1#retail.selfcheckout [^]

3) Add a product -> Finish and pay -> Continue -> Credit Card Print ask -> Pay

4) "Technical error" page is displayed.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0120011)
hgbot (developer)
2020-05-19 05:43

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 02ad73639e8d55940940299ac6a6a661db3e4db9
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue May 19 09:13:17 2020 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/02ad73639e8d55940940299ac6a6a661db3e4db9 [^]

Related to issue-44056 : Added validation to show Welcome Message in OBPOS_PostSyncReceipt hook

* Added Print Welcome function for Global Access

---
M web/org.openbravo.retail.posterminal/js/data/dataordersave.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-print.js
---
(0120012)
hgbot (developer)
2020-05-19 06:13

Repository: erp/pmods/org.openbravo.retail.selfcheckout
Changeset: a6c647f8be5f87565844b874f770a2eb6af18ea6
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue May 19 09:42:45 2020 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.selfcheckout/rev/a6c647f8be5f87565844b874f770a2eb6af18ea6 [^]

Related to issue-44056 : Show Welcome message in Thankyou Screen

* Welcome Message should be shown in Thankyou Step instead of PrintReceipt step
  because when closing the receipt, Welcome Message was shown in OBPOS_PostSyncReceipt hook.
  So Updated hook args showWelcomeMessage as false for not showing message in the hook
* Reeipt Print timeout exceeds, it should be moved to Thankyou step instead of Start Step

---
M src/org/openbravo/retail/selfcheckout/SCOComponentProvider.java
M web/org.openbravo.retail.selfcheckout/source/actions/doPrintResult.js
M web/org.openbravo.retail.selfcheckout/source/actions/doThankYou.js
M web/org.openbravo.retail.selfcheckout/source/steps/receiptPrint.js
M web/org.openbravo.retail.selfcheckout/source/utils/scoUtils.js
A web/org.openbravo.retail.selfcheckout/source/hooks/postSyncReceipt.js
---

- Issue History
Date Modified Username Field Change
2020-05-13 17:34 Leyre New Issue
2020-05-13 17:34 Leyre Assigned To => Retail
2020-05-13 17:34 Leyre Triggers an Emergency Pack => No
2020-05-14 09:55 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2020-05-19 05:43 hgbot Checkin
2020-05-19 05:43 hgbot Note Added: 0120011
2020-05-19 06:13 hgbot Checkin
2020-05-19 06:13 hgbot Note Added: 0120012
2020-05-19 06:16 ranjith_qualiantech_com Status new => scheduled
2020-05-19 14:11 ranjith_qualiantech_com Status scheduled => resolved
2020-05-19 14:11 ranjith_qualiantech_com Resolution open => fixed
2020-05-25 08:28 marvintm Review Assigned To => marvintm
2020-05-25 08:28 marvintm Status resolved => closed
2020-05-25 08:28 marvintm Fixed in Version => RR20Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker