Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043998
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2020-05-08 10:272020-05-19 12:22
ReporteravicenteView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR20Q3
StatusclosedFix in branchFixed in SCM revision58db2d4c2546
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - Confirmed Stable
Regression date2019-04-15
Regression introduced in releaseRR19Q3
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/4ca429490a1f [^]
Triggers an Emergency PackNo
Summary

0043998: After delete a ticket, the product category chosen previously is not reset

DescriptionAfter delete a ticket, the product category chosen previously is not reset.

The behaviour has change at least from 19Q4.4, See videos:

19Q2.3
https://drive.google.com/file/d/1NEz4fIHTcBCvKjMeYmQDM512nrroqNir/view [^]
19Q4.4
https://drive.google.com/file/d/1NEz4fIHTcBCvKjMeYmQDM512nrroqNir/view [^]
Steps To Reproduce19Q4.4
https://drive.google.com/file/d/1NEz4fIHTcBCvKjMeYmQDM512nrroqNir/view [^]
Proposed Solutionreset product category filter after delete a ticket.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0044081RR20Q2 closedranjith_qualiantech_com After delete a ticket, the product category chosen previously is not reset 
depends on backport 0044082RR20Q1.2 closedranjith_qualiantech_com After delete a ticket, the product category chosen previously is not reset 
depends on backport 0044083RR19Q4.5 resolvedranjith_qualiantech_com After delete a ticket, the product category chosen previously is not reset 

-  Notes
(0119958)
hgbot (developer)
2020-05-18 08:54

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 58db2d4c2546d5f32e334f7398a74a166896f1d6
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon May 18 12:23:59 2020 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/58db2d4c2546d5f32e334f7398a74a166896f1d6 [^]

Fixed issue-43998 : Reset Product Category Tree Value when deleting receipt

* When deleting the receipt, Product Category Tree Value should be reset with "All" category

---
M web/org.openbravo.mobile.core/source/retail/component/ob-retail-searchproductcharacteristic.js
---
(0119961)
marvintm (developer)
2020-05-18 11:03

Fix is correct, but at the same time, this seems to be a regression. I've tentatively created backports for it, and if confirmed we will backport it to previous releases.

- Issue History
Date Modified Username Field Change
2020-05-08 10:27 avicente New Issue
2020-05-08 10:27 avicente Assigned To => Retail
2020-05-08 10:27 avicente Triggers an Emergency Pack => No
2020-05-12 12:25 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2020-05-18 08:54 hgbot Checkin
2020-05-18 08:54 hgbot Note Added: 0119958
2020-05-18 08:54 hgbot Status new => resolved
2020-05-18 08:54 hgbot Resolution open => fixed
2020-05-18 08:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/58db2d4c2546d5f32e334f7398a74a166896f1d6 [^]
2020-05-18 11:02 marvintm Status resolved => new
2020-05-18 11:02 marvintm Resolution fixed => open
2020-05-18 11:02 marvintm Status new => scheduled
2020-05-18 11:03 marvintm Status scheduled => resolved
2020-05-18 11:03 marvintm Fixed in Version => RR20Q3
2020-05-18 11:03 marvintm Resolution open => fixed
2020-05-18 11:03 marvintm Review Assigned To => marvintm
2020-05-18 11:03 marvintm Note Added: 0119961
2020-05-18 11:03 marvintm Status resolved => closed
2020-05-19 12:22 ranjith_qualiantech_com Regression level => Production - Confirmed Stable
2020-05-19 12:22 ranjith_qualiantech_com Regression date => 2019-04-15
2020-05-19 12:22 ranjith_qualiantech_com Regression introduced in release => RR19Q3
2020-05-19 12:22 ranjith_qualiantech_com Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/4ca429490a1f [^]


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker