Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043917
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2020-04-30 16:502020-05-05 11:41
ReporterLeyreView Statuspublic 
Assigned Tocberner 
PriorityimmediateResolutionfixedFixed in VersionPR20Q3
StatusclosedFix in branchFixed in SCM revision085530872a7f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-06-17
Regression introduced in release3.0PR19Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/a82f9a0e813e [^]
Triggers an Emergency PackNo
Summary

0043917: Filtering in the grid is not working properly using the keybord

DescriptionWhen filtering in the grid on a window configured with lazy filtering, it is needed to click 2 times the intro key to apply the filtering. In previous releases pressing intro only once after fill the value on the filter the filtering was being applied.
Steps To ReproduceBackend as system admin:
1. Open the "Grid Configuration at Window/Tab/Field level" window.
2. Add a record:
   2.1. Tab: Header - Sales Invoice
   2.2. Lazy Filtering on Grid = Yes
3. Logout/login

4. Open the "Sales invoice" window
5. Fill the date field by typing "29-04-2020"
6. Click "enter" on the keyboard -> the filter does not work the first time
7. Click "enter" a second time on the keyboard -> the filter works correctly the second time.

-> This worked correctly in 19Q2.3 version

-> This started working incorrectly in 19Q3.3 version
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00439333.0PR20Q2 closedcberner Filtering in the grid is not working properly using the keybord 
depends on backport 00439343.0PR20Q1.2 closedcberner Filtering in the grid is not working properly using the keybord 
depends on backport 00439353.0PR19Q4.5 closedcberner Filtering in the grid is not working properly using the keybord 
caused by defect 0041076 closedcaristu With Lazy Filtering Date filters are not applied after the value is formatted, you should change to another field 

-  Notes
(0119554)
hgbot (developer)
2020-05-05 10:53

Repository: erp/devel/pi
Changeset: 085530872a7f33f404444effbd6a956c1366f4fd
Author: Cristian Berner <cristian.berner <at> openbravo.com>
Date: Mon May 04 14:41:06 2020 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/085530872a7f33f404444effbd6a956c1366f4fd [^]

Fixes ISSUE-43917: Filter by single date with lazy filtering on first enter

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-minidaterange.js
---
(0119561)
caristu (developer)
2020-05-05 10:56

Reviewed + tested OK.

MR: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/68 [^]

- Issue History
Date Modified Username Field Change
2020-04-30 16:50 Leyre New Issue
2020-04-30 16:50 Leyre Assigned To => platform
2020-04-30 16:50 Leyre Modules => Core
2020-04-30 16:50 Leyre Triggers an Emergency Pack => No
2020-04-30 17:45 egoitz Priority urgent => immediate
2020-05-04 10:48 Leyre Steps to Reproduce Updated View Revisions
2020-05-04 11:33 Leyre Summary Registry filter problem in different windows using the "enter" key => Filtering in the grid is not working properly using the keybord
2020-05-04 11:33 Leyre Description Updated View Revisions
2020-05-04 12:39 cberner Assigned To platform => cberner
2020-05-04 12:57 cberner Regression level => Production - Confirmed Stable
2020-05-04 12:57 cberner Regression date => 2018-06-17
2020-05-04 12:57 cberner Regression introduced in release => 3.0PR19Q3
2020-05-04 12:57 cberner Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/a82f9a0e813e [^]
2020-05-04 13:02 alostale Relationship added caused by 0041076
2020-05-04 19:07 cberner Review Assigned To => caristu
2020-05-05 10:53 hgbot Checkin
2020-05-05 10:53 hgbot Note Added: 0119554
2020-05-05 10:53 hgbot Status new => resolved
2020-05-05 10:53 hgbot Resolution open => fixed
2020-05-05 10:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/085530872a7f33f404444effbd6a956c1366f4fd [^]
2020-05-05 10:55 caristu Status resolved => new
2020-05-05 10:55 caristu Resolution fixed => open
2020-05-05 10:55 caristu Status new => scheduled
2020-05-05 10:56 caristu Note Added: 0119561
2020-05-05 10:56 caristu Status scheduled => resolved
2020-05-05 10:56 caristu Fixed in Version => 3.0PR20Q3
2020-05-05 10:56 caristu Resolution open => fixed
2020-05-05 10:56 caristu Status resolved => closed
2020-05-05 11:41 caristu Relationship added depends on 0043935


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker