Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043852
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminorrandom2020-04-24 05:102020-07-01 09:47
Reporterranjith_qualiantech_comView Statuspublic 
Assigned Toprakashmurugesan88 
PrioritynormalResolutionopenFixed in Version
StatusnewFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0043852: Test fails randomly in try-retail

DescriptionRandom Error occurs in tests in try-retail module suites

junit.framework.AssertionFailedError: (2) errors in the browser log:
[2020-04-22T00:11:46+0000] [SEVERE] http://127.0.0.1/try-ret-modules-pgsql-suite2/org.openbravo.mobile.core.service.jsonrest/org.openbravo.retail.posterminal.term.Terminal/%7B%22parameters%22:%7B%22terminalTime%22:%222020-04-22T00:11:46.540Z%22,%22terminalTimeOffset%22:%7B%22value%22:0,%22type%22:%22long%22%7D%7D,%22terminalName%22:%22YS-11%22,%22appName%22:%22WebPOS%22,%22timeout%22:15000%7D [^] - Failed to load resource: the server responded with a status of 401 (401)
[2020-04-22T00:11:46+0000] [SEVERE] http://127.0.0.1/try-ret-modules-pgsql-suite2/org.openbravo.mobile.core.service.jsonrest/org.openbravo.retail.discounts.category.term.DiscountCategory/%7B%22terminalName%22:%22YS-11%22,%22appName%22:%22WebPOS%22,%22timeout%22:15000%7D [^] - Failed to load resource: the server responded with a status of 401 (401)

    at org.openbravo.test.mobile.core.selenium.SeleniumHelper.saveLog(SeleniumHelper.java:379)
    at org.openbravo.test.mobile.core.selenium.SeleniumHelper.saveLog(SeleniumHelper.java:318)
    at org.openbravo.test.mobile.core.selenium.SeleniumHelper.executeJavascript(SeleniumHelper.java:450)
    at org.openbravo.test.mobile.core.selenium.SeleniumHelper.executeScriptWithReturn(SeleniumHelper.java:426)
    at org.openbravo.test.mobile.retail.mobilecore.javascript.SynchronizationMonitor$2.until(SynchronizationMonitor.java:66)
    at org.openbravo.test.mobile.core.utils.OBWait.<init>(OBWait.java:61)
    at org.openbravo.test.mobile.retail.mobilecore.javascript.SynchronizationMonitor$2.<init>(SynchronizationMonitor.java:63)
    at org.openbravo.test.mobile.retail.mobilecore.javascript.SynchronizationMonitor.waitUntiTheApplicationHasSynchronized(SynchronizationMonitor.java:63)
    at org.openbravo.test.mobile.retail.mobilecore.javascript.TestRegistryHelper.forceRefresh(TestRegistryHelper.java:69)
    at org.openbravo.test.mobile.retail.mobilecore.javascript.TestRegistryHelper.waitForPopupToUpdate(TestRegistryHelper.java:88)
    at org.openbravo.test.mobile.retail.mobilecore.javascript.EnyoNode.checkIfItsAPopup(EnyoNode.java:638)
    at org.openbravo.test.mobile.retail.mobilecore.javascript.EnyoNode.isReady(EnyoNode.java:224)
    at org.openbravo.test.mobile.retail.mobilecore.intuitive.IntuitiveCommandsMobileCore$8.until(IntuitiveCommandsMobileCore.java:630)
    at org.openbravo.test.mobile.core.utils.OBWait.<init>(OBWait.java:61)
    at org.openbravo.test.mobile.core.utils.OBWait.<init>(OBWait.java:35)
    at org.openbravo.test.mobile.retail.mobilecore.intuitive.IntuitiveCommandsMobileCore$8.<init>(IntuitiveCommandsMobileCore.java:621)
    at org.openbravo.test.mobile.retail.mobilecore.intuitive.IntuitiveCommandsMobileCore.firstOf(IntuitiveCommandsMobileCore.java:621)
    at org.openbravo.test.mobile.retail.extmodules.selenium.terminals.WebPOSExtModulesTerminalHelper.postLogInActions(WebPOSExtModulesTerminalHelper.java:89)
    at org.openbravo.test.mobile.retail.mobilecore.selenium.terminals.MobileCoreTerminalHelper.loginInPostUserActions(MobileCoreTerminalHelper.java:452)
    at org.openbravo.test.mobile.retail.mobilecore.selenium.terminals.MobileCoreTerminalHelper.logIn(MobileCoreTerminalHelper.java:398)
    at org.openbravo.test.mobile.retail.mobilecore.selenium.terminals.MobileCoreTerminalHelper.logIn(MobileCoreTerminalHelper.java:392)
    at org.openbravo.test.mobile.retail.pack.selenium.terminals.WebPOSTerminalHelper.logIn(WebPOSTerminalHelper.java:352)
    at org.openbravo.test.mobile.retail.mobilecore.selenium.terminals.MobileCoreTerminalHelper.logIn(MobileCoreTerminalHelper.java:388)
    at org.openbravo.test.mobile.retail.mobilecore.selenium.terminals.MobileCoreTerminalHelper.before(MobileCoreTerminalHelper.java:296)
    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
Steps To ReproduceRandom Error occurs in tests in try-retail module suites
https://ci.openbravo.com/job/try-ret-modules-pgsql-suite2/10417/ [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0044176 closedprakashmurugesan88 VerifyReload automated test failed randomly in try 

-  Notes
(0119654)
ranjith_qualiantech_com (developer)
2020-05-07 12:03

Failing test "ActiveDiscountsPopupAddProductAndPay" is the first test of the suite.
Request for Class Terminal and DiscountCategory returns 401 error.
Finding the possible cause of the issue is difficult.
(0119781)
migueldejuana (developer)
2020-05-12 15:13

The issue not resolved and we are not going to work on it for now
(0121109)
hgbot (developer)
2020-06-26 11:56

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 99e430fb31fd0b8122455f684007ff25a444b8d9
Author: Prakash M <prakash <at> qualiantech.com>
Date: Fri Jun 26 15:25:48 2020 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/99e430fb31fd0b8122455f684007ff25a444b8d9 [^]

Related to BUG-43852: Added logs to debug the try error

---
M src/org/openbravo/mobile/core/utils/OBMOBCUtils.java
---

- Issue History
Date Modified Username Field Change
2020-04-24 05:10 ranjith_qualiantech_com New Issue
2020-04-24 05:10 ranjith_qualiantech_com Assigned To => ranjith_qualiantech_com
2020-04-24 05:10 ranjith_qualiantech_com Triggers an Emergency Pack => No
2020-05-07 11:32 ranjith_qualiantech_com Steps to Reproduce Updated View Revisions
2020-05-07 12:03 ranjith_qualiantech_com Note Added: 0119654
2020-05-11 08:20 ranjith_qualiantech_com Status new => scheduled
2020-05-11 08:21 ranjith_qualiantech_com Status scheduled => resolved
2020-05-11 08:21 ranjith_qualiantech_com Resolution open => fixed
2020-05-12 15:13 migueldejuana Note Added: 0119781
2020-05-12 15:13 migueldejuana Status resolved => new
2020-05-12 15:13 migueldejuana Resolution fixed => open
2020-05-30 09:40 prakashmurugesan88 Relationship added related to 0044176
2020-06-26 11:56 hgbot Checkin
2020-06-26 11:56 hgbot Note Added: 0121109
2020-07-01 09:47 ranjith_qualiantech_com Assigned To ranjith_qualiantech_com => prakashmurugesan88


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker