Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043672
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminoralways2020-04-06 11:562020-04-17 12:38
ReportercaristuView Statuspublic 
Assigned ToSandrahuguet 
PriorityhighResolutionfixedFixed in VersionRR20Q3
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0043672: API change: Repackage ReturnReason class

DescriptionThe ReturnReason class has been repackaged from org.openbravo.retail.posterminal.master.ReturnReason to org.openbravo.retail.posterminal.term.ReturnReason

This is because it is not a model but a terminal property. Also its extension property has been renamed to follow the standard convention: returnReasonPropertyExtension constant is now RETURNREASONPROPERTYEXTENSION
Steps To Reproduce,
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0043657 closedSandrahuguet Masterdata IndexedDB - Phase 1 

-  Notes
(0118983)
caristu (developer)
2020-04-06 12:04

Repository: retail/api-checks-retail
Changeset: 6784f352d855faa5bef38d82a805fc2a5673b820
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Mon Apr 06 11:31:31 2020 +0200
URL: http://code.openbravo.com/retail/api-checks-retail/rev/6784f352d855faa5bef38d82a805fc2a5673b820 [^] [^]

Fixed issue 43672. Repackage ReturnReason class

---
M java/reference/java.japi.gz
---

- Issue History
Date Modified Username Field Change
2020-04-06 11:56 caristu New Issue
2020-04-06 11:56 caristu Assigned To => Retail
2020-04-06 11:56 caristu Triggers an Emergency Pack => No
2020-04-06 11:56 caristu Issue generated from 0043655
2020-04-06 11:56 caristu Relationship added related to 0043657
2020-04-06 11:57 caristu Description Updated View Revisions
2020-04-06 11:57 caristu Description Updated View Revisions
2020-04-06 12:03 caristu Status new => acknowledged
2020-04-06 12:03 caristu Status acknowledged => scheduled
2020-04-06 12:04 caristu Note Added: 0118983
2020-04-06 12:04 caristu Status scheduled => resolved
2020-04-06 12:04 caristu Resolution open => fixed
2020-04-06 16:03 Sandrahuguet Assigned To Retail => Sandrahuguet
2020-04-07 11:46 Sandrahuguet Review Assigned To => marvintm
2020-04-17 12:38 marvintm Status resolved => closed
2020-04-17 12:38 marvintm Fixed in Version => RR20Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker