Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043404
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2020-03-03 13:502020-03-06 15:07
Reporterinigo_lergaView Statuspublic 
Assigned Toinigo_lerga 
PrioritynormalResolutionfixedFixed in Version3.0PR20Q2
StatusclosedFix in branchFixed in SCM revisionef59a5ef2626
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0043404: Apply new HQL Style in UOMConversionEventHandler.java

DescriptionUOMConversionEventHandler.java has one HQL query with:
- the HQL is hard to read because of formatting
- and it is mixing txt and i.e PROPERTY_ID constant which is not recommended by default
Steps To Reproduce-
Proposed SolutionFollow new format as in http://wiki.openbravo.com/wiki/HQL_Coding_Conventions [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0041287 acknowledgedplatform Tracking issue: Convert HQL to apply new style 

-  Notes
(0118301)
inigo_lerga (developer)
2020-03-03 16:46

--Test Plan Mantis HQL queries--
For this query to get executed, the preference Enable UOM Management
needs to be activated.
As the F&B International Group Admin role:
  - Go to the Unit of Measure window and create a new
    record. Put any name and EDI Code desired.
    Save the record and enter the Conversion Tab.
    Create a new Conversion with any To UOM and Multiple
    Rate By values.
    Save the record.
  
  #In this moment the modified HQL is executed#
(0118405)
dmiguelez (developer)
2020-03-06 15:06

Test Plan II

Using the data created in first test plan.
Try to create another record in the Conversion Tab for the same To UOM.
The process fails because it does not allow to create more than one conversion to the same UOM
(0118406)
hgbot (developer)
2020-03-06 15:07

Repository: erp/devel/pi
Changeset: ef59a5ef2626261c33d057be6a7080381f522a90
Author: Iñigo Lerga <inigo.lerga <at> openbravo.com>
Date: Tue Mar 03 16:47:28 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ef59a5ef2626261c33d057be6a7080381f522a90 [^]

fixes BUG-43404:Applied new HQL Style

---
M src/org/openbravo/event/UOMConversionEventHandler.java
---
(0118407)
hgbot (developer)
2020-03-06 15:07

Repository: erp/devel/pi
Changeset: 60b69f08a51226aebd38f423e676ab1b4ddeb549
Author: Iñigo Lerga <inigo.lerga <at> openbravo.com>
Date: Tue Mar 03 16:54:16 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/60b69f08a51226aebd38f423e676ab1b4ddeb549 [^]

related to ISSUE-43404: Finals added

-Finals added

---
M src/org/openbravo/event/UOMConversionEventHandler.java
---
(0118408)
dmiguelez (developer)
2020-03-06 15:07

Code Review + Testing Ok

- Issue History
Date Modified Username Field Change
2020-03-03 13:50 inigo_lerga New Issue
2020-03-03 13:50 inigo_lerga Assigned To => inigo_lerga
2020-03-03 13:50 inigo_lerga Modules => Core
2020-03-03 13:50 inigo_lerga Triggers an Emergency Pack => No
2020-03-03 13:50 inigo_lerga Relationship added related to 0041287
2020-03-03 13:51 inigo_lerga Status new => scheduled
2020-03-03 16:46 inigo_lerga Note Added: 0118301
2020-03-06 15:06 dmiguelez Note Added: 0118405
2020-03-06 15:07 hgbot Checkin
2020-03-06 15:07 hgbot Note Added: 0118406
2020-03-06 15:07 hgbot Status scheduled => resolved
2020-03-06 15:07 hgbot Resolution open => fixed
2020-03-06 15:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ef59a5ef2626261c33d057be6a7080381f522a90 [^]
2020-03-06 15:07 hgbot Checkin
2020-03-06 15:07 hgbot Note Added: 0118407
2020-03-06 15:07 dmiguelez Review Assigned To => dmiguelez
2020-03-06 15:07 dmiguelez Note Added: 0118408
2020-03-06 15:07 dmiguelez Status resolved => closed
2020-03-06 15:07 dmiguelez Fixed in Version => 3.0PR20Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker