Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043376
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2020-02-28 13:252020-03-06 13:17
Reporterinigo_lergaView Statuspublic 
Assigned Toinigo_lerga 
PrioritynormalResolutionfixedFixed in Version3.0PR20Q2
StatusclosedFix in branchFixed in SCM revisioncb0899b44c4d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0043376: Apply new HQL Style in CashVATUtil.java

DescriptionCashVATUtil.java has three HQL queries with:
- the HQL is hard to read because of formatting
- and it is mixing txt and i.e PROPERTY_ID constant which is not recommended by default
Steps To Reproduce-
Proposed SolutionFollow new format as in http://wiki.openbravo.com/wiki/HQL_Coding_Conventions [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0041287 acknowledgedplatform Tracking issue: Convert HQL to apply new style 

-  Notes
(0118230)
inigo_lerga (developer)
2020-03-02 10:28
edited on: 2020-03-02 12:07

--Test Plan Mantis HQL queries--
First of all, to execute this query it is needed to
have installed the Cash VAT Management module.

As the F&B International Group Admin role:
  - Go to the Organization window and enter the
    "F&B US, Inc." record. Open its Information Tab
    line and check the Cash VAT checkbox.
  - Go to the Tax Rate window and create a new record
    with "F&B US, Inc." as Business Partner, any name
    and rate desired. Put any previous day before today as
    the Valid From Date field.
    Check the Cash VAT checkbox and save the record.
  - Go now to the Sales Invoice window and create a
    new record with "F&B US, Inc." as Organization and
    "Healthy Food Supermarkets, Co." as Business Partner.
    Go to the Lines Tab and create a new one with
    "Cola" as Product and 10 units in Invoiced Quantity.
    Select the previosly created Tax Rate in the Tax field.
  - Go back to the Sales Invoice Header and press the Complete
    button and OK button in the popup window.
    Press the Add Payment button and Done button in the popup
    window.
  
  #In this moment two of the modified HQLs are executed#

  - Press the Post button and OK button in the popup window.

  #In this moment the last modified HQL is executed#

(0118372)
hgbot (developer)
2020-03-06 13:16

Repository: erp/devel/pi
Changeset: cb0899b44c4dc4bf61b305086eaa2e816cddb16b
Author: Iñigo Lerga <inigo.lerga <at> openbravo.com>
Date: Mon Mar 02 10:46:16 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/cb0899b44c4dc4bf61b305086eaa2e816cddb16b [^]

fixes BUG-43376:Applied new HQL Style

---
M src/org/openbravo/erpCommon/utility/CashVATUtil.java
---
(0118373)
hgbot (developer)
2020-03-06 13:16

Repository: erp/devel/pi
Changeset: bbf99091e921244a3333e13ae53fe1b1c6879125
Author: Iñigo Lerga <inigo.lerga <at> openbravo.com>
Date: Mon Mar 02 12:09:24 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/bbf99091e921244a3333e13ae53fe1b1c6879125 [^]

related to ISSUE-43376: Applied Sonarlint suggestions and more

-Finals added
-Sonarlint suggestions applied

---
M src/org/openbravo/erpCommon/utility/CashVATUtil.java
---
(0118374)
hgbot (developer)
2020-03-06 13:16

Repository: erp/devel/pi
Changeset: 298670191d095316dd461841de5562bc33b0d29f
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Fri Mar 06 12:50:32 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/298670191d095316dd461841de5562bc33b0d29f [^]

Related to ISSUE-43376. Code Review changes:
Retrieve first the query into an object and then do the !list.isEmpty() comparison.
The reason for this change is to make more obvius the list empty comparison
while reading the code.

---
M src/org/openbravo/erpCommon/utility/CashVATUtil.java
---
(0118375)
dmiguelez (developer)
2020-03-06 13:17

Code Review + Testing Ok

- Issue History
Date Modified Username Field Change
2020-02-28 13:25 inigo_lerga New Issue
2020-02-28 13:25 inigo_lerga Assigned To => inigo_lerga
2020-02-28 13:25 inigo_lerga Modules => Core
2020-02-28 13:25 inigo_lerga Triggers an Emergency Pack => No
2020-02-28 13:25 inigo_lerga Status new => scheduled
2020-03-02 10:28 inigo_lerga Note Added: 0118230
2020-03-02 12:07 inigo_lerga Note Edited: 0118230 View Revisions
2020-03-02 12:13 inigo_lerga Relationship added related to 0041287
2020-03-06 13:16 hgbot Checkin
2020-03-06 13:16 hgbot Note Added: 0118372
2020-03-06 13:16 hgbot Status scheduled => resolved
2020-03-06 13:16 hgbot Resolution open => fixed
2020-03-06 13:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/cb0899b44c4dc4bf61b305086eaa2e816cddb16b [^]
2020-03-06 13:16 hgbot Checkin
2020-03-06 13:16 hgbot Note Added: 0118373
2020-03-06 13:16 hgbot Checkin
2020-03-06 13:16 hgbot Note Added: 0118374
2020-03-06 13:17 dmiguelez Review Assigned To => dmiguelez
2020-03-06 13:17 dmiguelez Note Added: 0118375
2020-03-06 13:17 dmiguelez Status resolved => closed
2020-03-06 13:17 dmiguelez Fixed in Version => 3.0PR20Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker