Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043284
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2020-02-20 15:362020-03-02 16:22
Reporterinigo_lergaView Statuspublic 
Assigned Toinigo_lerga 
PrioritynormalResolutionfixedFixed in Version3.0PR20Q2
StatusclosedFix in branchFixed in SCM revision3f0ef21fd46d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0043284: Apply new HQL Style in DocMovement.java

DescriptionDocMovement.java has one HQL query with:
- the HQL is hard to read because of formatting
- and it is mixing txt and i.e PROPERTY_ID constant which is not recommended by default
Steps To Reproduce-
Proposed SolutionFollow new format as in http://wiki.openbravo.com/wiki/HQL_Coding_Conventions [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0041287 acknowledgedplatform Tracking issue: Convert HQL to apply new style 

-  Notes
(0118256)
dmiguelez (developer)
2020-03-02 16:19

Log in as F&B Admin

Go to Goods Movement Window and create a new record with:
* Organization: F&B US
Move to the lines and create a new record with:
* Product: Ale Beer
* Movement Quantity: 100
* Storage Bin: EC-0-0-0
* New Storage Bin: EC-1-0-0
Complete the Document.
Click on Post and check that the record is posted properly.
If it fails because the cost is not calculated, launch the costing background process or wait for it to finish (it is already scheduled by default for every 5 minutes)
(0118257)
hgbot (developer)
2020-03-02 16:21

Repository: erp/devel/pi
Changeset: 3f0ef21fd46d7f5d6cd78c6ae02f2b40a6911e7f
Author: IƱigo Lerga <inigo.lerga <at> openbravo.com>
Date: Thu Feb 20 16:53:42 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/3f0ef21fd46d7f5d6cd78c6ae02f2b40a6911e7f [^]

fixes BUG-43284:Applied new HQL Style

---
M src/org/openbravo/erpCommon/ad_forms/DocMovement.java
---
(0118258)
hgbot (developer)
2020-03-02 16:21

Repository: erp/devel/pi
Changeset: bfe8bc743d4fe472a9707c438e11b1317856ee13
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Mon Mar 02 16:21:01 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/bfe8bc743d4fe472a9707c438e11b1317856ee13 [^]

Related to ISSUE-43284. Removes obsolete comment.

---
M src/org/openbravo/erpCommon/ad_forms/DocMovement.java
---
(0118259)
dmiguelez (developer)
2020-03-02 16:22

Code Review + Testing Ok

- Issue History
Date Modified Username Field Change
2020-02-20 15:36 inigo_lerga New Issue
2020-02-20 15:36 inigo_lerga Assigned To => inigo_lerga
2020-02-20 15:36 inigo_lerga Modules => Core
2020-02-20 15:36 inigo_lerga Triggers an Emergency Pack => No
2020-02-20 15:36 inigo_lerga Status new => scheduled
2020-02-20 15:36 inigo_lerga Relationship added related to 0041287
2020-03-02 16:19 dmiguelez Note Added: 0118256
2020-03-02 16:21 hgbot Checkin
2020-03-02 16:21 hgbot Note Added: 0118257
2020-03-02 16:21 hgbot Status scheduled => resolved
2020-03-02 16:21 hgbot Resolution open => fixed
2020-03-02 16:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3f0ef21fd46d7f5d6cd78c6ae02f2b40a6911e7f [^]
2020-03-02 16:21 hgbot Checkin
2020-03-02 16:21 hgbot Note Added: 0118258
2020-03-02 16:22 dmiguelez Review Assigned To => dmiguelez
2020-03-02 16:22 dmiguelez Note Added: 0118259
2020-03-02 16:22 dmiguelez Status resolved => closed
2020-03-02 16:22 dmiguelez Fixed in Version => 3.0PR20Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker