Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043272
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2020-02-19 17:462020-02-28 07:49
ReportershuehnerView Statuspublic 
Assigned Tocberner 
PrioritynormalResolutionfixedFixed in Version3.0PR20Q2
StatusclosedFix in branchFixed in SCM revision33db07200942
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2019-11-28
Regression introduced in releasemain
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/c47b63fff5775ab73ce8072af4fa6fd6c13d197e [^]
Triggers an Emergency PackNo
Summary

0043272: When importing translation for no longer existing elements -> INFO message is missing all necessary details

DescriptionWhen importing translation values from a translation pack it can happen that the original row to be translated does no longer exist.

In that case a message is shown like the following:
     [java] 36825 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE AD_TEXTINTERFACES_Trl SET Text='Sous-total de la Grille',Updated=now(),IsTranslated='Y' WHERE AD_TEXTINTERFACES_ID='508174CC5C8C4E4B90AF19C2FE2A5B40' AND AD_Language='fr_FR' AND AD_Client_ID='0'

showing which translation is not finding its row to update.
Note that message is INFO level only as that is info useful to maintainer of the translation but not a problem for the user of the translation pack.

That message is now broken in pi as it looks like:
     [java] 35685 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - update AD_TEXTINTERFACES_Trl set Text=?,Updated=now() ,IsTranslated=? where AD_TEXTINTERFACES_ID=? and AD_Language=? and AD_Client_ID=?

That is side-effect of improving the code to use SQL bind-parameters.
The values interesting to print are now parameter-values but the code is only printing the sql-string
Steps To ReproduceInstall a translation having at least 1 trl value for which the original row does no longer exist.
Review the 'Not Found' to notice all reference to the element are missing
Proposed Solution-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00433173.0PR20Q1 closedcberner When importing translation for no longer existing elements -> INFO message is missing all necessary details 
caused by defect 0041942 closedcberner Apply new HQL Style to platform classes 
related to defect 0043686 closedcberner TranslationHandler shows INFO of not found after each ERROR 
related to defect 0043687 closedcberner TranslationHandler does not cancel on first exception and makes more transactions 
causes defect 0043685 closedcberner Re-add exception message when error importing translations 

-  Notes
(0118072)
hgbot (developer)
2020-02-25 09:20

Repository: erp/devel/pi
Changeset: 33db07200942157629e9ab28df79b49bfb675960
Author: Cristian Berner <cristian.berner <at> openbravo.com>
Date: Mon Feb 24 17:13:12 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/33db07200942157629e9ab28df79b49bfb675960 [^]

Fixes ISSUE-43272: Info message on importing missing translation shows params

---
M src/org/openbravo/erpCommon/ad_forms/TranslationHandler.java
---
(0118093)
cberner (developer)
2020-02-25 12:38

Reviewed in MR: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/46 [^]
(0118193)
alostale (developer)
2020-02-28 07:49

reviewed

- Issue History
Date Modified Username Field Change
2020-02-19 17:46 shuehner New Issue
2020-02-19 17:46 shuehner Assigned To => platform
2020-02-19 17:46 shuehner Modules => Core
2020-02-19 17:46 shuehner Regression level => Packaging and release
2020-02-19 17:46 shuehner Regression date => 2019-11-28
2020-02-19 17:46 shuehner Regression introduced in release => main
2020-02-19 17:46 shuehner Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/c47b63fff5775ab73ce8072af4fa6fd6c13d197e [^]
2020-02-19 17:46 shuehner Triggers an Emergency Pack => No
2020-02-19 17:47 shuehner Relationship added caused by 0041942
2020-02-19 19:00 cberner Assigned To platform => cberner
2020-02-21 08:09 alostale Severity major => minor
2020-02-25 09:20 hgbot Checkin
2020-02-25 09:20 hgbot Note Added: 0118072
2020-02-25 09:20 hgbot Status new => resolved
2020-02-25 09:20 hgbot Resolution open => fixed
2020-02-25 09:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/33db07200942157629e9ab28df79b49bfb675960 [^]
2020-02-25 09:52 cberner Note Added: 0118083
2020-02-25 09:52 cberner Status resolved => new
2020-02-25 09:52 cberner Resolution fixed => open
2020-02-25 09:56 cberner Status new => scheduled
2020-02-25 09:58 cberner Status scheduled => resolved
2020-02-25 09:58 cberner Resolution open => fixed
2020-02-25 12:37 cberner Note Deleted: 0118083
2020-02-25 12:38 cberner Note Added: 0118093
2020-02-28 07:49 alostale Review Assigned To => alostale
2020-02-28 07:49 alostale Note Added: 0118193
2020-02-28 07:49 alostale Status resolved => closed
2020-02-28 07:49 alostale Fixed in Version => 3.0PR20Q2
2020-04-07 09:32 cberner Relationship added causes 0043685
2020-04-07 09:36 cberner Relationship added related to 0043686
2020-04-07 09:42 cberner Relationship added related to 0043687


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker