Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043265
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2020-02-19 13:562020-03-02 12:40
Reporterinigo_lergaView Statuspublic 
Assigned Toinigo_lerga 
PrioritynormalResolutionfixedFixed in Version3.0PR20Q2
StatusclosedFix in branchFixed in SCM revision845e19484c1b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0043265: Apply new HQL Style in SL_ProductPrice_PriceListVersion.java

DescriptionSL_ProductPrice_PriceListVersion.java has one HQL query with:
- the HQL is hard to read because of formatting
- and it is mixing txt and i.e PROPERTY_ID constant which is not recommended by default
Steps To Reproduce-
Proposed SolutionFollow new format as in http://wiki.openbravo.com/wiki/HQL_Coding_Conventions [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0041287 acknowledgedplatform Tracking issue: Convert HQL to apply new style 

-  Notes
(0118243)
hgbot (developer)
2020-03-02 12:40

Repository: erp/devel/pi
Changeset: 845e19484c1bdbd0c84192baf10e622c02fa8a43
Author: IƱigo Lerga <inigo.lerga <at> openbravo.com>
Date: Thu Feb 20 11:44:47 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/845e19484c1bdbd0c84192baf10e622c02fa8a43 [^]

fixes BUG-43265:Applied new HQL Style + finals added

---
M src/org/openbravo/erpCommon/ad_callouts/SL_ProductPrice_PriceListVersion.java
---
(0118244)
dmiguelez (developer)
2020-03-02 12:40

Code Review + Testing ok

- Issue History
Date Modified Username Field Change
2020-02-19 13:56 inigo_lerga New Issue
2020-02-19 13:56 inigo_lerga Assigned To => inigo_lerga
2020-02-19 13:56 inigo_lerga Modules => Core
2020-02-19 13:56 inigo_lerga Triggers an Emergency Pack => No
2020-02-19 13:57 inigo_lerga Relationship added related to 0041287
2020-02-19 14:15 inigo_lerga Status new => scheduled
2020-03-02 12:40 hgbot Checkin
2020-03-02 12:40 hgbot Note Added: 0118243
2020-03-02 12:40 hgbot Status scheduled => resolved
2020-03-02 12:40 hgbot Resolution open => fixed
2020-03-02 12:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/845e19484c1bdbd0c84192baf10e622c02fa8a43 [^]
2020-03-02 12:40 dmiguelez Review Assigned To => dmiguelez
2020-03-02 12:40 dmiguelez Note Added: 0118244
2020-03-02 12:40 dmiguelez Status resolved => closed
2020-03-02 12:40 dmiguelez Fixed in Version => 3.0PR20Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker