Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043044
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2020-01-29 10:212020-02-07 10:48
Reporterinigo_lergaView Statuspublic 
Assigned Toinigo_lerga 
PrioritynormalResolutionfixedFixed in Version3.0PR20Q2
StatusclosedFix in branchFixed in SCM revision93e16fd2b918
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0043044: Apply new HQL Style in CostingAlgorithmAdjustmentImp.java

DescriptionCostingAlgorithmAdjustmentImp.java has two HQL queries with:
- the HQL is hard to read because of formatting
- and it is mixing txt and i.e PROPERTY_ID constant which is not recommended by default
Steps To Reproduce-
Proposed SolutionFollow new format as in http://wiki.openbravo.com/wiki/HQL_Coding_Conventions [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0041287 acknowledgedplatform Tracking issue: Convert HQL to apply new style 
related to defect 0043061 closedinigo_lerga Private functions not locally used in CostingAlgorithmAdjustmentImp.java 

-  Notes
(0117324)
inigo_lerga (developer)
2020-01-29 15:18

Test Plan Mantis HQL queries:
Execute the TestCosting.java JUnit tests.
#In this moment all the modified HQLs are executed#
(0117548)
hgbot (developer)
2020-02-07 10:46

Repository: erp/devel/pi
Changeset: 93e16fd2b91833d4868763128b4297a4dbc4d853
Author: IƱigo Lerga <inigo.lerga <at> openbravo.com>
Date: Wed Jan 29 15:55:25 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/93e16fd2b91833d4868763128b4297a4dbc4d853 [^]

fixes BUG-43044:New HQL Style + minor Sonarlint suggestions

---
M src/org/openbravo/costing/CostingAlgorithmAdjustmentImp.java
---
(0117549)
hgbot (developer)
2020-02-07 10:46

Repository: erp/devel/pi
Changeset: 130c190966f38597a1773763e3470aa7f549f3a7
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Fri Feb 07 10:46:06 2020 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/130c190966f38597a1773763e3470aa7f549f3a7 [^]

Related to ISSUE-43044. Code Review Changes:
  * Changed variable names to better reflect that they are referring to
    id's and not to the objects
  * Use id in hql query instead of object
  * In swithc-case statement, remove added breaks, as they were altering
    the originally intended logic

---
M src/org/openbravo/costing/CostingAlgorithmAdjustmentImp.java
---
(0117550)
dmiguelez (developer)
2020-02-07 10:48

Code Review + Testing ok

- Issue History
Date Modified Username Field Change
2020-01-29 10:21 inigo_lerga New Issue
2020-01-29 10:21 inigo_lerga Assigned To => inigo_lerga
2020-01-29 10:21 inigo_lerga Modules => Core
2020-01-29 10:21 inigo_lerga Triggers an Emergency Pack => No
2020-01-29 10:21 inigo_lerga Relationship added related to 0041287
2020-01-29 11:03 inigo_lerga Status new => acknowledged
2020-01-29 11:03 inigo_lerga Status acknowledged => scheduled
2020-01-29 15:18 inigo_lerga Note Added: 0117324
2020-01-30 09:49 inigo_lerga Relationship added related to 0043061
2020-02-07 10:46 hgbot Checkin
2020-02-07 10:46 hgbot Note Added: 0117548
2020-02-07 10:46 hgbot Status scheduled => resolved
2020-02-07 10:46 hgbot Resolution open => fixed
2020-02-07 10:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/93e16fd2b91833d4868763128b4297a4dbc4d853 [^]
2020-02-07 10:46 hgbot Checkin
2020-02-07 10:46 hgbot Note Added: 0117549
2020-02-07 10:48 dmiguelez Review Assigned To => dmiguelez
2020-02-07 10:48 dmiguelez Note Added: 0117550
2020-02-07 10:48 dmiguelez Status resolved => closed
2020-02-07 10:48 dmiguelez Fixed in Version => 3.0PR20Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker