Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0042919
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Analyticsmajoralways2020-01-16 17:402020-01-31 08:52
Reportersalvador_campanellaView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision674120c39d4c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Tocaristu
Regression introduced in release
Summary

0042919: Export Analytics reports on PDF doesn't work

DescriptionExport Analytics reports on PDF doesn't work
Steps To Reproduce- Install Analytics module
- Install Legacy FOP support module
- Rebuild
- Enter in OB analytics
- Select a cube a generate a report
- Click on Export PDF button

Result:" An unexpected error has occurred"

In openbravo.log:

2020-01-24 09:14:02,226 [http-nio-8282-exec-1] ERROR org.openbravo.dal.core.ThreadHandler - Exception thrown org/mozilla/javascript/Scriptable
org.openbravo.base.exception.OBException: Exception thrown org/mozilla/javascript/Scriptable
    ...
Caused by: java.lang.NoClassDefFoundError: org/mozilla/javascript/Scriptable
    at org.saiku.web.export.PdfReport.generateContentAsHtmlString(PdfReport.java:178) ~[saiku-web-3.7.4.jar:?]
    at org.saiku.web.export.PdfReport.populatePdf(PdfReport.java:153) ~[saiku-web-3.7.4.jar:?]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0039983 closedjarmendariz Openbravo ERP Upgrade javascript linter and formatter 
related to design defect 0040535 closedalostale Openbravo ERP old callouts should use OBScriptEngine to evaluate response 

-  Notes
(0117216)
alostale (developer)
2020-01-24 09:43

MR: https://gitlab.com/openbravo/product/pmods/org.openbravo.client.analytics/merge_requests/1 [^]
(0117232)
hgbot (developer)
2020-01-24 12:45

Repository: erp/pmods/org.openbravo.client.analytics
Changeset: 674120c39d4c258357cba42eb53243df481a9502
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jan 24 09:37:20 2020 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/674120c39d4c258357cba42eb53243df481a9502 [^]

fixed ISSUE-42919: can't export to pdf

  Starting from 19Q3 it was not possible to export to pdf (having fop
  support module) because Saiku makes use of rhino js engine which was
  removed from core's classpath.

  It has now been added to the classpath as a copy of lib/build/js.jar.

---
M legal/Licensing.txt
A lib/runtime/js.jar
---
(0117233)
hgbot (developer)
2020-01-24 12:45

Repository: erp/pmods/org.openbravo.client.analytics
Changeset: 6af56131368bb0db43b20469dc56d4afc64ead24
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jan 24 09:40:44 2020 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/6af56131368bb0db43b20469dc56d4afc64ead24 [^]

related to ISSUE-42919: updated module version

---
M src-db/database/sourcedata/AD_MODULE.xml
---
(0117345)
alostale (developer)
2020-01-30 09:06

published analytics version 1.4.7000 including this fix
(0117391)
caristu (developer)
2020-01-31 08:35

Reviewed + tested OK

- Issue History
Date Modified Username Field Change
2020-01-16 17:40 salvador_campanella New Issue
2020-01-16 17:40 salvador_campanella Assigned To => platform
2020-01-16 17:40 salvador_campanella Modules => Core
2020-01-16 17:40 salvador_campanella Triggers an Emergency Pack => No
2020-01-16 17:44 Practics Issue Monitored: Practics
2020-01-24 09:15 alostale Steps to Reproduce Updated View Revisions
2020-01-24 09:16 alostale Assigned To platform => alostale
2020-01-24 09:16 alostale Relationship added related to 0039983
2020-01-24 09:17 alostale Relationship added related to 0040535
2020-01-24 09:43 alostale Status new => scheduled
2020-01-24 09:43 alostale Note Added: 0117216
2020-01-24 12:45 hgbot Checkin
2020-01-24 12:45 hgbot Note Added: 0117232
2020-01-24 12:45 hgbot Status scheduled => resolved
2020-01-24 12:45 hgbot Resolution open => fixed
2020-01-24 12:45 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/674120c39d4c258357cba42eb53243df481a9502 [^]
2020-01-24 12:45 hgbot Checkin
2020-01-24 12:45 hgbot Note Added: 0117233
2020-01-30 07:47 alostale Review Assigned To => caristu
2020-01-30 09:06 alostale Note Added: 0117345
2020-01-31 08:35 caristu Note Added: 0117391
2020-01-31 08:35 caristu Status resolved => closed
2020-01-31 08:37 caristu Project Openbravo ERP => Modules
2020-01-31 08:52 caristu Category A. Platform => Analytics
2020-01-31 08:52 caristu version pi =>


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker