Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0042167
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-10-31 12:302019-11-15 09:03
ReportermalsasuaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR20Q1
StatusclosedFix in branchFixed in SCM revisioned4d6c49f4ee
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0042167: In OrderLoader request, the timeout for the request is always 21000 millisecond

DescriptionIn the request done from POS to Backoffice with the receipt, the timeout can not be modified. It is always 21000

request executed:
https://livebuilds.openbravo.com/retail_pi_pgsql/org.openbravo.mobile.core.service.jsonrest/org.openbravo.retail.posterminal.OrderLoader?timeout=21000 [^]

Steps To Reproduce[POS]
. complete a ticket
. check the network tab in Chrome Developers tools
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0115546)
hgbot (developer)
2019-11-12 07:05

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 999fc6b605f34c396ad8d9b5ade460e2bbacdb0d
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Nov 12 11:35:41 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/999fc6b605f34c396ad8d9b5ade460e2bbacdb0d [^]

Fixed issue 42167 : Timeout is updated in dataparams and removed in url

---
M web/org.openbravo.mobile.core/source/data/ob-datasource.js
---
(0115611)
marvintm (developer)
2019-11-14 17:55

Fix is incorrect, we need the timeout in the request URL because it is used by the mechanism in backend which cancels the request early in case the timeout has already been reached
(0115616)
hgbot (developer)
2019-11-15 07:57

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: ed4d6c49f4eef9f26b99c3b3bfb84812ece4dce7
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Fri Nov 15 12:09:30 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/ed4d6c49f4eef9f26b99c3b3bfb84812ece4dce7 [^]

Fixed issue 42167 : Timeout value should be added to Request URL

---
M web/org.openbravo.mobile.core/source/data/ob-datasource.js
---

- Issue History
Date Modified Username Field Change
2019-10-31 12:30 malsasua New Issue
2019-10-31 12:30 malsasua Assigned To => Retail
2019-10-31 12:30 malsasua Resolution time => 1574204400
2019-10-31 12:30 malsasua Triggers an Emergency Pack => No
2019-11-07 11:55 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2019-11-07 15:14 ranjith_qualiantech_com Status new => scheduled
2019-11-12 07:05 hgbot Checkin
2019-11-12 07:05 hgbot Note Added: 0115546
2019-11-12 07:05 hgbot Status scheduled => resolved
2019-11-12 07:05 hgbot Resolution open => fixed
2019-11-12 07:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/999fc6b605f34c396ad8d9b5ade460e2bbacdb0d [^]
2019-11-14 17:55 marvintm Note Added: 0115611
2019-11-14 17:55 marvintm Status resolved => new
2019-11-14 17:55 marvintm Resolution fixed => open
2019-11-15 06:29 ranjith_qualiantech_com Status new => scheduled
2019-11-15 07:57 hgbot Checkin
2019-11-15 07:57 hgbot Note Added: 0115616
2019-11-15 07:57 hgbot Status scheduled => resolved
2019-11-15 07:57 hgbot Resolution open => fixed
2019-11-15 07:57 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/999fc6b605f34c396ad8d9b5ade460e2bbacdb0d [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/ed4d6c49f4eef9f26b99c3b3bfb84812ece4dce7 [^]
2019-11-15 09:03 marvintm Review Assigned To => marvintm
2019-11-15 09:03 marvintm Status resolved => closed
2019-11-15 09:03 marvintm Fixed in Version => RR20Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker