Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0042067
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2019-10-18 12:542019-12-16 12:36
ReportercbernerView Statuspublic 
Assigned Tocberner 
PriorityimmediateResolutionfixedFixed in Version3.0PR20Q1
StatusclosedFix in branchFixed in SCM revision5bbb3a83581e
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelCoding ( Testing )
Regression date2019-10-13
Regression introduced in releasepi
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/640df6f887be0f091a25bba4177800837297c8fa [^]
Triggers an Emergency PackNo
Summary

0042067: Eclipse warnings caused by javadoc changes

DescriptionJavadoc generated for entities shows errors in eclipse. Mainly @see tags with nothing linked.

A screenshot of eclipse warnings has been attached.
Steps To ReproduceOpen eclipse and build, javadoc errors will show in Markers tab.
Proposed SolutionRemove @see tag when it is not needed correctly.
TagsNo tags attached.
Attached Filespng file icon Selection_005.png [^] (165,396 bytes) 2019-10-18 12:54

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 0041629 closedcberner improve javadoc of generated entities: Include help for table and columns 

-  Notes
(0115832)
hgbot (developer)
2019-11-26 12:28

Repository: erp/devel/pi
Changeset: 5bbb3a83581ed997bebc9dca04ada45a8abb1db2
Author: Cristian Berner <cristian.berner <at> openbravo.com>
Date: Wed Oct 23 13:56:21 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5bbb3a83581ed997bebc9dca04ada45a8abb1db2 [^]

fixes issue 42067: Entity Javadoc generated now is correct and has no warnings

---
M src/org/openbravo/base/gen/entity.ftl
M src/org/openbravo/base/model/Entity.java
M src/org/openbravo/base/model/Property.java
---
(0116289)
hudsonbot (developer)
2019-12-12 23:01

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/954d2b7a66fb [^]
Maturity status: Test
(0116339)
AugustoMauch (developer)
2019-12-16 12:36

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2019-10-18 12:54 cberner New Issue
2019-10-18 12:54 cberner Assigned To => cberner
2019-10-18 12:54 cberner File Added: Selection_005.png
2019-10-18 12:54 cberner Modules => Core
2019-10-18 12:54 cberner Regression level => Coding ( Testing )
2019-10-18 12:54 cberner Regression date => 2019-10-13
2019-10-18 12:54 cberner Regression introduced in release => pi
2019-10-18 12:54 cberner Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/640df6f887be0f091a25bba4177800837297c8fa [^]
2019-10-18 12:54 cberner Triggers an Emergency Pack => No
2019-10-18 12:56 alostale Relationship added caused by 0041629
2019-10-21 10:41 cberner Status new => scheduled
2019-11-26 12:28 hgbot Checkin
2019-11-26 12:28 hgbot Note Added: 0115832
2019-11-26 12:28 hgbot Status scheduled => resolved
2019-11-26 12:28 hgbot Resolution open => fixed
2019-11-26 12:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5bbb3a83581ed997bebc9dca04ada45a8abb1db2 [^]
2019-11-29 09:57 alostale Review Assigned To => AugustoMauch
2019-12-12 23:01 hudsonbot Checkin
2019-12-12 23:01 hudsonbot Note Added: 0116289
2019-12-16 12:36 AugustoMauch Note Added: 0116339
2019-12-16 12:36 AugustoMauch Status resolved => closed
2019-12-16 12:36 AugustoMauch Fixed in Version => 3.0PR20Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker