Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0042066
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajoralways2019-10-18 12:292019-12-12 23:01
Reportersanti_lozanoView Statuspublic 
Assigned Toalostale 
PriorityhighResolutionfixedFixed in Version3.0PR20Q1
StatusclosedFix in branchFixed in SCM revisioneaa68147b81b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tojarmendariz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0042066: truncated year in date picker

DescriptionThe date selector from any field in Openbravo back office is cutting the year of the date, as seen on the image attached and explained in the steps to reproduce. In the newer version it happens as in the previous ones it doesn't happen
Steps To Reproduce*go to https://livebuilds.openbravo.com/ [^] select pgsql backend from Retail with modules section
*go to sales order, click on Show Date Chooser (column Order Date, open date selector)
*in the popup open again the date selector and see that the year of the date selector isn't being fully shown
(note that it can be reproduced from any other date selector)
TagsNo tags attached.
Attached Filespng file icon cut.png [^] (254,786 bytes) 2019-10-21 09:21

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0042105 acknowledgedplatform use CSS @font-face instead of system fonts 

-  Notes
(0115241)
santi_lozano (developer)
2019-10-23 10:32

Reproduced in Firefox version 69 and Chrome version lower than 77
(0115265)
hgbot (developer)
2019-10-24 12:54

Repository: erp/devel/pi
Changeset: eaa68147b81ba7c0ca815185a6c85ecadc09d45e
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Oct 23 10:32:17 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/eaa68147b81ba7c0ca815185a6c85ecadc09d45e [^]

fixed issue 42066: truncated year in date picker

Date picker truncates year in some browser/OS combinations.

The problem is caused by font and weight selection making year legth
longer than maximum.

Removing "bold" weight is enough to fit it.

---
M modules/org.openbravo.client.application/web/org.openbravo.userinterface.smartclient/openbravo/skins/Default/org.openbravo.client.application/ob-form-styles.css
---
(0115266)
alostale (developer)
2019-10-24 12:57

Tested with:
Chrome 78
Firefox 70
Internet Explorer 11
Edge 44

MacOSX Mojave (10.14):

Chrome 78
Firefox 70
Safari 14

Ubuntu 18.04:

Chrome 77
Firefox 69
(0116263)
hudsonbot (developer)
2019-12-12 23:01

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/954d2b7a66fb [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-10-18 12:29 santi_lozano New Issue
2019-10-18 12:29 santi_lozano Assigned To => platform
2019-10-18 12:29 santi_lozano File Added: date.JPG
2019-10-18 12:29 santi_lozano Modules => Core
2019-10-18 12:29 santi_lozano Triggers an Emergency Pack => No
2019-10-21 09:18 santi_lozano File Deleted: date.JPG
2019-10-21 09:21 santi_lozano File Added: cut.png
2019-10-23 10:32 santi_lozano Note Added: 0115241
2019-10-23 11:10 alostale Relationship added related to 0042105
2019-10-23 11:12 alostale Assigned To platform => alostale
2019-10-23 11:12 alostale Status new => acknowledged
2019-10-23 11:12 alostale Review Assigned To => jarmendariz
2019-10-24 12:54 hgbot Checkin
2019-10-24 12:54 hgbot Note Added: 0115265
2019-10-24 12:54 hgbot Status acknowledged => resolved
2019-10-24 12:54 hgbot Resolution open => fixed
2019-10-24 12:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/eaa68147b81ba7c0ca815185a6c85ecadc09d45e [^]
2019-10-24 12:57 alostale Note Added: 0115266
2019-10-24 12:57 alostale Summary Date field display is cutting the year in back office and new version of Openbravo => truncated year in date picker
2019-10-24 13:15 jarmendariz Note Added: 0115267
2019-10-24 13:15 jarmendariz Status resolved => closed
2019-10-24 13:15 jarmendariz Fixed in Version => 3.0PR20Q1
2019-10-24 13:16 jarmendariz Note Deleted: 0115267
2019-12-12 23:01 hudsonbot Checkin
2019-12-12 23:01 hudsonbot Note Added: 0116263


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker