Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041751
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2019-09-04 17:282019-09-20 13:01
ReporterucarrionView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q4
StatusclosedFix in branchFixed in SCM revision82dd9efb8ab3
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0041751: Problems to translate selector fields 'centrally maintained'

DescriptionTranslations for selector fields defined as 'centrally maintained' should be retrieved from the ad_element of their related ad_element.

Therefore, there exists triggers that detect changes done in the ad_element/ad_element_trl tables in order to properly update the labels of different application elements like parameters, selectors etc.

In the case of selector fields, this trigger is the OBUISEL_ELEMENT_TRL_TRG but it currently is not working properly.
Steps To Reproduce1) Go to the [Language] window
2) Select a language, for example Catalan (Spain). Set is as "System Language"
3) Click on "Verify Language" process to populate the _trl tables with the records to be translated to the selected language
4) Go to [Reference] window, select the "PLM Status" reference, navigate to "Defined Selector" > "Defined Selector Fields" subtab
5) Select a field, for example "Restrict Manufacture" and note that a new register exists under the "Selector Field Translation" tab
6) Edit the AD_Element related to the selector field. Following our example, go to the Element window, and look for the element with name "Restrict Manufacture"
7) Modify the translation of the element, for example by changing the name
8) Go back to the selector field and check its translation under "Selector Field Translation" tab. ERROR -> It has not changed. It should be updated with the same name set to the AD_Element
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0114601)
hgbot (developer)
2019-09-17 18:15

Repository: erp/devel/pi
Changeset: 82dd9efb8ab3609d6948bbe4ce4ef79bb403e7e8
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Sep 17 18:03:45 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/82dd9efb8ab3609d6948bbe4ce4ef79bb403e7e8 [^]

fixes bug 41751: some selector field translations not being properly updated

  The translation of the selector fields marked as centrally maintained should be kept in sync with their corresponding AD_Element translations. The OBUISEL_ELEMENT_TRL_TRG is the trigger in charge of doing this job. But due to a wrong comparison in the implementation of this trigger, no selector field was being updated after modifying its corresponding element translation.

  Fixed this issue just by doing the proper comparison with AD_Language column.

---
M modules/org.openbravo.userinterface.selector/src-db/database/model/triggers/OBUISEL_ELEMENT_TRL_TRG.xml
---
(0114643)
hudsonbot (developer)
2019-09-18 15:36

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/39a64f55bfbd [^]
Maturity status: Test
(0114692)
alostale (developer)
2019-09-20 13:01

reviewed + tested

- Issue History
Date Modified Username Field Change
2019-09-04 17:28 ucarrion New Issue
2019-09-04 17:28 ucarrion Assigned To => platform
2019-09-04 17:28 ucarrion Modules => Core
2019-09-04 17:28 ucarrion Triggers an Emergency Pack => No
2019-09-05 09:23 caristu Description Updated View Revisions
2019-09-05 09:23 caristu Steps to Reproduce Updated View Revisions
2019-09-05 09:23 caristu Proposed Solution updated
2019-09-05 09:23 caristu Severity major => minor
2019-09-05 09:28 caristu Note Added: 0114410
2019-09-17 17:22 caristu Description Updated View Revisions
2019-09-17 17:22 caristu Steps to Reproduce Updated View Revisions
2019-09-17 17:22 caristu Proposed Solution updated
2019-09-17 17:22 caristu Note Deleted: 0114410
2019-09-17 18:15 hgbot Checkin
2019-09-17 18:15 hgbot Note Added: 0114601
2019-09-17 18:15 hgbot Status new => resolved
2019-09-17 18:15 hgbot Resolution open => fixed
2019-09-17 18:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/82dd9efb8ab3609d6948bbe4ce4ef79bb403e7e8 [^]
2019-09-17 18:16 caristu Review Assigned To => alostale
2019-09-17 18:16 caristu Assigned To platform => caristu
2019-09-18 15:36 hudsonbot Checkin
2019-09-18 15:36 hudsonbot Note Added: 0114643
2019-09-20 13:01 alostale Note Added: 0114692
2019-09-20 13:01 alostale Status resolved => closed
2019-09-20 13:01 alostale Fixed in Version => 3.0PR19Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker