Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041747
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2019-09-04 12:152019-09-10 10:29
Reportersalvador_campanellaView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q4
StatusclosedFix in branchFixed in SCM revision5879f2488432
ProjectionnoneETAnoneTarget Versionpi
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR19Q3SCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2019-04-26
Regression introduced in release3.0PR19Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/cbb150e17b8b69ad6f243c526ba64ef744ed8ba2 [^]
Triggers an Emergency PackNo
Summary

0041747: Negative values have string format when they are exported to csv file

DescriptionWhen the data of any grid is exported as csv using the button "Export to Spreadsheet" the negative values have a prefix "tabulation Character" this produces that the spreadsheet program format the field as text. This causes that these values don't be used to do autosum or in formulas.

Also, if the spreadsheet program has the tab character as separator the field with negative value have a shift to the right column

This prefix character was introduced in the issue
https://issues.openbravo.com/view.php?id=40647 [^]
Steps To Reproduce- Export any grid than contains negative values
- Open the CSV file with a spreadsheet program

a.- Leave the tab character selected as a separator
- Result all the values negatives will be a shift to the right column

b.- Deselect the tab character
- Do an Autosum with all the column that contains negative values
- Save the value
- Edit any negative value erasing the tab character
- Do the autosum again
- Result if different.
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2019-09-04 12-03-00.png [^] (24,753 bytes) 2019-09-04 12:15


png file icon Screenshot from 2019-09-04 12-04-12.png [^] (12,856 bytes) 2019-09-04 12:15

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00417543.0PR19Q3.1 closedalostale Negative values have string format when they are exported to csv file 
caused by defect 0040647 closedalostale escape formulas when exporting csv 

-  Notes
(0114405)
hgbot (developer)
2019-09-05 08:47

Repository: erp/devel/pi
Changeset: 5879f2488432819dc36b197421e94aca5f804314
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Sep 05 08:47:04 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5879f2488432819dc36b197421e94aca5f804314 [^]

fixed bug 41747: negative numeric values exported as string in csv

  Whenever a value is exported to csv, it is prepended a tab if it starts with
  any character that can be used for formulas (issue 0040647) in order to prevent
  formula injection. This causes negative numeric values to be also escaped being
  treated as strings.

  Numeric values don't require to be escaped at all as they are cannot be crafted
  for formula injection.

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/DataSourceServlet.java
---
(0114427)
hudsonbot (developer)
2019-09-05 18:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/494bf1e23c6a [^]
Maturity status: Test
(0114486)
caristu (developer)
2019-09-10 10:29

Reviewed + tested OK.

- Issue History
Date Modified Username Field Change
2019-09-04 12:15 salvador_campanella New Issue
2019-09-04 12:15 salvador_campanella Assigned To => platform
2019-09-04 12:15 salvador_campanella File Added: Screenshot from 2019-09-04 12-03-00.png
2019-09-04 12:15 salvador_campanella Modules => Core
2019-09-04 12:15 salvador_campanella Triggers an Emergency Pack => No
2019-09-04 12:15 salvador_campanella File Added: Screenshot from 2019-09-04 12-04-12.png
2019-09-04 12:18 Practics Issue Monitored: Practics
2019-09-04 12:20 Practics Issue End Monitor: Practics
2019-09-04 12:20 Practics Issue Monitored: Practics
2019-09-05 08:27 alostale Assigned To platform => alostale
2019-09-05 08:27 alostale Relationship added caused by 0040647
2019-09-05 08:30 alostale Review Assigned To => caristu
2019-09-05 08:30 alostale Regression level => Production - QA Approved
2019-09-05 08:30 alostale Regression date => 2019-04-26
2019-09-05 08:30 alostale Regression introduced in release => 3.0PR19Q3
2019-09-05 08:30 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/cbb150e17b8b69ad6f243c526ba64ef744ed8ba2 [^]
2019-09-05 08:30 alostale Priority normal => immediate
2019-09-05 08:32 alostale Status new => scheduled
2019-09-05 08:47 hgbot Checkin
2019-09-05 08:47 hgbot Note Added: 0114405
2019-09-05 08:47 hgbot Status scheduled => resolved
2019-09-05 08:47 hgbot Resolution open => fixed
2019-09-05 08:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5879f2488432819dc36b197421e94aca5f804314 [^]
2019-09-05 18:16 hudsonbot Checkin
2019-09-05 18:16 hudsonbot Note Added: 0114427
2019-09-10 10:29 caristu Note Added: 0114486
2019-09-10 10:29 caristu Status resolved => closed
2019-09-10 10:29 caristu Fixed in Version => 3.0PR19Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker